Jump to content


Photo

Stairs Problem

stairs issue

This topic has been archived. This means that you cannot reply to this topic.
9 replies to this topic

#1 skozax

skozax

    Newbie

  • Members
  • 5 posts

Posted 16 August 2012 - 06:18 AM

Hello,

I am new to this forum. I started using RPG Maker VX Ace a week ago and now I encountered this problem. I searched if it was solved already and I found similar solutions but none worked. The problem I have is with the stairs, I can't walk pass the red line (as seen on screenshot) on either way. Top-bottom, bottom-top. I would appreciate the help.

Thank You

Attached Files



#2 Domin0e

Domin0e

    Like a leaf in the wind

  • Early Adopter
  • 188 posts

Posted 16 August 2012 - 06:27 AM

Sounds like a passability issue.
Take a look at your Tileset, you might have used a second blank tile in Tiles BCDE which has it's passability not set as "above player" (star).

"Twelve highlanders and a bagpipe make a rebellion."

 

bf92a7cce0997cc0e4bad6b03f5dc.png

 

 

 


#3 skozax

skozax

    Newbie

  • Members
  • 5 posts

Posted 16 August 2012 - 06:38 AM

I went to Database -->Tilesets-->004:Dungeon-->Tab A. The stairs I used have the "O" symbol. When I try to change it it goes straight to "X" instead of star. If I understood correctly what you said. (i am still noob in rpg maker). It only goes through with "Ctrl" pressed. What do you mean by blank tile? And even if i "stretch" the stairs the same problem occurs..

Edited by skozax, 16 August 2012 - 06:39 AM.


#4 Necromus

Necromus

    Advanced Member

  • Early Adopter+
  • 297 posts

Posted 16 August 2012 - 06:45 AM

If you look at the top left tile in every other tab besides A, you most likely have a tile that is empty.
All of those need to have a star as the passability setting, else you might actually block your char from moving sometimes, and since the tile is empty you will not notice in the editor/game.
That's what Domin0e means.

#5 skozax

skozax

    Newbie

  • Members
  • 5 posts

Posted 16 August 2012 - 06:56 AM

I found it. It was "Star". When I change it to "O", I can pass but it also messes the passability on the level and I can roam free almost everywhere. Is there a way to make an exception?

#6 Necromus

Necromus

    Advanced Member

  • Early Adopter+
  • 297 posts

Posted 16 August 2012 - 07:18 AM

What was star?

Tiles in the A tab are always either O or X, O for everything you want to pass, X for everything you don't.
If you turned the empty tile i described above into O, then you might be able to go everywhere, it always needs to be star.

#7 skozax

skozax

    Newbie

  • Members
  • 5 posts

Posted 16 August 2012 - 07:34 AM

Yes, I noticed that I could go everywhere. I changed it back to "star". Is there any other way to make it work?

#8 tpasmall

tpasmall

    The Mauve Avenger

  • Early Adopter+
  • 669 posts

Posted 16 August 2012 - 08:43 AM

Check the 4-way passability. If you cant get it to work, upload a demo of the project and I'll take a look at it.

newbanner.png

editorium.png

 

RM Games I've Enjoyed:

Manifest, Forced Recall, The Cartographer, Star Stealing Prince


#9 skozax

skozax

    Newbie

  • Members
  • 5 posts

Posted 16 August 2012 - 08:55 AM

It's ok! I just changed the tiles. Thank You all very much

#10 Celianna

Celianna

    VX/Ace tileset artist

  • Global Moderators
  • 6,350 posts

Posted 16 August 2012 - 10:01 AM

The top-left tile in TileB should always be set to a star, otherwise you'll mess up the passability for all other tiles.

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

logo_dropshadow_zps9089e8b6.png
Out now!!