Comments on Profile Post by Tai_MT

  1. samkfj
    samkfj
    Sounds like a rubber gasket leak. The oil hits the engine and makes that familiar smell.
    Jan 14, 2019
    Philosophus Vagus likes this.
  2. samkfj
    samkfj
    but--I don't think that would cause shaking--unless it's a huge leak--which I hope not. Or a shifted motor mount, could be why the gasket could have failed though on account'a the motor mount.
    Jan 14, 2019
    Philosophus Vagus likes this.
  3. samkfj
    samkfj
    but I could be way off--open that sucker up and take a look, bro.
    Jan 14, 2019
    Philosophus Vagus likes this.
  4. Philosophus Vagus
    Philosophus Vagus
    That sucks, hopefully it's a simple fix and not something requiring a mechanic to look at it. I've been stuck trying to get a mechanic to change out some struts for me for two weeks now; makes me want to just invest in a lift...but where the hell would I put a lift?
    Jan 14, 2019
  5. Tai_MT
    Tai_MT
    I have no idea what it may be. I went through the Owner's Manual and it says that if the Check Engine light is on, but it's not flashing and not red, that is' some sort of problem with the exhaust efficiency thing or something... And that can cause shaking or misfiring...
    Jan 14, 2019
  6. Tai_MT
    Tai_MT
    I talked to my mom and she was telling me that it's probably just time for me to get a new car. That I got my $3000 out of this one (I've had it 8 years). So, I'll check my accounts and see what kind of money I have in order to see if I can afford another cheap little car, maybe. There goes the money I was saving for a house. :(
    Jan 14, 2019