RPG Maker Forums

ShadowHawkDragon
ShadowHawkDragon
Can you download the Executioner Battler I released just last week and check to see if that has the same problem.

There's a setting on my side that 'may' be responsible for this. However as I don't have the MZ plugin I can't test for myself.

I know the latest battlers are correct, so if they do work then that'll confirm that I need to update the older battlers, if not then there's nothing I can do on my side.
Dope
Ooooh I get to bug test! Will do. Gimme a sec, I'll update this post once I check.

Edit:

Just checked. If you're talking about the Executioner Temple and Executioner Grave then they're working as I initially described. Great work on those too btw, they'll work nicely for my game.
ShadowHawkDragon
ShadowHawkDragon
can you test one of the three flownnon battlers or one of the centipedes too? just to make sure
ShadowHawkDragon
ShadowHawkDragon
So I can safely say that the executioners have the same mistake, my bad for asking you to test them. Turns out I changed them after release...

I have dug into the raw data of the .json files and can confirm that the flownnons and centipedes do have the correct setting.

But again I can't say for sure if this setting is in fact the issue.
Dope
I thought I tested all the battlers and had the same results. I'll check the flower cannons and centipedes again though to be sure.
Dope
Yeah, had the same result. Don't stress yourself over it though, get to it when you get to it. I'll still be using it as is for now. I'm also happy to test more stuff out if you want in the future. The battlers work, they just don't start moving until they're attacked or they attack. Not ideal, but not game breaking either. As far as alpha/beta dev goes, I call that a success. Cheers!
ShadowHawkDragon
ShadowHawkDragon
Thanks for testing them, you have helped me confirm that the "default animation" setting doesn't actually make a difference.

The problem then is more likely to be on the plugin's side of things, I'd recommend checking the instructions again and trying the plugins out in a fresh project in case there's a compatibility conflict. Otherwise you may want to contact visustella.
  • Like
Reactions: Dope
Dope
Cool. I use some battlers from Ækashics too but those were designed for MZ. I'll take a look at how those are setup and see if I can't get those settings to work with yours. Thanks for the help, keep up the work!
ShadowHawkDragon
ShadowHawkDragon
Theoretically it shouldn't matter what they were designed for as they are made in the same program, if Ækashics' battlers work in the same project that does imply that something is wrong with my battlers.

Can you send me the note tags you are using for my battlers? I'll check if there's anything obvious
Dope
Well, the way you and Ækashics have things setup are different. I can just drop your battlers in the game, name it and go. With Ækashics, I have to use additional code or the battlers just idle.

For yours I literally just name them and move on. So for example, <Dragonbones Battler: WingedSerpentHellviper> and done.
Dope
I couldn't even post the notes for Ækashics because it's too long but basically I have to put the full dragonbones settings (height, scale, ani wait/walk, etc) in each battlers notes. I tried using those settings with your battlers but they were still static until attacking or being attacked.
ShadowHawkDragon
ShadowHawkDragon
I have updated the files for Exectutioner - Grave, can you download it again to confirm whether that fixes the issue or not.

If not there is one other thing I can try on my side but I'd rather not do it unless I have to as it breaks compatibility with MV due to MV's plugin using an earlier version of DragonBones.
Dope
Just tried it, unfortunately there is no change. As you've said, it might be an issue between different versions of DragonBones causing the problem. Kind of sucks, but at least you know for the future in case you want to make some assets tailored for MZ.
ShadowHawkDragon
ShadowHawkDragon
I've made a test version of the executioner exported as the latest version of dragonbones. If this works then we'll know its a compatibility issue, if not then I've done everything one my end I know I can do.

Dope
Hmm. Just tried this and it still started static. If I use the additional settings with this then it's actually worse and the battler remains static until defeat. Not sure what the issue could be but I'll keep playing around with it. Thanks for all your help.
ShadowHawkDragon
ShadowHawkDragon
Your welcome, sorry to say I can't help much further as it seems to be an issue on your end.

The only other thing I can think of is to manually tie each of the animations with the corresponding notetag, especially the Walk animation.

In the MV version the tag would be
<DragonBone Ani Walk: Walk>

The 'read me' files included with the downloads list all the animation names used with each battler.
ShadowHawkDragon
ShadowHawkDragon
In case you haven't come up with a solution to your battlers being static at battle start, here's something I thought of that might work as a stopgap.

You could try making a skill which targets 'all allies', give it an action sequence with the bare minimum not even damage, and have it set the targets' animation to 'Walk'

Then setup a troop event to make the first enemy cast the skill at battle start.
nemesis99
nemesis99
Hi ShadowHawkDragon, I also met this issue in MZ -- enemy battlers stay static after damaged by my character, when I tested Battlemouse(basic). Another one, MaskedDevil, are always looping damage when it takes damage and looping casting after it casts.

Latest Threads

Latest Posts

Latest Profile Posts

I feel still screenshots don't do my game justice. the characters don't move, but the filter over them does...
Wonder if this year, there be more MZ plugin than MV or that MZ is still small compare to whole MV collection
Zaj
Hey morning all! I got another quick question..I just switched to RMMZ from VX Ace..so I am wondering why default scripts(is that how u call it) of VXAce is available, but not in MZ's case? How do I figure out ahh I mean could you show me
Sometimes im the biggest fool alive... Ah well, ce la vie
The worst feeling in the world is going for a walk on a nice summer day, seeing an ice cream truck, and realizing you don't have any money with you :(

Forum statistics

Threads
111,346
Messages
1,060,375
Members
144,673
Latest member
LuCaRoCa
Top