2 different issues with Yanfly Battle Engine and Yami Battle Symphony

TimmyTheNerd

Veteran
Veteran
Joined
Aug 16, 2012
Messages
182
Reaction score
111
First Language
English
Primarily Uses
NOTE: Not having any conflict problems, the scripts are working fine together and playing nice.

For the Yanfly Battle Engine. Using version 1.22 with Enemy HP Bars version 1.10:
Okay, so I'm not using the standard iconset, but one of the ones from PVG for the High Fantasy stuff. The result is it's showing the icon for shielding against the water element, instead of a blank circle like its suppose to. How do I change the icon so it shows a blank circle, or no icon at all, if the player isn't affected by any states?

This is what I'm getting:


This is what Yanfly's page shows:


For the Yami Battle Symphony. Using version 1.16e with the Holders Battlers add-on in addition to the Vlue Set Guard/Attack Skills version 1.3:
The problem I'm having with Yami Battle Symphony is that I had to set up a skill for ranged attack characters so they don't go charging in and hitting in Melee Combat with their bows. However, whenever the character makes the attack, he doesn't gain any TP. I also made custom scripts for each type of monster attack (Blundgeon Weapons, Slashing Weapons, Piercing Weapons, Claws, Bites, Bow Attack and Magic Attack) and they're not causing any TP gain when their attacks hit. So my Archer, whose abilities are all based on TP, doesn't get to use most of his abilities during battle. What would I have to do to add TP gain? Kes was very patient and helpful when we were talking in PMs, and I tried everything he suggested. Nothing seems to be working though.

Another issue with Yanfly Battle Engine, but not really urgent. This time with how it reacts to Shaz's Super Simple Mouse System version 1.10:
The problem I'm having regarding the mouse script is that when I go to attack, I can't use the mouse to select the target and instead must change to keyboard (That lone sword in my screenshot for the other issue with the Yanfly Battle Engine is my mouse icon). Anyone know how to bring up the original target select message box for attacks or skills? If not, I'll just remove the mouse script. That way my players don't have to keep switching between mouse and keyboard.
 

Engr. Adiktuzmiko

Chemical Engineer, Game Developer, Using BlinkBoy'
Veteran
Joined
May 15, 2012
Messages
14,670
Reaction score
2,992
First Language
Tagalog
Primarily Uses
That circle is setup via an icon index that picks which icon from the iconset is to be used. Since you changed iconsets, it now shows the icon in your iconset that is found on the index set on the script. To change it, just find a new icon in your new iconset that you want to use and modify the script to use the index of that icon. If you want it blank, I believe index 0 of most iconsets is blank.


By default it uses icon in the index 185, this is the line where it's set (just find it in the config part of Battle Engine core.


BATTLESTATUS_NO_ACTION_ICON = 185 # No action icon.




Also, another note: that icon isn't a state icon, it's actually an icon to show that battler's action, if you choose a skill, it changes to the icon used by the skill chosen.
 
Last edited by a moderator:

TimmyTheNerd

Veteran
Veteran
Joined
Aug 16, 2012
Messages
182
Reaction score
111
First Language
English
Primarily Uses
Thank you. And I did not know that, nifty info.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Love it when someone confuses "RPG Maker (or script/plugin) has a bug" with "I didn't set it up right and it's not working as I want (or gives an error)"
Is animation really as hard as I think it is?
Out of sudden, snow. Everywhere.
Blech. I hate coming up with stories. Making gameplay is fun but coming up with lore and reasons for these areas/mechanics just makes me sleepy.

Forum statistics

Threads
94,575
Messages
922,009
Members
124,441
Latest member
nanaya07
Top