A very big problem

Froggo32

Villager
Member
Joined
Jul 5, 2020
Messages
23
Reaction score
6
First Language
Polish, English
Primarily Uses
RMVXA
I've made first part of my game and exported the folder so that my friends could play it. Today I've opened MV to continue making it, but what I noticed is that even if I change the last script of my game, in the playtest everything's going by the old one. I mean, when I released the game yesterday at the end of prologue the screen faded out and the game added two actors to party. But today I edited it so that the BGM would fade out alongside with the screen, all current actors would be removed and a new one would be added and then transfered to other map. But it isn't working. Does it have something with me uploading the game earlier and playing it on my computer? How do I fix it?
Here are screenshots of my script:
peoblm.pngaaa.png
 

dragoonwys

Freelance Illustrator
Veteran
Joined
Jul 26, 2016
Messages
358
Reaction score
925
First Language
english
Primarily Uses
RMMV
Looks like the map that your transfer event us supposed to lead to doesn't exist, you can see that its ?(10,7) Instead of a map name. Did you accidentally delete it?
Make sure you're not loading from a saved file too, it has to be new game.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,335
Reaction score
7,656
First Language
German
Primarily Uses
RMMV
exported the folder
here is where you made your mistake.

you must never deploy into your project folder - there are a lot of reasons why it is asking for an output folder by default, and you should not change that to your project folder.
because if you do deploy into your project, all later playtests are redirected to the deployed version instead of the project version.

you can check for that and repair it relatively easy.
go to your project folder. is there a www folder inside? if yes, then that is the reason.
the www folder is deployed version only, there must never be a www folder inside your project directory!!!

here is how to repair your project:
1) delete the www folder (that is your deployed game only)
2) make a new project if you have no undamaged project anywhere
3) copy the package.json file from an undamaged project into your damaged project, overwriting the file that is there.

now the project should be repaired and the playtest work on the project version again.
and next time you need to deploy, make sure it goes into a different output folder
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
13,522
Reaction score
14,253
First Language
English
Primarily Uses
RMVXA
Also when you save the events pick up where they left off but run the event as it was when you saved. So changed to an event in progress never register.

For that reason you need to either use a new event or use a save from before you ran that event.
 

Froggo32

Villager
Member
Joined
Jul 5, 2020
Messages
23
Reaction score
6
First Language
Polish, English
Primarily Uses
RMVXA
Ouch I created a new project and I can't get to my old one. Now the folder of my project looks like this:
(with package.json copied from new project and swapped with old one)
ararara.png
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,335
Reaction score
7,656
First Language
German
Primarily Uses
RMMV
that is the folder of a deployed project minus the www folder, not the original project where you did your work.
you need to find the project folder where you originally worked in, and navigate the editor there.

that folder should have a file named
Game.rpgproject

so I suggest you search your computer for all folders with that file.
(there should be only three files but 7 folders in there - sometimes a few more folders depending on plugins and if it is still damaged)
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

SF_Monster6 added!

Wonder when the next theme contest is coming?
Long time no see. I'm aiming a vertical slice / tech demo for my game featuring a series of boss battles this month. I hope I could get some testers.
So which forum do I use if I want to showcase graphics? I've been using AML forum, but I'm not sure it's correct.

Forum statistics

Threads
105,781
Messages
1,016,459
Members
137,482
Latest member
mentalhealthawareness
Top