kingkoopa300

Sprite Farmer
Veteran
Joined
Nov 17, 2014
Messages
46
Reaction score
11
First Language
English
what about combo with other heroes o.o

is there a way to do that Oo

hero uses one skill another hero uses one skill they both use it and the get another skill by combo Oo
Very easy to do Trial and Error my friend just keep experimenting you'll figure it out
 

tvorimvsevmeste

Villager
Member
Joined
Nov 11, 2015
Messages
26
Reaction score
3
First Language
русский
I can`t use weapons with "SV Weapon: id'' !!! ;_;  What the matter? Please help me!
 

kingkoopa300

Sprite Farmer
Veteran
Joined
Nov 17, 2014
Messages
46
Reaction score
11
First Language
English
I can`t use weapons with "SV Weapon: id'' !!! ;_;  What the matter? Please help me!
use "perform action" must have weapon equipped to show weapon...

P.S. it's kinda wrong ya asking for advice for Yanfly's here please refer to Yanfly's page for help
 
Joined
Jan 9, 2016
Messages
1
Reaction score
0
First Language
english
I'm new to this but I want to try out this plug-in but I have no clue how to download the plug-in using the coding above
 

Ghost of Christmas Kloe

The Icecream Princess
Veteran
Joined
Nov 15, 2015
Messages
1,548
Reaction score
960
First Language
English
Primarily Uses
RMMZ
I'm new to this but I want to try out this plug-in but I have no clue how to download the plug-in using the coding above
Basically take the code, paste it into a text editor (Such as Notepad) and save it as the correct file name and with the extension .js

Although you're not really meant to post this here...
 

saberw60

Warper
Member
Joined
Jun 22, 2013
Messages
3
Reaction score
0
First Language
English
Hey all,

I'm pretty new to RPG Maker MV and I decided to use this plugin for my game. I'm not using Yanfly's plugins, just this one as a standalone. It was working just fine, but the SV Battle was using the entire sprite sheet for the enemy. After tweaking it, I tried to run it again but I have an issue. The moment the battle starts, I get a black screen and "TypeError: undefined is not a function" is shown." I made sure that I named everything the same for both sv_actors and sv_enemies, but I don't know what the issue is. I do know that the issue starts up the moment I add the Sprite into the Troop section of the Database. If I don't, the battle starts, but instantly shows the victory animations without any enemies.

After testing it with the console log, I get this error: 

Playtest and Console Log:

https://gyazo.com/47e45a0f7810c3709389badb7a9c5a77

This is currently how everything is setup in the img/sv_actors and img/sv_enemies folders:

https://gyazo.com/1a9ec1917a36c0c419109502e6c7a8d7

https://gyazo.com/4b311c72ac5a849ddc219f5ddb270cdd

I'm currently using version 1.15.5.1 of the plugin.

Anyone able to tell me what I'm doing wrong?

Thanks in advance.

EDIT: Nevermind. It seems the only problem was that I had "SV Animated" in brackets. How strange. It still takes the entire sprite sheet and doesn't flip it, though.

SaberW
 
Last edited by a moderator:

Fawnzy23

Warper
Member
Joined
Jan 19, 2016
Messages
4
Reaction score
4
Primarily Uses
N/A
Could someone PLEASE clarify how this works? Because for some reason I cannot figure it out. I want a sideview bear character to use claws instead of punching its targets. I used a different plugin to make it use the sideview character, but apparently it is not compatible. So I tried using this plugins sideview command and disabling the other one, but I don't understand what is wrong. I put in the command like this:


[SV Animated]


SV Weapon: 7


And I put the sideview character file in as the exact same name as the static battler filename like the plugin told me to. I even put the file into the sv_enemies folder just to try it and that didn't work either. As for the weapon command, it is supposed to equip its claws, correct? Doesn't work either. I put it at the top of the plugin list and the bottom. Neither changed anything. PLEASE someone tell me what I am doing wrong!
 

Ghost of Christmas Kloe

The Icecream Princess
Veteran
Joined
Nov 15, 2015
Messages
1,548
Reaction score
960
First Language
English
Primarily Uses
RMMZ
Could someone PLEASE clarify how this works? Because for some reason I cannot figure it out. I want a sideview bear character to use claws instead of punching its targets. I used a different plugin to make it use the sideview character, but apparently it is not compatible. So I tried using this plugins sideview command and disabling the other one, but I don't understand what is wrong. I put in the command like this:


[SV Animated]


SV Weapon: 7


And I put the sideview character file in as the exact same name as the static battler filename like the plugin told me to. I even put the file into the sv_enemies folder just to try it and that didn't work either. As for the weapon command, it is supposed to equip its claws, correct? Doesn't work either. I put it at the top of the plugin list and the bottom. Neither changed anything. PLEASE someone tell me what I am doing wrong!

If you're using Yanfly's Sideview Enemies, its in-compatible as far as I know... Many sideview plugins aren NOT compatible with eachother, so keep this in mind! We cant fix every compatibility issue ever made... 
 

Fawnzy23

Warper
Member
Joined
Jan 19, 2016
Messages
4
Reaction score
4
Primarily Uses
N/A
If you're using Yanfly's Sideview Enemies, its in-compatible as far as I know... Many sideview plugins aren NOT compatible with eachother, so keep this in mind! We cant fix every compatibility issue ever made... 

I did have Yanflys side view plugin but I said I disabled it and it still didn't work.
 

Ghost of Christmas Kloe

The Icecream Princess
Veteran
Joined
Nov 15, 2015
Messages
1,548
Reaction score
960
First Language
English
Primarily Uses
RMMZ
I did have Yanflys side view plugin but I said I disabled it and it still didn't work.

Well I'm not exactly sure what to do to help but currently this plugin is un-suppported due to the hiatus of the OP, so I would (At least temporarily) use another plugin for now!
 

Fawnzy23

Warper
Member
Joined
Jan 19, 2016
Messages
4
Reaction score
4
Primarily Uses
N/A
Well I'm not exactly sure what to do to help but currently this plugin is un-suppported due to the hiatus of the OP, so I would (At least temporarily) use another plugin for now!

Okay, thanks for the advice. If you know about any other plugins that support enemy equipping weapons that are relatively simple to use, could you point me in that direction. I tried one other one but it seemed like a lot of work and seemed complicated.
 

Ghost of Christmas Kloe

The Icecream Princess
Veteran
Joined
Nov 15, 2015
Messages
1,548
Reaction score
960
First Language
English
Primarily Uses
RMMZ
Last edited by a moderator:

Fawnzy23

Warper
Member
Joined
Jan 19, 2016
Messages
4
Reaction score
4
Primarily Uses
N/A

Oxameter

Villager
Member
Joined
Feb 9, 2014
Messages
5
Reaction score
0
First Language
English
Primarily Uses
It doesn't work for me. I have the note on the enemy set up like so, but it doesn't show the sprite. The sprite I want is in my sv actors folder, bl1.png. Shouldn't this work? Also I don't know if static enemies need note tags to breathe, but statics don't breathe for me by default. Don't know if this is intended or not. Urgent help needed pls.


bl1.png
 
Last edited by a moderator:

Black0Seraph

Villager
Member
Joined
Nov 15, 2013
Messages
9
Reaction score
0
First Language
English
Primarily Uses
I'm having a problem....my animated battlers (enemy) is appearing in the 


middle of the screen. I don't know if I did something wrong.


Any advice is appreciated....
 

OOTWGZephir

Villager
Member
Joined
May 25, 2015
Messages
7
Reaction score
0
First Language
english
Primarily Uses
hello i was wondering if you can help me with an issue i came across   i added into my game this addon   from your demo. i can see that when you do a battle the static images are moving up and down (breathing i think you called it)   but i added the addon to my game all the addon setting are identical to your demo  yet my static image dont breath or move infact  i even copy and pasted one of my static images over to your demo and it work perfectly fine  would you know why your addon is not working on my game  thanks
 

Nechigawara

Certamen Promus
Veteran
Joined
Oct 24, 2015
Messages
54
Reaction score
36
First Language
Thai/English
Primarily Uses
N/A
hello i was wondering if you can help me with an issue i came across   i added into my game this addon   from your demo. i can see that when you do a battle the static images are moving up and down (breathing i think you called it)   but i added the addon to my game all the addon setting are identical to your demo  yet my static image dont breath or move infact  i even copy and pasted one of my static images over to your demo and it work perfectly fine  would you know why your addon is not working on my game  thanks

That's an option from Yanfly Battle Engine Core Plugin, not this one.
 

Ghost of Christmas Kloe

The Icecream Princess
Veteran
Joined
Nov 15, 2015
Messages
1,548
Reaction score
960
First Language
English
Primarily Uses
RMMZ
Last edited by a moderator:

terrorchan

Literally a Gloop
Veteran
Joined
Mar 17, 2014
Messages
249
Reaction score
179
First Language
English
Primarily Uses
Is there anyway I could make it not flip the sprites?
 

Nechigawara

Certamen Promus
Veteran
Joined
Oct 24, 2015
Messages
54
Reaction score
36
First Language
Thai/English
Primarily Uses
N/A
It's in both! Look at the preview image at the top of the OP and you'll see!  :|


Also take this quote from the OP

My bad!! Sorry about that again.

Is there anyway I could make it not flip the sprites?

After checking, most sideview plugin doesn't give this option. So may be you have to try edit the plugin yourself.
 

Latest Threads

Latest Posts

Latest Profile Posts

Progress on my game is nearly done, so I figured I show you guys the title screen. I hope you like it!
Title Screen.png
Does this ever happen to anyone?: your making a battle sprite [or any sprite] then when you mess something up you then see it as something diff, then working with it? its hard to say in words but it happens to me all the time
found out how to change pfp, literally there's a hidden thingy on the bottom of it
Tarzanthecat wrote on SoftCloud's profile.
Bill_shitting.jpg
Interesting week. Lots of stress and anxiety especially on Tuesday but still got thru it. How is everyone doing?

Forum statistics

Threads
109,162
Messages
1,042,645
Members
141,663
Latest member
skipbinsperthwa
Top