BiovoG

Villager
Member
Joined
Apr 18, 2021
Messages
5
Reaction score
0
First Language
English
Primarily Uses
RMMV
I'm having an issue with the AnimatedSVEnemies plugin where the animated enemy performs said actions super fast, like 1 frame fast. This happens with him attacking or getting hit. I also used the sprite sheet on an actor and that worked correctly. What I find so weird is that the idle animation is still normal speed, so that probably not it either. I also have all plugins in the correct order.

Below is video of what I mean:


Thanks in advance!
 

BiovoG

Villager
Member
Joined
Apr 18, 2021
Messages
5
Reaction score
0
First Language
English
Primarily Uses
RMMV

BiovoG

Villager
Member
Joined
Apr 18, 2021
Messages
5
Reaction score
0
First Language
English
Primarily Uses
RMMV
buuuuuuuuuuuuuuuuump
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
950
Reaction score
498
First Language
English
Primarily Uses
RMMV
You haven't supplied much information to work with. Can you provide screenshots of the enemy database entry? Have you tried changing the <Sideview Frame Speed> tag? Is there an action sequence in the skill it's using? Have you given it a <Sideview Attack Motion>?
 

BiovoG

Villager
Member
Joined
Apr 18, 2021
Messages
5
Reaction score
0
First Language
English
Primarily Uses
RMMV
Enemy database entry:
1618943795225.png

As you can see its sideview attack motion is swing. Notice how I didn't put any <Sideview Frame Speed> and thats because in the screenshot below the default should be 12 (This is the Animated sv Enemies plugin parameters section):
1618943903102.png

I did however change this value both in here and in the notebox of the enemy and the IDLE animation gets slower but the rest is still super fast.

it is currently not using any action sequences. I also discovered that this happens with every enemy. I've tried disabling several plugins and even all except for the AnimatedSVEnemies plugin, but I keep getting the same result.
 

ATT_Turan

Forewarner of the Black Wind
Veteran
Joined
Jul 2, 2014
Messages
950
Reaction score
498
First Language
English
Primarily Uses
RMMV
Are you sure your sprite sheets are in the correct format? If you replace the graphics with one of the default SV actors, does the same problem happen?
 

BiovoG

Villager
Member
Joined
Apr 18, 2021
Messages
5
Reaction score
0
First Language
English
Primarily Uses
RMMV
Yup, the exact same problem. Furthermore if I use this minotaur sprite sheet on a playable character it works perfectly fine.
 

Latest Threads

Latest Profile Posts

Hey everyone! No Studio Blue RPG Maker Critiques Stream today! But you can always check the playlist for old streams you've missed!

I ran out of paper sheets to draw, so I guess I'm forced to do digital for a while now...
x778xt8.jpg

Still haven0t found a colouring style that I like :kaoswt:
woods.pngshop.jpgboss.jpgRoom.png

Mapping is becoming so much easier!
FirestormNeos wrote on Neikoku's profile.
the cat in your profile picture is adorable
Are the default-size "chibi" sprites really a bad thing for a project? I'm not planning to sell my game anyway but I was wondering if they were as hated as some videos seem to claim...

Forum statistics

Threads
111,431
Messages
1,061,081
Members
144,797
Latest member
gh05tinblack
Top