Animation failed to load in deployed game

Indra

RM Student
Veteran
Joined
Jan 20, 2018
Messages
39
Reaction score
35
First Language
Indonesian
Primarily Uses
RMMV
This is my first time deploying a game to windows. When I play it on my windows machine, in battle it always fail to load animations of enemy attacking, and stuck. Any idea on how to fix this?

When I deploy the game I check exclude unused, is this the problem? Or should I remove unused stuff manually?

The game is free on here http://indraaziz.itch.io/kristamata (password: rpgmaker) but it is in bahasa indonesia though.
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,633
Reaction score
13,223
First Language
English
Primarily Uses
RMMV
If you are using a plugin for the enemy attacking animations and you exclude unused resources, those images won't be deployed unless the plugin has specific code to include them. Most of the earlier plugins probably won't, as that feature was only introduced in a later version.

If your deployed game has folders for the images, just copy those images into the correct folder in the deployed version and you'll be able to play. I don't recall if MV bundles up its graphics or modifies them so they can't just be pulled out of the project or not.
 

Indra

RM Student
Veteran
Joined
Jan 20, 2018
Messages
39
Reaction score
35
First Language
Indonesian
Primarily Uses
RMMV
Ah that's why! Yes, I just checked the img>animations in www and those missing in game weren't included in it. So I just copied the whole animation in it just to make sure it wont fail again lol, but sadly it added up the file size quite a bit.

Thank you @Shaz!

But turns out that there are a few more missing file, like SE. But every missing one is ones used in battle. Is there a way to quickly compare the files that are used in the original game vs the files in the deployed?
 
Last edited:

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,633
Reaction score
13,223
First Language
English
Primarily Uses
RMMV
are they all used by the plugin?
 

Indra

RM Student
Veteran
Joined
Jan 20, 2018
Messages
39
Reaction score
35
First Language
Indonesian
Primarily Uses
RMMV
That's the thing, I don't know how to identify the ones used in the plugins. Are they specified in the plugins js text file somewhere?

I just played through the game and find missing files one at a time, so far I only found 3 more missing ogg files when in some battles. After I replaced the files everything works so far.

The failing error usually comes right after the heroes turn in battle, so when it's time for the enemies to attack.

There's got to be a more efficient way of doing this right?

Here are the list of my active plugins, if that is useful info
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

Small rant: While using SRD Hud maker for a battle hud, I typed in the wrong script call and got an error, but then forgot to delete the piece that caused the error before closed the Hud maker and hit F5 to restart the game. Now everytime I engage in a battle my game crashes...
:kaolivid:
Would Jump into Javascript be best off continuing to break down the MV core files, or would people prefer a quick detour to cover everything that's changed in the core from MV to MZ?
Not going to lie... PIXI Particles make fantastic graphics... But predicting the hitbox of something with a "fixed size" but whose graphics can stick out past that, is quite challenging. :kaoswt:
Would you like a glass of spiders?

Forum statistics

Threads
100,530
Messages
976,897
Members
132,081
Latest member
Kaezyelnatz
Top