Anyone know how to disable Skype attenuation?

Discussion in 'General Lounge' started by Zevia, Oct 5, 2015.

  1. Zevia

    Zevia Veteran Veteran

    Messages:
    622
    Likes Received:
    329
    First Language:
    English
    Primarily Uses:
    RMMV
    Short version of the question: If somebody knows a way to stop Skype's automatic attenuation/ducking that does not involve one of the solutions we already tried (listed below), that would be very helpful.

    So we tried something new with the RPGMakerTV stream yesterday, which was having people come in and voice act different characters. Initially, the thought was people could just hop on Skype with the person streaming, then read off the stream - but of course, streaming on any platform always brings with it a delay of about 10-20 seconds. So that was no longer feasible - we had to get people able to watch the game in real-time.

    Well, since they're already on Skype, the person streaming can just do a screen-share of the RM game. No problem - however, it would mean that the game audio wouldn't be synced with the visual for the people watching it on Skype instead of on stream.

    So then we figured out that if you go into your sound properties, right-click on your microphone, go to listen, and check the box "Listen to this Device," you can monitor yourself - which effectively lets your mic go through your Stereo Mix. So then, if you transmit your Stereo Mix as your microphone, it would send both your microphone and your sound output to people. So then, in the streaming software, you just disable sending anything through the speaker output and just send your microphone.

    It took a lot of finagling and trial and error, but we got it working just fine - we now had multiple people voice acting and commentating on a game in real time for the viewers on stream to watch.

    However, Skype has a very annoying auto-attenuation or "ducking" feature in it, such that whenever anybody talks, the Skype audio is immediately muted. We tried every single solution we were able to find around the web, including the following:

    1. Go into your sound properties, go to the communications tab, and change "When Windows detects communication activity:" to "Do nothing." It didn't do anything to change that to any option.

    2. Go into the shared.xml file for Skype in the AppData/Roaming folder and find the line that says <AGC>0</AGC> and change it to 0 (it was already at 0. We tried changing it to 1, no go).

    3. In the Skype sound options, uncheck the boxes that say "Automatically adjust my microphone levels" and "Automatically adjust my speaker levels." Nothing changed.

    4. In your playback device, add the Loudness Equalization enhancement. This actually made everything significantly worse.

    5. In the advanced tab of either your Stereo Mix, your playback device, or your microphone, uncheck the boxes that say "Allow applications to take exclusive control of this device" and "Give exclusive mode applications priority."

    6. Change your connection settings in Skype's advanced options. I have no idea how this would affect anything, but it was a suggested solution somewhere. It didn't do anything.

    I found thread after thread after thread of people that just kept saying, "Go to the communications tab and check the box that says 'do nothing,'" as well as just as many threads of people going, "I tried that. It doesn't work. It hasn't worked for 2 years. Has anybody actually figured out how to solve it?"

    We watched the stream again and, at least, the stream does not seem to be affected. It specifically affects only Skype, and it only affects the people who are not doing the screen/audio sharing. So, for example, Person A is sharing screen and sharing audio. Person B talks - the audio that Person A is sharing is immediately reduced to 0 for Persons B, C, and D, until Person B stops talking, at which point the sound returns to normal.

    From what I can gather, it's an issue specific to Skype that a lot of people are aware of, but nobody has found a solution for in years. We considered that maybe we could just do screen-sharing in Skype, then do the audio in another program, but we preferred not to ask people who wanted to guest voice act or commentate to download any extra programs beyond Skype (especially since most people probably already have that and don't need to do anything to their own settings, just hop on and talk).

    It wouldn't be noticeable to people watching the stream, but it would be an annoyance to people who are helping out voice acting that every time someone talks, the game's audio gets muted for them. So if somebody knows a way to stop Skype's automatic attenuation/ducking that does not involve one of the solutions we already tried above, that would be very helpful.
     
    #1
  2. Shaz

    Shaz Veteran Veteran

    Messages:
    37,794
    Likes Received:
    11,502
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    Who is the person who should do these steps - the person streaming, on their skype? Or ALL of the people who are connected to each other through Skype? Have the others tried those things as well, or just the one person? Might be worth a shot.
     
    #2
  3. Zevia

    Zevia Veteran Veteran

    Messages:
    622
    Likes Received:
    329
    First Language:
    English
    Primarily Uses:
    RMMV
    Hmm. That's a thought - we mostly just had the person hosting the Skype session trying various solutions, not everybody trying it.

    The two of us who were trying to test things, I know for sure, had both simultaneously attempted solutions 1, 2, 3 and 5.

    The way it works for us is that whoever is screen-sharing on Skype adds their microphone to their stereo mix, then selects stereo mix as their microphone. Everyone else just joins and speaks normally, without otherwise changing settings. This is nice, too, so that people who want to hop in and voice act or commentate don't have to go through any lengthy process beyond just getting on Skype and joining the group call.

    One thing that I was pleasantly surprised about - I would think that, since you are transmitting your Stereo Mix, it would echo everything everybody says (since you would hear it, then the Stereo Mix would re-transmit it back out since you're using it as a microphone), and yet, that wasn't an issue.
     
    Last edited by a moderator: Oct 5, 2015
    #3

Share This Page