Status
Not open for further replies.

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
626
Reaction score
45
First Language
english
Primarily Uses
RMVXA
So my testers are having an issue with saves and region battlebacks when they get into a battle.
This error pops up when they try to get into a battle:
1652575503993.png
This is the region battle setup that I have for the area:
1652575542723.png
What is going wrong and how do I fix it?
Edit: I may have found the problem. Trying a fix now. Will keep updated if it doesn't work.
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
36,278
Reaction score
9,702
First Language
German
Primarily Uses
RMMV
my first guess would be a script incompatibility or an incompatible older savefile.

the second is best tested with starting a new game, then creating a new savefile and test with that.

the best way to check fot compatibility issues is to install a backtracer script and check the error trace. you can find a link to a backtracer in the "how to use a script" tutorial in my signature.
 

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
626
Reaction score
45
First Language
english
Primarily Uses
RMVXA
my first guess would be a script incompatibility or an incompatible older savefile.

the second is best tested with starting a new game, then creating a new savefile and test with that.

the best way to check fot compatibility issues is to install a backtracer script and check the error trace. you can find a link to a backtracer in the "how to use a script" tutorial in my signature.
So it is happening any time the player loads a save from the game after they have used a save item that is part of my game. I don't understand how it is a problem. I have never had this issue before. I don't have any new scripts and have made sure to look at the map info.
I tried the backtracer and this was the info it gave me:
1652616218457.png
I don't know what this means.
Here is my game file so that might make it easier for you guys to see the issue:
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
36,278
Reaction score
9,702
First Language
German
Primarily Uses
RMMV
the parts of each line that says: in 'scriptslotname' at the end of each line tells you which scripts are involved with the error. If the name is one of the default slots you can ignore it unless you edited them.
the important ones are usually the names for the added slots.

they can indicate an incompatibility between one or more of them.

Due to this most people use the names of the scripts themselves as the slotnames, but unfortunately you used more descriptive names instead, so I can only tell there are several added scripts involved, but not which ones.

Another hint is your description of the tests. If this happens even to a savefile that was made from a new game, without any change in the scripts between, then that means that one of those added scripts does not save its data correctly.
that would be a failure of the script directly.

However due to you using your own names for the script slots, we have to ask for additional data:
please use the error trace to identify every added script involved, and give us links to the websites where you got those scripts from, as well as the order in which you added them below materials in the script editor.
 

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
626
Reaction score
45
First Language
english
Primarily Uses
RMVXA
the parts of each line that says: in 'scriptslotname' at the end of each line tells you which scripts are involved with the error. If the name is one of the default slots you can ignore it unless you edited them.
the important ones are usually the names for the added slots.

they can indicate an incompatibility between one or more of them.

Due to this most people use the names of the scripts themselves as the slotnames, but unfortunately you used more descriptive names instead, so I can only tell there are several added scripts involved, but not which ones.

Another hint is your description of the tests. If this happens even to a savefile that was made from a new game, without any change in the scripts between, then that means that one of those added scripts does not save its data correctly.
that would be a failure of the script directly.

However due to you using your own names for the script slots, we have to ask for additional data:
please use the error trace to identify every added script involved, and give us links to the websites where you got those scripts from, as well as the order in which you added them below materials in the script editor.
Here is my game file so that might make it easier for you guys to see the issue:
By the way the save crystals on the map are not causing the problem. The item that I use in my game for saving as well is causing the problem.

Yanfly script website: https://yanflychannel.wordpress.com/rmvxa/
MOGhunter websites are all down.
TDS Battleback: https://rmrk.net/index.php?topic=45083.0
1652624107520.png
 
Last edited:

Roninator2

Gamer
Veteran
Joined
May 22, 2016
Messages
4,131
Reaction score
1,109
First Language
English
Primarily Uses
RMVXA
The save crystals on the map also cause the issue. But the issue isn't saving or loading, it's the map battleback data not being refreshed or saving with the save game. I tested your game both ways and if you get into a battle on the map that you return to when loading, the error occurs, but if you go to another map, it's fine.
 

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
626
Reaction score
45
First Language
english
Primarily Uses
RMVXA
The save crystals on the map also cause the issue. But the issue isn't saving or loading, it's the map battleback data not being refreshed or saving with the save game. I tested your game both ways and if you get into a battle on the map that you return to when loading, the error occurs, but if you go to another map, it's fine.
Okay so how do I fix it?
 

Roninator2

Gamer
Veteran
Joined
May 22, 2016
Messages
4,131
Reaction score
1,109
First Language
English
Primarily Uses
RMVXA
On further testing it's not that the data is not saved or loaded, it has something else to do with the data not getting restored to the way it need it to be.
I added one line to Yanfly region Battleback and it works.
line 256 return @map.region_battlebacks
Add before that, this line
@map.load_notetags_rbb if @map.region_battlebacks == nil
 

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
626
Reaction score
45
First Language
english
Primarily Uses
RMVXA
On further testing it's not that the data is not saved or loaded, it has something else to do with the data not getting restored to the way it need it to be.
I added one line to Yanfly region Battleback and it works.
line 256 return @map.region_battlebacks
Add before that, this line
@map.load_notetags_rbb if @map.region_battlebacks == nil
It worked.
 

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
9,715
Reaction score
6,169
First Language
Dutch
Primarily Uses
RMXP

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Latest Threads

Latest Profile Posts

ScreenShot_6_28_2022_3_2_40.png

There's 7 main areas in the game that are all connected. This train get's you from an underground lab to the center of someone's subconscious. inside the train you can talk to some of the passengers. but going to the top of it, there's battles.
Speedrunning all character portraits just so they all have the same quality. Not sure if this was a good idea, but now I'm almost done.
We now have a gameplay video!
DrBuni wrote on Akiritas's profile.
That is a cute Link picture, reminds me of the Samurai Jack artstyle.
I had an idea on how to get my encounters to leash after chasing the player for a little bit. After going down the Javascript rabbit hole, I realized I could do it in a regular movement route. Derp!

Forum statistics

Threads
123,146
Messages
1,154,378
Members
161,492
Latest member
moslngs
Top