Blurry Text

Discussion in 'RPG Maker MV' started by ChaoticShadow24, Nov 9, 2015.

  1. ChaoticShadow24

    ChaoticShadow24 The Most Chaotic Veteran

    Messages:
    186
    Likes Received:
    6
    First Language:
    English
    Why is the text in the RPG Maker MV program slightly blurry? It looks like it's been bilinear upscaled from 1280x720p to 1920x1080p..

    Anyone else with a 1920x1080p monitor having this issue?

    Is there a way to fix this? I promise you I'm not blind!
     
    #1
  2. Kenen

    Kenen Veteran Veteran

    Messages:
    255
    Likes Received:
    152
    First Language:
    English
    Primarily Uses:
    RMMV
    MV generally appears to use different (possibly more aggressive) font anti-aliasing than Ace did, and also has a much thicker font outline by default. With regards to adjusting it, it's possible to reduce the weight of the outline. You can also experiment with changing the font face; it won't change the anti-aliasing method, but different fonts do render and react to anti-aliasing differently.


    This plugin would be a good start in terms of tweaking MV's font: http://forums.rpgmakerweb.com/index.php?/topic/47788-font-editorloader/?hl=loader
     
    Last edited by a moderator: Nov 9, 2015
    #2
  3. ChaoticShadow24

    ChaoticShadow24 The Most Chaotic Veteran

    Messages:
    186
    Likes Received:
    6
    First Language:
    English
    Thank you very much! I appreciate your help.  :D
     
    #3
    Kenen likes this.
  4. Kenen

    Kenen Veteran Veteran

    Messages:
    255
    Likes Received:
    152
    First Language:
    English
    Primarily Uses:
    RMMV
    You're welcome. I would recommend tweaking the font face, font size, and font outline. A combination of those adjustments may give you the result that you're looking for.
     
    #4
  5. Risewild

    Risewild Villager Member

    Messages:
    6
    Likes Received:
    3
    Location:
    Australia
    First Language:
    Portuguese
     I just joined this awesome site and was curious about blurry fonts/text.

     I have read the OP post and seems to me that he is describing a problem I also have, but that handy Plugin that Kenen posted unfortunately does not adress my problem.

     My problem is that the RPG Maker MV software (the editor/actual program, not the games we can make on it) has a blurry font, it seems like it doesn't use the windows cleartype option, I seem to be very sensitive to fonts without cleartype and can't use this new RPG Maker because it causes my eyes to start tearing due to the blurry fonts.

     I have been googling for how to apply the cleartype effect to software without success (I guess we can't) and I have been googling for days too how to try and remove the blurriness from the RPG Maker MV editor fonts but again without any success, I can only find posts related to fonts ingame and not the actual editor/maker software.

     I do not own RPG Maker MV yet, I was lucky I tried the demo version first and I have probably around 15 days left but I can't use it, if anyone could be kind and tell me if there is any known way for me to remove the blurryness or be able to add the cleartype font option to RPG Mkaer MV I would be very grateful.

    Thanks for your time :)
     
    #5
  6. Shaz

    Shaz Veteran Veteran

    Messages:
    37,711
    Likes Received:
    11,419
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    Plugins do not change the editor. And we have no way to change the editor without breaching the terms of use.


    Can you show a screenshot? I don't find the text blurry at all. Maybe you don't have the font installed that it needs and it's picking a different one. Maybe you've got your DPI settings changed from the default 100% and that's causing it to look blurry.
     
    #6
  7. Risewild

    Risewild Villager Member

    Messages:
    6
    Likes Received:
    3
    Location:
    Australia
    First Language:
    Portuguese
     Thanks for replying :) .

     I just checked the Windows DPI just in case and it is 100% (Default), I also do not have any other font on any other program I use looking like that. It might be that I don't have the right font like you mentioned, but I assume it would use a font that is distributed with Windows?

     I am using Windows 7 Ultimate and a laptop so the screen is smaller than most people would use I guess.

     Many (or even most) people do not seem to have this thing about noticing a small blurriness in some fonts (for example some people have no problems with not using cleartype option on for their computers), unfortunately it seems to affect me in a stupid way D:< .

     I am posting a screenshot as requested, it is not resized in any way and I saved it with the highest quality possible as to be as faithful to what I see in my game, but even though I can see the blurriness in teh screenshot it seems a tiny bit less than in the actual program :unsure: .

    [​IMG]

    Thanks for the help, I really do not know how to fix this and it's driving me crazy :p , I wonder if it is because I got the demo version and the full version has different fonts or something...

    EDIT: Just noticed that to see the fullsized pic one has to click on it.
     
    Last edited by a moderator: Nov 11, 2015
    #7
  8. Tommy Gun

    Tommy Gun ♩ ♪ ♫ ♬ Veteran

    Messages:
    385
    Likes Received:
    120
    First Language:
    English
    I've seen a lot of complaints about that, and it looks like that in my MV too. I should add that to my faq. As far as I know, there's no way to change it. Is it clear for anyone, or are some people just not bothered by it? (It's not a dealbreaker for me, but it's a little annoying.)
     
    #8
  9. Shaz

    Shaz Veteran Veteran

    Messages:
    37,711
    Likes Received:
    11,419
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    I just don't see it, I'm afraid. Mine looks like that too, but I don't consider it to be blurry, and any blurriness that I consider might be there I just put down to tired eyes. Sorry :( I'm not much help to you on this one.
     
    #9
  10. Risewild

    Risewild Villager Member

    Messages:
    6
    Likes Received:
    3
    Location:
    Australia
    First Language:
    Portuguese
     Thanks Tommy Gun and Shaz for taking the time to reply. I guess it is like that and most people are just not bothered by it, I am because my eyes are not what they used to be, I guess I can blame getting older and being a diabetic ;) .

     At least now I know it is just not in my Demo :D . Well I better force myself playing around with the demo and see if I like it even with the eyes tearing  ;_; , after all I can avoid looking at the text while I am making maps, it's the event making page and writing text that really break my eyes. :D
     
    #10
  11. Tsukitsune

    Tsukitsune Veteran Veteran

    Messages:
    835
    Likes Received:
    638
    First Language:
    English
    Bump because my text looks horrid


    [​IMG]
     
    #11
  12. ZcheK

    ZcheK ZcheK Veteran

    Messages:
    96
    Likes Received:
    22
    First Language:
    English
    This worked for me on Windows 10: Go to your RPG Maker installation folder and right click on RPGMV.exe.
    Choose "properties" then "compatibility" then set "override high DPI scaling behavior" to "application".
     
    #12

Share This Page