devonair320

Villager
Member
Joined
Dec 29, 2014
Messages
5
Reaction score
2
First Language
English
Primarily Uses
As said, my ship turns but doesn't move no matter what. I'm using the Dungeon tileset, and I'm using the first tile in A1. I've tried the second tile, and I've tried both the boat and the ship, and neither work. Both seem to be able to turn though, just not move. I've changed both tiles that I've tried to the passable "O", but nothing is working. I'm not sure what the issue is :/ Thanks for any help!
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,789
Reaction score
15,917
First Language
English
Primarily Uses
RMMV
Are you using the boat vehicle, or did you just give an event the boat sprite?


If you can turn but not move, that's a passability setting.


Check the top left tile in tab B and make sure it's passability is set to a star.
 

devonair320

Villager
Member
Joined
Dec 29, 2014
Messages
5
Reaction score
2
First Language
English
Primarily Uses
Thanks for the quick response! I've tried using both the actual boat vehicle, and using the different ship vehicle but changing the sprite to the rowboat. I just checked the tile on B and it is set to star.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
36,693
Reaction score
9,863
First Language
German
Primarily Uses
RMMV
Boat and ship do not move by regular passability, you can read more about it in the help file.


In this case however I assume it's your setting to passable that blocks this, because the boat can only move in shallow water that is IMpassable to the (land) player.


Just think about it this way: if shallow water is shallow enough to allow the player to walk on it, it is too shallow to allow a boat to pass through it.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,789
Reaction score
15,917
First Language
English
Primarily Uses
RMMV
Are you using any custom scripts or have you made any script mods?


Can you double-check the tileset that's being used on the map? Make sure you don't have two similar tilesets where one is set incorrectly.


Any chance you have a "blank" tile in the B-E slots set to X for passability, that you might have used to "erase" tiles you didn't want on the map?


Apart from


- must use an actual vehicle (right-click, choose Set Vehicle Location)


- top left tile in B is a star


that's about all I can think of.
 

devonair320

Villager
Member
Joined
Dec 29, 2014
Messages
5
Reaction score
2
First Language
English
Primarily Uses
Hmm I'm not using any custom scripts or mods. I did add a tile that wasn't in the original set, but I've sort of "painted" over that one with the ones from A1, so it shouldn't be an issue, right? I can check again for the passability of that stuff, or just go ahead and use invisible tiles to set a clean slate there and see if that helps, though I don't think that's the issue. Otherwise, I haven't really used any blank tiles to erase anything previously.

Ah, I see what you're saying, Andar! I'll also try switching the passability back to impassible and see if that works.

[after trying~]

Ahhh it worked!! I think it was the passibility thing, Andar! Thank you both so much! I really appreciate the help :) My problem is solved!
 

Latest Threads

Latest Profile Posts

Can you recognize where this area is from? :kaocry:
Mq9QM3h.png
For those with up to 9 elements of magic; how do you structure your database. By element? Or by what is offensive vs supportive spells?
would anyone here be interested in rough concept art for the main protagonist of my game that might get changed later? :kaoswt2:
I guess I have no idea how to properly upload a custom font lmao. The menu fonts are too damn small.

Font_Size.PNG

Forum statistics

Threads
124,436
Messages
1,163,647
Members
163,252
Latest member
kurus_12
Top