Bobstah's Battle Commands Customization v2.2.1 - Updated 05/17/2017

Discussion in 'JS Plugin Releases (RMMV)' started by Bobstah, Oct 24, 2015.

  1. Emje-noeg

    Emje-noeg :v Veteran

    Messages:
    31
    Likes Received:
    4
    Location:
    Demak, Indonesia
    First Language:
    Indonesia
    Ah sorry for late reply. Using this plugin alone and your last suggestion, I managed to do what I wanted to do.

    So I made this notetag on class database:
     

    <Battle Commands>

    Attack

    Skills

    ActorCmd
    WeaponCmd

    </Battle Commands>

    And then just made:

    <Battle Commands>
    Items

    </Battle Commands>

    on Weapon database (I add ActorCmd incase I want to add skill based on actor later). And it working perfectly! Now I also had idea making something like Final fantasy's Paladin/Knight where guard command become Defend/Cover command and so on.

    Thank you Bobstah for your help~
     
    Bobstah likes this.
  2. Villhelm

    Villhelm Veteran Veteran

    Messages:
    53
    Likes Received:
    30
    First Language:
    English
    I'm running into an issue with Skill Types and Skills learned through Armor traits. I just wanted to post my implementation to see if anyone could catch my error.

    I have 4 armor items (of armor/equipment type "Ring" if that matters).

    Armor 41 adds Stype 5 and Skill 181 through traits.

    Armor 42 adds Stype 6 and Skill 182 through traits.

    Armor 43 adds Stype 7 and Skill 183 through traits.

    Armor 44 adds Stype 8 and Skill 184 through traits.

    The actor only ever has one of these equipped at a time. Due to overwriting the Battle Commands window and bringing some skills out of the menu, I can't use the 'Skills' notetag on this actor. The actor's Battle Commands looks something like this:

    <Battle Commands>

    Skill:101

    Skill:102

    Skill:103

    !SType:5

    !SType:6

    !SType:7

    !SType:8

    </Battle Commands>

    My hope was to only show the SType of the currently equipped ring. However, the above ends up showing the STypes of all four rings (even though 3 of them are empty menus). I was expecting ! to hide the empty menus.This is occurring whether I place this in the class notetags or in the actor notetags and reference it via ActorCmd.

    I also attempted to utilize the Enhanced Restrictions plugin and set up a dummy actor with the following restrictions:

    <Restrict SType:5>

    Armor:41

    </Restrict>

    <Restrict SType:6>

    Armor:42

    </Restrict>

    <Restrict SType:7>

    Armor:43

    </Restrict>

    <Restrict SType:8>

    Armor:44

    </Restrict>

     

    This seems to be incorrect as well, since SType 5 is restricted always, regardless of the equipped ring.

     

    I have also attempted to replace:

    !SType:5

    !SType:6

    !SType:7

    !SType:8

    With:

    ArmorCmd

    To no avail. Any suggestions?
     
  3. Bobstah

    Bobstah Pluginstah Veteran

    Messages:
    216
    Likes Received:
    164
    Location:
    United States
    First Language:
    English
    Primarily Uses:
    N/A
    @Villhelm: I'll look into this tomorrow and try to replicate the bug. I am away on business today. :(
     
  4. SuperMasterSword

    SuperMasterSword That Guy You Dont Know Veteran

    Messages:
    117
    Likes Received:
    48
    Location:
    Awesomeville
    First Language:
    Javascript
    Primarily Uses:
    RMMV
    @Villhelm

    I haven't used this plugin all that much but aren't you supposed to put the exclamation mark at the end of the tag?
     
  5. Villhelm

    Villhelm Veteran Veteran

    Messages:
    53
    Likes Received:
    30
    First Language:
    English
    My apologies, that crept in during my debugging. I originally had:

    SType:5!

    SType:6!

    SType:7!

    SType:8!

    And have just confirmed that I'm still seeing the same behaviour.
     
  6. Bobstah

    Bobstah Pluginstah Veteran

    Messages:
    216
    Likes Received:
    164
    Location:
    United States
    First Language:
    English
    Primarily Uses:
    N/A
    @Villhelm: I released an update recently to the Enhanced Restrictions plugin that fixed some logic problems. Have you tried the update?

    For version 2.1, I've added STypes to the main skills menu, so it will emulate how skills are shown in battle. If a skill type is shown in a combined tag, it is not shown again. If it isn't shown in a combined tag, it will be shown after all STypes are shown.

    Are there any other suggestions for version 2.1 before I release it?
     
    Roguedeus likes this.
  7. Villhelm

    Villhelm Veteran Veteran

    Messages:
    53
    Likes Received:
    30
    First Language:
    English
    @Bobstah: I was on v2.0 of the Battle Commands and v1.5 of Enhanced Restrictions. I have updated to v1.5.1 and am still seeing the same behaviour.

    This is occurring in my project with all other plugins deleted. The order of these two in the plugin manager doesn't seem to change the issue.

    Force Default Commands is set to 0.

    Classes have no battle command notetags.

    Restrictions are set on a dummy actor with the notetags from my previous post (#202).

    Rings are set up in the Types tab of the database as Armor Type 06: Ring and Equipment Type 04: Ring

    Actor 1 has the Skills notetag.

    Actor 3 has SType notetags as in my previous post (#203 i.e. SType:5!, SType:6!, SType7!, and SType8!).

    Actor 1 with Ring (Armor DB item #41) equipped (granting him SType 5 and Skill 181 through traits):

    - Has SType 5 and Skill 181 greyed out, even though he has the right ring equipped (unexpected).

    - No other STypes appear (expected).

    Actor 3 with Ring (Armor DB item #43) equipped (granting him SType 7 and Skill 183 through traits):

    - Does not have SType 5 at all in his menu (expected).

    - SType 6 and 8 show in his menu but are empty (unexpected).

    - SType 7 and Skill 183 appear (expected).

    When I navigate to the skills menu during playtest the skills are showing up properly for Actor 3 (not seeing STypes 5, 6, or 8). Actor 1 still has the issue that SType 5 is appearing but the corresponding skill is greyed out. I'm seeing the same behaviour in Battle Test mode through the Troops tab of the database.

    Let me know if you have any luck reproducing the issue or spot a problem with my implementation.
     
  8. Mr_Bardo

    Mr_Bardo Warper Member

    Messages:
    3
    Likes Received:
    7
    First Language:
    Spanish
    Hi Bobstah, im new with the RM but i need this plugin, i was fighting to use it all day but finally i get this...
     
    [​IMG]
     
    Nothing ;_;
     
    It's something wrong?
    [​IMG]
     
    ___________
     
    [​IMG]
    By the way, thanks.

    __________________________

    Edit: I did it!  :D Grat plugin.
     
    Last edited by a moderator: Jan 3, 2016
  9. ranmaster27

    ranmaster27 Villager Member

    Messages:
    8
    Likes Received:
    0
    First Language:
    English
    Question.
    Is there a way to make it so when an actor's TP is at 100.

    The battle command [Limit] will appear.

    And when the actors TP is less than 100, the battle command [Limit] will disappear?
     
  10. MrPurpleDreadlocks

    MrPurpleDreadlocks Veteran Veteran

    Messages:
    159
    Likes Received:
    19
    First Language:
    English
    masterlobo and ranmaster27 like this.
  11. kranasAngel

    kranasAngel Wanderer Veteran

    Messages:
    122
    Likes Received:
    41
    First Language:
    English
    Primarily Uses:
    RMMV
  12. Villhelm

    Villhelm Veteran Veteran

    Messages:
    53
    Likes Received:
    30
    First Language:
    English
    @kranasAngel

    I had to locally modify the Battle Commands Plugin to get it to work but this is how I'm accomplishing it in my project:

    1) Added the following case to processCommandEntry (line 614):

            case "mix":            return this.addMixCommand();        break;2) Added an addMixCommand function (I added it following addSkillCommand at line 724):

    Window_ActorCommand.prototype.addMixCommand = function() {this._actor.mixActions().forEach(function(mix) {this.addCommand(mix.name, 'mix action', true, mix);}, this);    return true;};3) I setup the mix command from Victor's plugin in the Class notetags:

    <mix command: 'Alchemy'>...</mix command>4) I added Mix to the list of the Actors notetags for Battle Commands:

    Code:
    <Battle Commands>...Mix...</Battle Commands>
     
    kranasAngel likes this.
  13. ranmaster27

    ranmaster27 Villager Member

    Messages:
    8
    Likes Received:
    0
    First Language:
    English
    Why thank you Mr. Purple.
    Thanks for the heads up. =)
     
  14. kranasAngel

    kranasAngel Wanderer Veteran

    Messages:
    122
    Likes Received:
    41
    First Language:
    English
    Primarily Uses:
    RMMV
    @villhelm

    Thank you so much
     
  15. ramza

    ramza Lunatic Coder Veteran

    Messages:
    540
    Likes Received:
    295
    Location:
    Nova Scotia, Canada
    First Language:
    English
    Primarily Uses:
    RMMV
    The OP in this topic seems to imply that I can use StateCmd to show STypes unlocked by states but I can't seem to get that to work at all. I have tested with a passive state, as well as a state that was put on my actor using a skill. Additionally, the help documentation doesn't mention this functionality at all, was it put in the OP by mistake and is a feature for the next version?


    The version I have is 2.0, and I see a post higher up where it was mentioned that there would soon be a 2.1. What happened to that?


    Thanks.
     
  16. Little Paw

    Little Paw Veteran Veteran

    Messages:
    710
    Likes Received:
    293
    First Language:
    English
    Sorry to necro this thread but... I can't find any answers to my problem...


    I'm trying to put a Steal skill to be used on the command list, but it doesn't work.


    Currently, my setup is like this (in the actor's notebox):


    <Battle Commands>


    Attack


    Skill:13


    Skills


    Items


    Guard


    </Battle Commands>


    Skill 13 is of course Steal. But it doesn't show up there on the command list.


    If I have it set as the Lance Art (the character in question's skill type) skill type, Steal appears in the Lance Art (skills) menu.


    If I create a new skill type called Steal, and make Steal the Steal skill type, it just puts the Steal skill menu there and the Steal skill within it.


    If I set Steal to no Skill Type, it just appears in the menu with a blank space that can't be selected.


    What do I need to do to be able to use Steal right from the main command menu?
     
  17. ramza

    ramza Lunatic Coder Veteran

    Messages:
    540
    Likes Received:
    295
    Location:
    Nova Scotia, Canada
    First Language:
    English
    Primarily Uses:
    RMMV
    What you have should work. If your actor has class commands, they will overwrite his actor commands. If you have the first parameter in this plugin set to 1, it will ignore the actor notetag commands entirely.
     
  18. Little Paw

    Little Paw Veteran Veteran

    Messages:
    710
    Likes Received:
    293
    First Language:
    English


    Well that was a simple solution. All I had to do was set it to 0 and now it works lol


    Thanks. Sorry for the necro ^_^;
     
  19. Little Paw

    Little Paw Veteran Veteran

    Messages:
    710
    Likes Received:
    293
    First Language:
    English
    Actually... looks like I've run into another problem...


    It works fine in battle....


    [​IMG]


    But...


    [​IMG]


    This shouldn't happen. I want the Steal skill (and other skills like it that other characters have) to be hidden from the menu.


    How can I do that?
     
  20. ramza

    ramza Lunatic Coder Veteran

    Messages:
    540
    Likes Received:
    295
    Location:
    Nova Scotia, Canada
    First Language:
    English
    Primarily Uses:
    RMMV
    Get rid of that skilltype and give the actor the steal skill directly on his command window, and won't show up in the menu.
     
    Little Paw likes this.

Share This Page