Bobstah's Battle Commands Customization v2.2.1 - Updated 05/17/2017

Bobstah

Pluginstah
Veteran
Joined
Oct 24, 2015
Messages
216
Reaction score
165
First Language
English
Primarily Uses
N/A
Hello, the most recent update did something weird; I haven't updated for a long time though. Anyway, ever since i applied this update the default "Skill" command set got disabled in battle. It's still there; but it's not selectable...
Are you referring to Skills or Skill:ID?

If Skills, make sure the actor knows the skills and that they aren't sealed.

If Skill:ID, make sure the actor knows the skills and that they aren't sealed.

If both of those criteria are met, please provide the notetags you are using and the screenshot of the actor/class where they placed and where the skill and skill type are given and I will investigate further. :)
 

DustyCat Media

Indie Game Purrfector
Veteran
Joined
Oct 15, 2012
Messages
115
Reaction score
71
First Language
English
Are you referring to Skills or Skill:ID?

If Skills, make sure the actor knows the skills and that they aren't sealed.

If Skill:ID, make sure the actor knows the skills and that they aren't sealed.

If both of those criteria are met, please provide the notetags you are using and the screenshot of the actor/class where they placed and where the skill and skill type are given and I will investigate further. :)
I'm referring to the default Skills set.

Yes, the actor knows the skill/s and they aren't sealed.

Here are the screenies:



Thank you!
 

Bobstah

Pluginstah
Veteran
Joined
Oct 24, 2015
Messages
216
Reaction score
165
First Language
English
Primarily Uses
N/A
I'm referring to the default Skills set.

Yes, the actor knows the skill/s and they aren't sealed.

Thank you!
Interesting, I had never intended for the icon tag to be used with Skills. Glad it works, I guess! :p

If you replace i72-Skills with i72-SType: STypeIDForMana does it work?
 

DustyCat Media

Indie Game Purrfector
Veteran
Joined
Oct 15, 2012
Messages
115
Reaction score
71
First Language
English
Interesting, I had never intended for the icon tag to be used with Skills. Glad it works, I guess! :p

If you replace i72-Skills with i72-SType: STypeIDForMana does it work?
I'm not sure what you meant by replacing it with that:

I tried replacing i72-Skills directly with i72-Stype: STypeIDForMana and it crashed (sType ID not defined)

Replacing it with i72-SType:01 and it crashed as well (01 is the type id for Mana)

Replacing it with STypes(Mana):0008,0009 didn't crash but the command didn't show up at all.

(btw: "Mana" is the default Skills actually; i just replaced the actual text itself in the Type tab
 

Bobstah

Pluginstah
Veteran
Joined
Oct 24, 2015
Messages
216
Reaction score
165
First Language
English
Primarily Uses
N/A
I'm not sure what you meant by replacing it with that:

I tried replacing i72-Skills directly with i72-Stype: STypeIDForMana and it crashed (sType ID not defined)

Replacing it with i72-SType:01 and it crashed as well (01 is the type id for Mana)

Replacing it with STypes(Mana):0008,0009 didn't crash but the command didn't show up at all.

(btw: "Mana" is the default Skills actually; i just replaced the actual text itself in the Type tab
Try:i72-SType:1

Instead of skills. If that works, I'll know how to recreate this and release a fix in the morning.

Also, if you want an icon, you should be using SType instead of Skills.
 

DustyCat Media

Indie Game Purrfector
Veteran
Joined
Oct 15, 2012
Messages
115
Reaction score
71
First Language
English
Try:

i72-SType:1

Instead of skills. If that works, I'll know how to recreate this and release a fix in the morning.

Also, if you want an icon, you should be using SType instead of Skills.
Tried i72-Stype:1 and it still crashed.

I tried "Skills" (without the icon) and it's visible but still disabled / can't be selected. Hmm, it might not be an issue with your plugin after all.

Regardless, i'll wait for your fix :) . Thanks!

[EDIT]: I can confirm that this plugin causes the disabled command. I turned this plugin off and i can access my skills again / not disabled anymore. 

[EDIT2]: Tried another Skill type just to test, and now it's disabled as well.

[EDIT 3]: "i72-STypes(Mana):1" did the trick for me. Thanks! :)
 
Last edited by a moderator:

SOC

"God is my Judge"
Veteran
Joined
Mar 22, 2012
Messages
554
Reaction score
475
First Language
English
Primarily Uses
RMMV
I'm having a hard time understanding how to use the icons for commands, I just don't know what to put where and I don't really understand your main post, replies or help file. Can you add it to your FAQs how to add icons for stuff if that's all you wanted from this plugin?
 

residntevl

Blideo games
Veteran
Joined
Jul 30, 2012
Messages
37
Reaction score
26
First Language
English
Primarily Uses
RMMV
Currently SType is not working.

STypes does work, but it's actually not an issue considering STypes does exactly what SType does except has the extra functionality of grouping skills together.
 

Cel

Veteran
Veteran
Joined
Oct 28, 2015
Messages
88
Reaction score
56
First Language
Swedish
I got an error with my old notetags when updating to the latest version. Seems "Skill: 3" was the culprit as changing it to "Skill:3" made things work properly again.
 

Sera

Veteran
Veteran
Joined
Oct 27, 2015
Messages
80
Reaction score
16
First Language
English
I got an error with my old notetags when updating to the latest version. Seems "Skill: 3" was the culprit as changing it to "Skill:3" made things work properly again.
Thanks for posting this, it helped me to figure out what my issue was as well.

Having spaces between the 'Skill' and the number of the skill used to work fine in 1.7, but in 1.9 it will break the plugin. Removing all the spaces fixed my issue.
 

Bobstah

Pluginstah
Veteran
Joined
Oct 24, 2015
Messages
216
Reaction score
165
First Language
English
Primarily Uses
N/A
Version 1.9.3 is now available! Fixed notetags breaking when extra spaces used and skills/skill types always showing disabled. Download

Thanks for your patience, Sera, DustyCat Media, Cel, and residntevl. Please let me know if you experience any further issues.

I'm having a hard time understanding how to use the icons for commands, I just don't know what to put where and I don't really understand your main post, replies or help file. Can you add it to your FAQs how to add icons for stuff if that's all you wanted from this plugin?
If you only want to add icons, you still have to specify a battle commands notetag either at the actor level or the class level. It would look like this:

<Battle Commands>

i1-Attack

i1-Skills

i1-Guard

i1-Items

</Battle Commands>

Replace the number 1 in the above section to the icon index you want to use for each action. Note that if an actor has multiple skill types, the same icon will be used for each. To avoid that:

<Battle Commands>

i1-Attack

i1-SType:5

i1-SType:5

i1-Guard

i1-Items

</Battle Commands>

Replace the number 1 in the above section with the icon index you want to use (again). Replace the number 5 with the ID of the skill type from the 'Types' tab of your database.

Did this help?
 

DustyCat Media

Indie Game Purrfector
Veteran
Joined
Oct 15, 2012
Messages
115
Reaction score
71
First Language
English
@Bobstah: Actually your original suggestion (i72-Stype:1 ) worked even before the update; i just had to add the command name (i72-Stype(Mana):1. But anyway, thanks again! :)
 

Bobstah

Pluginstah
Veteran
Joined
Oct 24, 2015
Messages
216
Reaction score
165
First Language
English
Primarily Uses
N/A
@Bobstah: Actually your original suggestion (i72-Stype:1 ) worked even before the update; i just had to add the command name (i72-Stype(Mana):1. But anyway, thanks again! :)
If you didn't add the command name, it would break?

I believe I fixed that this time around, and if you're not renaming the command for combat, I would recommend taking (Mana) off of the tag. But it's your call. :)
 

DustyCat Media

Indie Game Purrfector
Veteran
Joined
Oct 15, 2012
Messages
115
Reaction score
71
First Language
English
If you didn't add the command name, it would break?

I believe I fixed that this time around, and if you're not renaming the command for combat, I would recommend taking (Mana) off of the tag. But it's your call. :)
I tried it just now, and while it works, the command just shows "???" instead of "Mana".

But anyway,what's important is that it's fixed. Thanks again! :)
 

Bobstah

Pluginstah
Veteran
Joined
Oct 24, 2015
Messages
216
Reaction score
165
First Language
English
Primarily Uses
N/A
I tried it just now, and while it works, the command just shows "???" instead of "Mana".

But anyway,what's important is that it's fixed. Thanks again! :)
It's not fixed if it isn't working like I want it to! :)

I tried to recreate this problem, but was unable to do so. Here are my notetags:

<Battle Commands>

attack

i11-SType: 00001

i11-stypes(Powers):1,2

i180-items

guard

</Battle Commands>

Can you post yours so that I can take a look?
 

DustyCat Media

Indie Game Purrfector
Veteran
Joined
Oct 15, 2012
Messages
115
Reaction score
71
First Language
English
It's not fixed if it isn't working like I want it to! :)

I tried to recreate this problem, but was unable to do so. Here are my notetags:

<Battle Commands>

attack

i11-SType: 00001

i11-stypes(Powers):1,2

i180-items

guard

</Battle Commands>

Can you post yours so that I can take a look?
Here's mine which produces the "???"

<Battle Commands>

Attack

Skill:0010

i72-STypes:1

i228-Items

</Battle Commands>

And here's a version that works:

<Battle Commands>

Attack

Skill:0010

i72-STypes(Mana):1

i228-Items

</Battle Commands>
 

Bobstah

Pluginstah
Veteran
Joined
Oct 24, 2015
Messages
216
Reaction score
165
First Language
English
Primarily Uses
N/A
Here's mine which produces the "???"

i72-STypes:1
I see the problem! You're using STypes, which requires a name to be specified. If you only want to list one skill type there, you should use SType:1 instead of STypes:1.

Make sense? :)
 
Last edited by a moderator:

DustyCat Media

Indie Game Purrfector
Veteran
Joined
Oct 15, 2012
Messages
115
Reaction score
71
First Language
English
I see the problem! You're using STypes, which requires a name to be specified. If you only want to list one skill type there, you should use SType:1 instead of STypes:1.

Make sense? :)
Tried it just now and it works! :)
 

SOC

"God is my Judge"
Veteran
Joined
Mar 22, 2012
Messages
554
Reaction score
475
First Language
English
Primarily Uses
RMMV
Did this help?
Yes it did!

Is it possible to include a "space" next to the icon and the text in the command window? Also, since the update, my actors "victory poses" are on fast forward now and they dance very fast after battle.
 
Last edited by a moderator:

Bobstah

Pluginstah
Veteran
Joined
Oct 24, 2015
Messages
216
Reaction score
165
First Language
English
Primarily Uses
N/A
Yes it did! However it doesn't seem to work with my cleric and mage's "magic" command, which are the same as the default magic command.

Is it possible to include a "space" next to the icon and the text in the command window? Also, since the update, my actors "victory poses" are on fast forward now and they dance very fast after battle.
The first setting's default value is set to 1 for that very reason. :)

I can add a parameter called Icon Padding that would take a number. It would then add that many pixels between the icon and the text. Would that work?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 2)

Latest Threads

Latest Posts

Latest Profile Posts

So I cloned an event in MV today.
Just got two custom tracks for my game. Things are shaping up nicely. :)
Remember, life is sh*t. But it will difinitely be less sh*t in the future! Stay happy everyone ^^ ...*continues to die inside*
Why is it that every time I take a short break from here, we get a new moderator?
Stream will be going live early today as I will be working on some music before I transition to art! When I switch to art, I will be focusing on making a new stream avatar~ Feel free to drop by!

Forum statistics

Threads
93,499
Messages
913,044
Members
123,036
Latest member
boredguy851
Top