[Bug] Portraits and avatars flicker.

Palxan

Veteran
Veteran
Joined
Jan 18, 2016
Messages
63
Reaction score
184
First Language
Russian
Primarily Uses
N/A
User: Palxan
Maker Version: RPG Maker MV 1.5.0 (Steam Version)
Bug: Portraits and avatars flicker when first used.

When the dialog is activated, if the portraits or avatars are not on the same file (they are on different panels)
delay occurs. It looks like a very unpleasant flicker.

If after the end of the dialogue to start it again, then the flicker disappears.

Video:

Project for demonstration:
https://mega.nz/#!QCA2iagK!flUpLYvS8pHDuUY4BS7detqIxxq8p9bPvQh0USUNR2k
 

Palxan

Veteran
Veteran
Joined
Jan 18, 2016
Messages
63
Reaction score
184
First Language
Russian
Primarily Uses
N/A
Sorry, but I would like to receive at least a short answer.
Was this message seen?
Will this bug be considered and the possibility of correcting it?
 

Oscar92player

Veteran
Veteran
Joined
Jul 26, 2012
Messages
501
Reaction score
220
First Language
Spanish
Primarily Uses
RMMV
This is a known issue, and it is related to this one regarding the frame drop, that I've reported some time ago (and it is not fixed yet).

This issue is caused by the poor performance of MV in some computers and how the engine preloads the graphic resources for your projects. The only solution I've found, is to preload all the images you are going to use with a plugin, unfortunatelly.
 

mlogan

Global Moderators
Global Mod
Joined
Mar 18, 2012
Messages
14,897
Reaction score
8,250
First Language
English
Primarily Uses
RMMV
@Palxan Yes, this message was seen, and recognized as an actual bug, which is why it was approved in the first place.

To both of you - a lack of response does not mean that it is being ignored or not worked on. While I have no clue what the development team is currently doing or what their priorities are, I'm sure, with this topic being approved, therefore the bug being acknowledged, that it has been placed somewhere on the list. It just takes time for things to get resolved, as they have many, many things they are trying to work on, with limited hours to work on them.
 

Palxan

Veteran
Veteran
Joined
Jan 18, 2016
Messages
63
Reaction score
184
First Language
Russian
Primarily Uses
N/A
Many thanks for your answers.
It remains only to hope that this problem can soon be corrected.

Oscar92player, thank you for raising a similar theme earlier. I tried to fix the situation with a patch from Yanfly, but alas ... it did not help.
While I continue to work, ignoring the flicker, and I hope that this bug will disappear with new updates of the program.
 

Archeia

Level 99 Demi-fiend
Developer
Joined
Mar 1, 2012
Messages
14,919
Reaction score
15,114
First Language
Filipino
Primarily Uses
VNM
This is related to resource loading because RPG Maker MV loads all files asynchronous as opposed to older RMs. A byproduct of mobile support/html5. Do you use any preloaders?

Galenmereth's plugin is officially provided with RPG Maker MV to avoid issues like these. You can even see it here:

Although there seems to be issues with 1.5.0 so it's better to grab the latest version from the forum topic. There's also YSP_Preloader by Yami.

EDIT:
Here's the project with a preloader, you'll notice that the flicker disappears completely.
 
Last edited:

Oscar92player

Veteran
Veteran
Joined
Jul 26, 2012
Messages
501
Reaction score
220
First Language
Spanish
Primarily Uses
RMMV
This is related to resource loading because RPG Maker MV loads all files asynchronous as opposed to older RMs. A byproduct of mobile support/html5. Do you use any preloaders?

Galenmereth's plugin is officially provided with RPG Maker MV to avoid issues like these. You can even see it here:

Although there seems to be issues with 1.5.0 so it's better to grab the latest version from the forum topic. There's also YSP_Preloader by Yami.

EDIT:
Here's the project with a preloader, you'll notice that the flicker disappears completely.
The link to the project with the preloader needs the decrypt password. Could you fix it, please? I would like to test it.
 

Palxan

Veteran
Veteran
Joined
Jan 18, 2016
Messages
63
Reaction score
184
First Language
Russian
Primarily Uses
N/A
The plugin is good, it seems I can make it work in my projects.

Oh... I have a lot of drawings and new ones are constantly added.
When adding I will have to re-write their addresses in a file.

But this is not so critical, just a lot of extra work.
Thank you for what has been done!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Work on Yanfly's MZ plug-ins is coming along nicely. Looking forward to getting them: http://www.yanfly.moe/wiki/Core_Engine_VisuStella_MZ
so uh variables can only be used for num lol? I guess I gotta fix that once MZ come out lol
I didn't think I'd spend the evening jamming out to the battle theme of a Hole Punch.
Welcome back to the dark era, where everything is in dark mode!
.
.
.
I'm not complaining! :o

Forum statistics

Threads
100,725
Messages
978,820
Members
132,351
Latest member
Subaya
Top