can i use multiple engine plugin in a project?

Discussion in 'Javascript/Plugin Support' started by Cheah Hsun Teik, Dec 2, 2016.

Thread Status:
Not open for further replies.
  1. Cheah Hsun Teik

    Cheah Hsun Teik plugin fixer Veteran

    Messages:
    35
    Likes Received:
    5
    Location:
    Malaysia
    First Language:
    English
    Can I use different engine plugin(yanfly,Luna,victor,etc) in one project?


    What sequence do I need to install the plugin in the plugin list or it can be installed anywhere in the plugin list?(only yanfly plugin teach you where to put each plugin in the list,the others don't)
     
    #1
  2. Dreadshadow

    Dreadshadow Lv 38 Tech Magician Moderator

    Messages:
    3,826
    Likes Received:
    2,469
    First Language:
    Greek
    Primarily Uses:
    RMMV
    Yes, no, maybe, I don't know.


    This is a tricky question and should be asked like "Hey can I use script A and Script B and Script C togehter?", specifying scripts A,B and C.


    Without knowing what scripts we are talking about, answering in general the answer should be "NO, not all scripts are compatible."


    :)


    So what scripts are you interested in compatibility?
     
    #2
  3. Cheah Hsun Teik

    Cheah Hsun Teik plugin fixer Veteran

    Messages:
    35
    Likes Received:
    5
    Location:
    Malaysia
    First Language:
    English
    I want to download all yanfly's plugin,but save core plugin  and new game+ plugin requires at rpgmaker MV 1.1 (mine is 1.0),so I think of creating or downloading a plugin that have a same function.will it work?where in the plugin list and how should I install this plugin?
     
    #3
  4. Dreadshadow

    Dreadshadow Lv 38 Tech Magician Moderator

    Messages:
    3,826
    Likes Received:
    2,469
    First Language:
    Greek
    Primarily Uses:
    RMMV
    Do you got MV on Steam?


    If not why you just don't update to a newer version?


    Edit:


    By the way, you asked something very different this time. :)
     
    Last edited by a moderator: Dec 2, 2016
    #4
  5. Cheah Hsun Teik

    Cheah Hsun Teik plugin fixer Veteran

    Messages:
    35
    Likes Received:
    5
    Location:
    Malaysia
    First Language:
    English
    I can't update using the updater/patch installer,it says" RPG maker MV has not been updated"(error)


    It is too time consuming and space consuming using the full installer


    That's why.
     
    #5
  6. Diretooth

    Diretooth Lv. 23 Werewolf Veteran

    Messages:
    1,197
    Likes Received:
    435
    Location:
    Earth
    First Language:
    English
    Primarily Uses:
    RMMV
    If what I'm understanding is correct, you are using a version of those plugins for later versions of MV. You should be able to upgrade MV to the most recent build.
     
    #6
  7. Dreadshadow

    Dreadshadow Lv 38 Tech Magician Moderator

    Messages:
    3,826
    Likes Received:
    2,469
    First Language:
    Greek
    Primarily Uses:
    RMMV


    Yes that's what I suggested but it seems it is hard for some users.


    @Cheah Hsun Teik


    Where did you bought MV from? :)
     
    Last edited by a moderator: Dec 2, 2016
    #7
  8. Cheah Hsun Teik

    Cheah Hsun Teik plugin fixer Veteran

    Messages:
    35
    Likes Received:
    5
    Location:
    Malaysia
    First Language:
    English
  9. Dreadshadow

    Dreadshadow Lv 38 Tech Magician Moderator

    Messages:
    3,826
    Likes Received:
    2,469
    First Language:
    Greek
    Primarily Uses:
    RMMV
    Great. Since you own it from there, you got the option to ask for supprot, you are at the correct place and thread category too!


    Some people told you already how to do it.  Once updated, you got all plugins working (hopefully) assuming no issues will occur and plugins are compatible. So why not? It is worth the time. Otherwise maybe follow their instructions? :)
     
    #9
    Cheah Hsun Teik likes this.
  10. Kes

    Kes Global Moderators Global Mod

    Messages:
    20,414
    Likes Received:
    10,416
    First Language:
    English
    Primarily Uses:
    RMVXA
    I've moved this thread to JS Plugin Support. Please be sure to post your threads in the correct forum next time. Thank you.


    All plugins will soon be assuming that you have at least version 1.3 so you will find this problem will only grow.  Please follow the advice to update your copy of MV.
     
    Last edited by a moderator: Dec 2, 2016
    #10
  11. Zalerinian

    Zalerinian Jack of all Errors Veteran

    Messages:
    4,695
    Likes Received:
    921
    Location:
    The Internet.
    First Language:
    English
    Primarily Uses:
    N/A
    Also, regardless of what version of MV you're using, I find it incredibly unlikely you'll be able to combine the difference "engines" into one project without a lot of modifications ensiring their compatibility. As I recall, Victor's scripts in particular were a pain to deal with on VXAce, though I haven't really looked at any of his MV stuff. 
     
    #11
  12. Wookiee420

    Wookiee420 Veteran Veteran

    Messages:
    294
    Likes Received:
    131
    Location:
    Colorado
    First Language:
    English
    yeah like ksjp17 said, but sometimes longer explanations help. when the program gets an update then the plugins must be updated as well, so seeing as you are 3 versions (and a few stability updates) behind your plugins will slowly start to work less and less (as they get updated) and your game will break. The only thing to prevent that is if you somehow were able to get all your plugins before anything was updated, because if you take Yanfly for example, he is all updated to 1.3.4 or get your program to update to current version.
     
    Last edited by a moderator: Dec 2, 2016
    #12
  13. Crabs

    Crabs Veteran Veteran

    Messages:
    153
    Likes Received:
    107
    Location:
    Brazil - São Paulo
    First Language:
    Portuguese
    It's possible. Moghunter's and Yanfly's plugins work well together. But as Zalerinian said, Victor's scripts has some weird behavior, but I didn't have to change the source-code, just putting it on the end of the plugin list was enough for me to make it work.


    Just keep in mind that if you decide to change the game resolution with Yanfly's Core Engine and use any Moghunter's HUD plugins, you will have to do a lot of configuration changes and image editing. But still there will be no necessity to edit code.
     
    Last edited by a moderator: Dec 2, 2016
    #13
  14. Andar

    Andar Veteran Veteran

    Messages:
    28,155
    Likes Received:
    6,375
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV


    Between 1.0 and the current 1.3.4 there were a lot of changes (for example changing from pixi V2 to pixi V4) that made a lot of scripts incompatible.


    It will be almost impossible for a lot of current scripts to run on a project based on the 1.0, you'll HAVE TO update at some time.


    If you don't have the space for the full installer on your computer even after deinstalling the existing maker version, then ask around in your family for the loan of an USB stick for a day or two and download and run the installer from that USB stick instead of your harddrive and give it back to the owner after you're finished.


    And if your internetconnection is too slow, consider using that USB-stick to download the full installer somewhere else and transfer it to your computer that way.
     
    #14
  15. Volkner

    Volkner Warper Member

    Messages:
    4
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMVXA
    Hi. I know how to use simple scripts and I love Arc Engine by Khas and Sapphire Action System by Khas, and of course, the original system! Can I switch between these three systems in different maps? Please help

    Thank you
     
    #15
  16. Kes

    Kes Global Moderators Global Mod

    Messages:
    20,414
    Likes Received:
    10,416
    First Language:
    English
    Primarily Uses:
    RMVXA

    Volkner, please refrain from necro-posting in a thread. Necro-posting is posting in a thread that has not had posting activity in over 30 days. You can review our forum rules here. Thank you.


    It's been well over 2 years since the last post.
    In addition, this is for MV and the information under your avatar says VX Ace. Solutions in one will not necessarily work in the other, as they use different programming languages.

    I suggest you may a new thread in RGSSx Script Support specifying which scripts you are referring to, and telling us what you have done so far to establish compatibility; what problems you have had; any other details which you think might help people to help you.

    Closing this

     
    #16
Thread Status:
Not open for further replies.

Share This Page