Can too many Parrarel Events cause the game to freeze?

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
646
Reaction score
582
First Language
English
Primarily Uses
RMMV
Well from what I understood it is that the game froze and the next time it worked. I'm hoping if I remove the parallel from the berries the game will work better.
 

Engr. Adiktuzmiko

Chemical Engineer, Game Developer, Using BlinkBoy'
Veteran
Joined
May 15, 2012
Messages
14,682
Reaction score
3,005
First Language
Tagalog
Primarily Uses
RMVXA
You should probably instruct your testers to always be wary of the situations before they encounter a bug so that they can report exactly what hapoened because unless you get to know what the real problem was, it might happen again and again. That would be bad once this is a released game.
 

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
646
Reaction score
582
First Language
English
Primarily Uses
RMMV
I don't understand what is causing it to freeze though. I do have night/day events set on parallel on every map. Hopefully that isn't doing it?
 

Nilom

Veteran
Veteran
Joined
Sep 9, 2013
Messages
178
Reaction score
40
First Language
German
Primarily Uses
RMMV
Do you have something like a testproject for us to test? Or screenshots of your parallel events?
 

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
646
Reaction score
582
First Language
English
Primarily Uses
RMMV
Here is my Day and Night parallel event. It's really the only one on every maps.
 

Attachments

  • day night.png
    day night.png
    140.2 KB · Views: 7

Nilom

Veteran
Veteran
Joined
Sep 9, 2013
Messages
178
Reaction score
40
First Language
German
Primarily Uses
RMMV
I think it might have something to do with your tint screens having an infinite loop. Because the IF condition will always be true the screen gets tinted over and over again. Am I right?
Edit: Ah I see you didn't set tint screen to wait. Maybe it isn't the issue.

Did you check F8 while running the game? Is there some red text in the window appearing?
 
Last edited:

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
646
Reaction score
582
First Language
English
Primarily Uses
RMMV
I'm on a laptop, I cannot use any of the F buttons to check things in game. =/ It sucks and I don't know another way around it.
 

Nilom

Veteran
Veteran
Joined
Sep 9, 2013
Messages
178
Reaction score
40
First Language
German
Primarily Uses
RMMV
Your Laptop should have an FN button or something the like. If you hold it then your regular buttons 1-0 (or other buttons) should have F functions.

function-key-on-windows-pc-1024x1024.jpg



Alternatively you can just use windows 10's on-screen keyboard. Search for it in the start menu.
1.png
 
Last edited:

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
646
Reaction score
582
First Language
English
Primarily Uses
RMMV
Yeah, neither one of your options is working. =/

I've tried holding F and then hitting 8 and F8. I tried the virtual keyboard and did the same but that didn't work either. F8 for me is increase volume and that is what is does.

Though I've only tried F8. This works fine on my desktop IIRC but I only have my laptop with me for the time being so desktop is out of the question.

I loaded the test game and pressed the buttons but nothing happens when I press F8, virtual key board or while holding the FN button.

It would be nice if I could see the screens for switches and variables used in the game but oh well.:kaoswt:

Thanks for trying to help.
 

Nilom

Veteran
Veteran
Joined
Sep 9, 2013
Messages
178
Reaction score
40
First Language
German
Primarily Uses
RMMV
This is very odd.
Normally, while pressing FN, they F8 key should be active and not change your volume.
It's also strange that the on screen keyboards F8 key doesn't work aswell.
Did you somehow mess with the windows key shortcuts?
Can you make a picture of your keyboard? Or tell us the model number of your notebook?
 

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
646
Reaction score
582
First Language
English
Primarily Uses
RMMV
I really doubt I have messed with Window key shortcuts. That's not something I would mess with.

And I do not know how to tell you the model number. I can tell you it is an HP though.

I'm sorry I'm not that helpful. Would be awesome if I could get this problem resolved though. Because then I wouldn't have to make events to check for variable status and such. =/
 

Nilom

Veteran
Veteran
Joined
Sep 9, 2013
Messages
178
Reaction score
40
First Language
German
Primarily Uses
RMMV
Yeah I see. And you need to get your F keys to work. It is essential to be able to use the debug tool. And for other every day use it is a must have too. Not having Alt + F4..? I would have smashed my PC long ago.:kaodes::kaoblush:

Does your keyboard have an FN Lock or an F Mode key? If so, press it and try it again. (Holding FN + the key that has a tiny F8)
If not hold FN + Esc.
Then try it again. (Holding FN + the key that has a tiny F8)
If that didn't make it work press F11, then F12 (one after another).
Then try it again. (Holding FN + the key that has a tiny F8)

I still think the on screen keyboard should have a normal working F8 key for you, tough. :kaoswt:
 
Last edited:

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
646
Reaction score
582
First Language
English
Primarily Uses
RMMV
I can do Alt + 3 to make ♥

Here, I attached a screenshot.

Also, I am holding FN and then pressing F8 on my keyboard. Nothing happens in the game. Pressing F11 does nothing and Pressing F12 just turns airplane mode on. o-o

Pressing Fn + ESP brings up the system information

I'll keep trying.

Edit: How do you hold the FN key and then press F8 on the windows keyboard?
 

Attachments

  • keypad.png
    keypad.png
    821.5 KB · Views: 6

Nilom

Veteran
Veteran
Joined
Sep 9, 2013
Messages
178
Reaction score
40
First Language
German
Primarily Uses
RMMV
How do you hold the FN key and then press F8 on the windows keyboard?
You do not need to hold FN on the on screen keyboard. Just press FN and then a F key, for example F8.

I think there might be something wrong with your keyboard drivers.


You could try this.


As a next step I would suggest updating your keyboard drivers.


You probably should change your FN key behaviour anyway. You can reverse it's function. So you do not need to press FN to use your normal F1-F12 keys, but instead need to press FN to increase volume etc.

Here is how it is done:
 
Last edited:

Bex

Veteran
Veteran
Joined
Aug 2, 2013
Messages
1,502
Reaction score
411
First Language
German
Primarily Uses
RMMV
If you have the newest MV Version installed and your Project runs old Version Library, than F9 for Variable and Switch Hud isnt working.
Maybe other F Number stuff also?

Yes repeating a Tint Screen 60times per second, sucks very much of your performance reserves. Not good.

If your Game realy Freezes or Player cant move, than you maybe have "Autorun" instead of "Parallel" choosen on one of your bushes.
Or one of your Cutscenes which uses Autorun, isnt ended properly and keeps running?
 

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
646
Reaction score
582
First Language
English
Primarily Uses
RMMV
It's not Auto run. The test player said that it froze and then it worked. The game just doesn't freeze and then suddenly works.

Edit: Just scanned for trouble shoot as shown in the first video and then searched for latest drivers as seen in the second video. Nothing was found to be troubled and everything was up to date.

Guess I'll keep pressing buttons and see if I can make it work on MV.

Edit: I don't think it is meant to be. Oh well. Thanks for trying to help. I don't think anything is wrong with my drivers, just not compatible with Rpg Maker Mv on a laptop.
 
Last edited:

Nilom

Veteran
Veteran
Joined
Sep 9, 2013
Messages
178
Reaction score
40
First Language
German
Primarily Uses
RMMV
Then try the 3rd solution. Set your F keys to be standardly used.
 

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
646
Reaction score
582
First Language
English
Primarily Uses
RMMV
I'm not that techno savy. I'm afraid I will ruin my laptop. :kaoswt: Maybe another time I will try it, maybe I won't. I'm tired tonight and I'm ready to give up.
 

Nilom

Veteran
Veteran
Joined
Sep 9, 2013
Messages
178
Reaction score
40
First Language
German
Primarily Uses
RMMV
It is pretty easy to do.
  • Reboot your System
  • Hold ESC while it is doing so
  • Press whatever it tells you to press to enter the Bios
  • Navigate with the arrow keys to System Configuration / Configuration
  • Find and navigate to Action Key Mode / HotKey Mode
  • Press Enter
  • Set it do Disabled
  • Safe your changes by pressing F10. If no window pops up press FN+F10
  • Inside the pop-up screen press Yes to exit and to safe your changes
  • (If neither F10, nor FN+F10 made the pop-up window appear then navigate to Exit and Safe & Exit there)

You can rethink about that tomorrow. :kaohi:
 

Sakurra

I want a brownie.
Veteran
Joined
Sep 1, 2015
Messages
646
Reaction score
582
First Language
English
Primarily Uses
RMMV
I think I have found the problem for the freezing. It is the video clips that play.

I use this site to convert files
https://video.online-convert.com/convert-to-webm


But sometimes the video plays in the game and other times it does not. Any way to fix this?
 

Latest Threads

Latest Profile Posts

I'm so freaking pissed right now i want to scream and rant and rave
It's a new month, and it's a new start! Let's go guys! There is one song I am listening today that is making me really happy and thinking that I can do anything... I don't know why but J-Pop have this kind of vibe and I love hahahaha
If you want something to bring you up here is a little tip!
Tarzanthecat wrote on hiddenone's profile.
THANK YOU SO MUCH HIDDENONE ADSKFSJDFSKDF
Another unscheduled stream for Lightestone~ this time because we hit affiliate! Aaaahh- So other than the game we're also going to work on emotes/badges/etc!

www.twitch.tv/riazey

Forum statistics

Threads
108,981
Messages
1,041,034
Members
141,448
Latest member
El_Palito45
Top