Cannot read property 'name' null (RPGMaker MZ VisuStella Battle Core)

Status
Not open for further replies.

Myriadnaut

Warper
Member
Joined
Aug 2, 2022
Messages
3
Reaction score
2
First Language
English
Primarily Uses
RMMZ
Hello there
I've recently been having issues with my game in regards to the VisuSTellaMZ Battle Core
I have an enemy set to use a skill on turn five that works as a scripted loss, leading to further story progress.
But instead pulls up this error of "Cannot read property 'name' null" with these as the reasons
1660168905408.png
This same error occurred when i tried to differentiate between enemies' attacks and give them unique skills to use as opposed to the ones set in the plugin settings.
The sequence works just as intended should I turn off the battle core, but I require the battle core for its battle weather effect.
What should I do to fix this error? I've tested and shut off all plugins that were incompatible with the VisuStella plugins, but the error remains.
1660168741368.png
Much thanks in advance.
 

Arthran

Veteran
Veteran
Joined
Jun 25, 2021
Messages
617
Reaction score
615
First Language
English
Primarily Uses
RMMZ
It looks like the skill animation, or the cast animation, is trying to play a sound effect that doesn't exist. Check the animations in your database, and make sure that it is referencing valid sound effects. And make sure that there aren't some invalid sound effects being referenced in your plugin parameters.
 
Last edited:

Myriadnaut

Warper
Member
Joined
Aug 2, 2022
Messages
3
Reaction score
2
First Language
English
Primarily Uses
RMMZ
It looks like the skill animation, or the cast animation, is trying to play a sound effect that doesn't exist. Check the animations in your database, and make sure that it is referencing valid sound effects. And make sure that there aren't some invalid sound effects being referenced in your plugin parameters.
Alright, after checking, it actually had to do with the skill type being used
Rather, I had the skill animation under certain hit instead of magical or physical
after changing the two, the error cleared up.
Thank You!
 

Arthran

Veteran
Veteran
Joined
Jun 25, 2021
Messages
617
Reaction score
615
First Language
English
Primarily Uses
RMMZ
Alright, after checking, it actually had to do with the skill type being used
Rather, I had the skill animation under certain hit instead of magical or physical
after changing the two, the error cleared up.
Thank You!
Battle Core plays a cast animation when you use skills. By default, it has a different cast animation for Certain Hit, Physical, and Magical. From what you described, it I believe there's a chance that the cast animation that it's playing for Certain Hit has some type of problem. The error message makes it look like the animation was trying to play a sound that doesn't exist.

If you go into Battle Core's plugin parameters, and look under Action Sequence Settings -> Cast Animations -> Certain Hit, it will tell you which animation ID is set for Certain Hit's cast animation. By default, I think it's ID 120, but you should double check.

I'd recommend that you go find that animation in your database, and make sure that there is not a problem. Make sure that the animation itself exists, and that the sound that it's set to play exists.
 

Myriadnaut

Warper
Member
Joined
Aug 2, 2022
Messages
3
Reaction score
2
First Language
English
Primarily Uses
RMMZ
Yep, made sure to fix/check on the stuff you suggested.
It seems like that wont be an issue anymore
Battle Core plays a cast animation when you use skills. By default, it has a different cast animation for Certain Hit, Physical, and Magical. From what you described, it I believe there's a chance that the cast animation that it's playing for Certain Hit has some type of problem. The error message makes it look like the animation was trying to play a sound that doesn't exist.

If you go into Battle Core's plugin parameters, and look under Action Sequence Settings -> Cast Animations -> Certain Hit, it will tell you which animation ID is set for Certain Hit's cast animation. By default, I think it's ID 120, but you should double check.

I'd recommend that you go find that animation in your database, and make sure that there is not a problem. Make sure that the animation itself exists, and that the sound that it's set to play exists.
 

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
9,945
Reaction score
6,305
First Language
Dutch
Primarily Uses
RMXP

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

New sprites & animations for Mint and Beri are coming along!
Guh-Colorbound.gif
ScreenShot_10_5_2022_4_44_8.png
Mad O' Malley... a stick figure that's afraid of it's existence being erased. so they always start battle in an anxious state.
Before, I was drawing all the sprite work, super big and shrinking it down. Which was really time consuming if thing's changed. So instead I'm drawing the characters sketch, and then remaking it with pixel art instead.
Why are job interviews so terrifying. :kaodes:

Forum statistics

Threads
125,801
Messages
1,173,664
Members
164,964
Latest member
oliveleaf
Top