RMMV Cannot seem to get masks working in my cleaning plugin when exporting to Windows

GreenTree-Studios

Creator of Dragon Bones
Member
Joined
Feb 3, 2021
Messages
17
Reaction score
1
First Language
English
Primarily Uses
RMMV
Hello, just one more question and I'll leave you guys alone. I plan to export a demo, alongside the plugin that makes up most of the demo, to Windows, but it appears that when I apply masks to an exported game, it disables all masks I've used in the Cleaning Core Plugin.js file.

This is what I did when I export it:
  1. I don't exclude unused files because if I do that then it will get rid of the cleaning folder and it's image files.
  2. I try to encrypt image files. However, it doesn't use the image files I placed specifically in the img folder.
  3. I do encrypt the audio files.

Figure 1 (Below) this is what it looks like when I playtest in the engine.

1627265060691.png

Figure 2 (Below) this is what it looks like when I play the exported game.
1627265497022.png

If there is any possible tip that can help, it would be heavily appreciated.

P.S. If you'd like to view my code, just send me a Private Message. I don't prefer to distribute my own plugins to other fellow RPG Makers publicly.
 

Latest Threads

Latest Posts

Latest Profile Posts

today is my birthday
Don't you just hate it when you get a high level armor only for it to look like a metal plated bikini on your female character?? Seriously. How can that protect you??? Enemies can hit the squishy parts! :kaosigh:
Bathrooms are not designed for the middle of the night.
so... I decided since a park was an area in my game... here's an enemy that's slide with a hand behind it. cause why not.

Forum statistics

Threads
115,277
Messages
1,088,556
Members
149,886
Latest member
Br8228
Top