can't equip weapon

monissa

Warper
Member
Joined
Jan 29, 2016
Messages
2
Reaction score
0
First Language
english
Primarily Uses
I have an event that places a weapon in the character's inventory. But the weapon isn't able to be equipped. The character can use it if I place the weapon in their inventory before the start of the game..But if obtained in this fashion, I can't do anything with it.


Event: http://tinypic.com/view.php?pic=rvc2te&s=9#.VqrH4rIrKUk  http://tinypic.com/view.php?pic=2z3xndj&s=9#.VqrIB7IrKUk


Actor: http://tinypic.com/view.php?pic=2u5xe13&s=9#.VqrIYLIrKUk


Class: http://tinypic.com/view.php?pic=oknzvb&s=9#.VqrIe7IrKUk


Weapon: http://tinypic.com/view.php?pic=33dl7at&s=9#.VqrIrrIrKUk


I cannot figure out what I've done wrong.
 

thehackeryacker

Veteran
Veteran
Joined
Jan 12, 2016
Messages
44
Reaction score
9
First Language
English
Primarily Uses
@monissa


Everything appears to be in order, class has flail equip, weapon set to flail, event adds constant +1, and actor set to class. Have you tried making another event (try quick event, chest , add broken mannacles.) and see if that works? Or try saving, closing RMMV, and re-opening it, trying again...


can you take a picture of your systems tab as well?


Does the weapon appear in the inventory when testing the game and the event?


I attmepted to recreate with all the same, I am not getting the error. Strange. Is it possible you changed settings and didnt save , check your database again.
 
Last edited by a moderator:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
29,230
Reaction score
6,776
First Language
German
Primarily Uses
RMMV
Can you check if you have two weapons of the same name, or two weapon types "flail" in the database?


The engine works on ID, not on name, and similiar problems have occurred in the past when users accidentally had several entries with the same names and selected the wrong ones in the event.
 

monissa

Warper
Member
Joined
Jan 29, 2016
Messages
2
Reaction score
0
First Language
english
Primarily Uses
Okay um. After looking around and getting some more pictures I found you aren't supposed to be equipping weapons from the 'item' tab in-game..But from 'equip' tab. <-< OOPS. would've taken me longer to figure it out without help so thanks!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Stream will be live shortly with some more Haunting Ground! Today, we encounter a new stalker! Feel free to drop by!
Tried the new Samsung Galaxy S20 Plus today. Very nice device overall, but flagship smartphone prices are getting completely out of control.
Sometimes I feel like I don't belong here. I feel like I have the exact opposite interests in storytelling as everyone else.
You know what really grinds my gears? Websites that block your access completely if you have an AdBlocker on...

I would rather skip the site than endure some popups that may give me a gnarly virus!
Guys this thread is so good and you should be reading it.

Forum statistics

Threads
94,493
Messages
921,413
Members
124,349
Latest member
Louxie
Top