DracoVanReign

Villager
Member
Joined
Jan 21, 2020
Messages
8
Reaction score
11
First Language
English
Primarily Uses
RMMV
I did all of that. The issue I'm having is that the sprites don't appear on-screen when I set them up with a prefix. Should the plugin be set in any specific order? Does it conflict with any other plugins?
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,789
Reaction score
15,914
First Language
English
Primarily Uses
RMMV
Are you aware that there are two folders for enemy sprites, and two folders for actor sprites? One is for side view and one is for front view. You have to have sprites in the correct folders, depending on whether you're doing front view or side view battles.

You still set up the troops the normal way (the sprites will be whatever you have in the system tab - front or side view).
 

wbthehero

Villager
Member
Joined
Apr 5, 2021
Messages
17
Reaction score
1
First Language
English US
Primarily Uses
RMXP
hello so I've been trying to get this to work but every time i use this plugin it makes it so the game can't read any files I've tried to reset and such do you know a good work around Shaz?

here are how the troops look but it does not read the files inside the game and says can't find this or this when it is there in all correct folders.
hello so I've been trying to get this to work but every time i use this plugin it makes it so the game can't read any files I've tried to reset and such do you know a good work around Shaz?
 

Attachments

  • Screenshot 2021-12-06 151704.png
    Screenshot 2021-12-06 151704.png
    217.1 KB · Views: 7

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,789
Reaction score
15,914
First Language
English
Primarily Uses
RMMV
@wbthehero

A screenshot of the error message from the console would be helpful here.

For troops starting with FV, or no prefix if you've selected front view in the System tab, the enemy sprites need to go in the img/enemies folder. For troops starting with SV, or no prefix if you've selected side view in the System tab, the enemy sprites need to go in the img/SV_enemies folder.

If that doesn't help, please give the following screenshots:
- F8 and go to Console tab when the error occurs, so we can see the exact error message and what's triggering it
- Troops tab, with the troop you're currently attempting to fight selected
- plugin manager

Also confirm if you're using the Battle Test command in the Troops tab or the Play Test command.


I've merged your posts. Next time please edit to add more information, rather than making several posts in a row :)
 
Last edited:

PixelBoy360

Veteran
Veteran
Joined
Apr 11, 2015
Messages
52
Reaction score
7
First Language
English
Whenever I go to attack an enemy in a troop with FV. The game crashes and shows this error:

Is this because I'm using MZ instead of MV?
1648577722439.png
 

Oggy

Villager
Member
Joined
Jun 1, 2022
Messages
24
Reaction score
12
First Language
English
Primarily Uses
RMMZ
Thank you so much for this! Simple and functional, I love it. @PixelbBoy360 I just tested this in my project in MZ and it seems to work for me.
 

Latest Threads

Latest Posts

Forum statistics

Threads
124,349
Messages
1,162,948
Members
163,147
Latest member
onbetme
Top