Amarok

Veteran
Veteran
Joined
Dec 15, 2016
Messages
298
Reaction score
733
First Language
Spanish
Primarily Uses
RMMV
Hello there, im trying to change this with no luck so far.
After scouting the internet i saw people used yanfly ExtMesPack1 plugin to change this with the \msgposx[x] text command.
This however doesnt seem to do anything for me.

I also tried moving the text itself to the right but then i would also need to move the face to the right, and i can't figure how to do this either...

Has anyone found the same issue or knows another way to achieve this? thanks in advance!
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,763
Reaction score
8,971
First Language
German
Primarily Uses
RMMV
if a plugin doesn't do what it is suppoesed to do, then you either have an incompatibility with another plugin or made a mistake installing it.
Please give us a screenshot of your projects plugin manager and tell us the version number inside its rpg_core.js file (open with text editor)
 

Amarok

Veteran
Veteran
Joined
Dec 15, 2016
Messages
298
Reaction score
733
First Language
Spanish
Primarily Uses
RMMV
@Andar kinda ashamed of showing this, since i just realized how much of a mess my plugin list is, maybe i should start troubleshooting there and erasing all the plugins ive accumulated that i dont really use, but well here it is:
Version plugin for yanfly ExtMesPack is 1.12

bCJbs7t.jpg

Here is my message box too
VzUbrK6.jpg
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,763
Reaction score
8,971
First Language
German
Primarily Uses
RMMV
your yanfly plugins need to be reordered, and you should remove the double-installed ones like the core (not only shut them off).
yanfly's plugins have to be in the order given on his website.
But most likely this is an incompatibility with one of the other plugins, you'll have to test that by disabling them one by one and testing with a new game (never a saved game) after each change in the plugin manager.

edit:
you didn't give your core version number, that is actually more important than the other data
 

Amarok

Veteran
Veteran
Joined
Dec 15, 2016
Messages
298
Reaction score
733
First Language
Spanish
Primarily Uses
RMMV
Ah right, the message core ver is 1.19, also thank you, i thought it was enough to just turn a plugin off.
Im going to clean and reorganize the plugin list and edit this message if i find whats causing the problem.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,763
Reaction score
8,971
First Language
German
Primarily Uses
RMMV
Ah right, the message core ver is 1.19, also thank you,
that is not the question I asked. I asked for the version of the rpg_core.js file of your project - not the version of any plugin (those are visible in most cases in the plugin manager.
Open your project folder, look for the file named "rpg_core.js" (which is a javascript file but NOT a plugin file), rightclick it and open it with a text editor (notepad is enough) and read the version number in the title line.
if there is no version number, it would be 1.0 and a problem in itself.
 

Amarok

Veteran
Veteran
Joined
Dec 15, 2016
Messages
298
Reaction score
733
First Language
Spanish
Primarily Uses
RMMV
oh sorry! i really suck at anything coding related xD
rpg_core.js v1.5.1 ive been reluctant to update since i didnt want any of the plugins i was using to break.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,763
Reaction score
8,971
First Language
German
Primarily Uses
RMMV
It's most likely a compatibility issue between plugins then, and you have too many plugins (including too many unknowns) to start guessing (unless it's galvs message plugin).

you can only start testing - probably best to do that in a new project where you add one plugin after another until the position no longer works as intended.
 

Amarok

Veteran
Veteran
Joined
Dec 15, 2016
Messages
298
Reaction score
733
First Language
Spanish
Primarily Uses
RMMV
Alright, i deleted all the plugins i had off, deleted galv message plugin (i had forgot it was even there) and now it works.
Massive facepalm on myself and problem solved, thank you so much @Andar
 

Latest Threads

Latest Profile Posts

SF_People3_3 added!
index.php

ScreenShot_1_3_2022_1_32_12.png
I feel QSprite for MV is underrated. I basically am able to use my chibi sideview battlers I drew on the maps and have all the motions available. this'll help a lot with cutscenes.
I've figured out how to reasonably tall-ify chibi sprites on my editor. I like that making tall sprites gives me control on expressing how tall characters seem on the field relative to each other as well as better differentiate adult sprites from child sprites.
doing some wacky experimental stuff in MV right now :kaoluv: I cannot wait to drop what I've been working on
Doing RPG Maker News for this week. (January 14th - 20th, 2022)

Forum statistics

Threads
118,557
Messages
1,116,943
Members
155,598
Latest member
kitismad
Top