character sprite doing strange things?

Discussion in 'RPG Maker 2000/2003' started by somehumanbeingpersonman, Jan 22, 2019.

  1. somehumanbeingpersonman

    somehumanbeingpersonman Warper Member

    Messages:
    4
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RM2k3
    was trying to create a simple character sprite for a game, and it worked fine first off. tried to edit the sprite in the form of newer versions, but it came out not fitting exactly into the frame and making my character, instead of the sprite, a giant green blob with my sprite's shape of a hole in the center of such green blob. ive been trying to fix this for like 3-4 hours, and its making me go mad. please help.
     
    #1
  2. JosephSeraph

    JosephSeraph White Mage Restaff

    Messages:
    862
    Likes Received:
    719
    Location:
    Santos, Brasil
    First Language:
    Portuguese
    Your character probably was a single colour sillouette and the program is understanding your character's color to represent transparency, rather than the background green. The solution to this is to actually use RM2k3's resource importer, or (i dont know how to explain this without using GraphicsGale, my freeware pixel art software of choice) making sure to use the first color on the palette as your transparency color.
    upload_2019-1-21_23-54-4.png upload_2019-1-21_23-55-21.png

    The first is easier to understand but the second can be more practical if you're doing a lot of custom art or editing a lot.
     
    #2
  3. somehumanbeingpersonman

    somehumanbeingpersonman Warper Member

    Messages:
    4
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RM2k3
    so, i went ahead and did this and made the transparency thing the pink color. but, the problem is that after doing this, the game's screen when starting it in a room with the tileset is just pink, nothing else. also, when viewing it in the event/upper layer editor its also just pink. idk how to fix this either... i just don't know a lot about the program.

    this is the tileset i am using now:
    [​IMG]

    this is what i see when starting the game: (unfortunately my screencap wouldn't screenshot the entire screen, but its basically a pink square with black around it)
    upload_2019-3-23_16-16-21.png

    this is what it looks like when viewing in the event editor:
    upload_2019-3-23_16-17-36.png

    and also, sorry for not replying for a couple of months; i've just been really busy.
     
    Last edited by a moderator: Mar 24, 2019
    #3
  4. Andar

    Andar Veteran Veteran

    Messages:
    28,627
    Likes Received:
    6,573
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    it looks as if you messed up the transparency.

    As the poster above said, you need to use the exact color of the first palette position for transparency. It will NOT work if you just set a color that seems to be identical to a human eye, its numerical value needs to be the exact one, and it should be the same color through every resource used.

    Additionally, the map should be screen size at minimum, if the map is smaller than the screen size then this can cause some display troubles as well.
     
    #4

Share This Page