ImaginaryVillain

High Cultist of the Sporkle
Veteran
Joined
Jun 22, 2019
Messages
959
Reaction score
5,866
First Language
Absurdism
Primarily Uses
RMMZ
Good to know, no guarantees that we'll fix it. But at least we know now in case someone wants to take on the challenge.

@DarkSearinox92 Other than probably updating the coordinate system at some point. I hadn't really planned anything. Then again that's the beauty of this project, anybody can update it. :LZSwink:

@Nekohime1989 The Github has been updated with your fix. :LZSexcite:
 

Platsch

Veteran
Veteran
Joined
Apr 23, 2016
Messages
100
Reaction score
109
First Language
German
Primarily Uses
N/A
Hello
I love this plug-in.
Can someone help me with my problem, please.
If I use (<Activation Square: 3>) at a fire event and approach the fire, the fire will come on.
But how do I get the light off again when I move away from the fire?
Thank you

1.png
 

ScorchedGround

Blizzards most disappointed fan (More than ever)
Veteran
Joined
Apr 12, 2020
Messages
742
Reaction score
1,116
First Language
German
Primarily Uses
RMMV
@Platsch What plugin are you even using? I don't recall (<Activation Square: 3>) being a function of this plugin, so where is that from? A temporary, but tedious solution would be to sorround the fire in question with events that upon player-touch turn off the fire again.



@ImaginaryVillain Concerning my light-lagging issues;
One peculiar thing I found (and a temporary or even permanent fix(?) for my light-lagging-problem) is that it seems that if the affected events have any kind of autonomous movement, their light will NEVER lag behind.

So what I did was I went to every problematic event that suffered from light lagging behind and changed the "autonomous movement type" from fixed to custom. I didn't even have to put any commands into the custom route and it still works!

YOU DONT CALL IT OAK ISLAND FOR NOTHING.png
 

stramin

Veteran
Veteran
Joined
Nov 4, 2012
Messages
316
Reaction score
151
First Language
spanish
Primarily Uses
N/A
I has been using TerraxLighting plugin for more than a year and I wanted to try Community_Lighting.

Sadly it is not working at all, and I don't understand why, I turned off TerraxLighting and Community_Lighting is just below:

1603418185252.png

Do I need to do some additional steps in order to make it work?
Do I need to start a new game?

Thank you!
 

ImaginaryVillain

High Cultist of the Sporkle
Veteran
Joined
Jun 22, 2019
Messages
959
Reaction score
5,866
First Language
Absurdism
Primarily Uses
RMMZ
@stramin It defaults to having CL as the tag indentifier for lights. If you want to use Terrax's old tags, go into the plugin settings and delete that.
 

stramin

Veteran
Veteran
Joined
Nov 4, 2012
Messages
316
Reaction score
151
First Language
spanish
Primarily Uses
N/A
@stramin It defaults to having CL as the tag indentifier for lights. If you want to use Terrax's old tags, go into the plugin settings and delete that.
Wonderful! it works!

thank you!

I have another question, it seems like light blocking still not working for me, I want to block this tile:

1603418868037.png1603419013527.png

So, I wrote this command:

Code:
TileBlock 98 ON #000000

it this number (98) correct?

1603419724462.png

I also tried 97 and 99.

------------
EDITED
------------

Ok, I just read the whole topic and I see there is no way to achieve it.

I will try doing it using a black square or something.

Thank you!
 
Last edited:

ImaginaryVillain

High Cultist of the Sporkle
Veteran
Joined
Jun 22, 2019
Messages
959
Reaction score
5,866
First Language
Absurdism
Primarily Uses
RMMZ
This version for MV changes how coordinates are calculated and should fix the problem of lights not following events during their move routes. If nobody finds any problems I'll see about pushing it to the MZ version as well.

@ScorchedGround Give this version a test and see if it works. I ran it through the demo and couldn't find anything that didn't work. Still it never hurts to have multiple testers.

@KaYsEr As I have redone how coordinates are calculated. I did some minor testing with UltraMode7 and didn't see any problems. If you end up testing it let me know how it goes.

Edit: I accidentally edited the wrong version without the Lights Active Radius option, so I reuploaded the correct version.
 

Attachments

  • Community_Lighting.js
    91.7 KB · Views: 12
Last edited:

ScorchedGround

Blizzards most disappointed fan (More than ever)
Veteran
Joined
Apr 12, 2020
Messages
742
Reaction score
1,116
First Language
German
Primarily Uses
RMMV
@ImaginaryVillain
I did some testing with one of my major cutscenes and it seems that all lights updated accordingly.
Which is a great thing. So far I've not encountered any negative side effects, but I'll let you know when I find any.

Anyways, thank you for your time and effort, kind villain.
 

Moon_Haven

Veteran
Veteran
Joined
May 5, 2020
Messages
191
Reaction score
87
First Language
French
Primarily Uses
RMMV
EDIT: I've discovered that plugins cannot be upgraded just by copying the new version over the old one...
 
Last edited:

ImaginaryVillain

High Cultist of the Sporkle
Veteran
Joined
Jun 22, 2019
Messages
959
Reaction score
5,866
First Language
Absurdism
Primarily Uses
RMMZ
@Moon_Haven In the case of this plugin, it's probably the tag being off in the plugin parameters. People periodically seem to change it randomly when they update the plugin. Check that and see if it matches the tag you've been using. Otherwise you should be able to simply copy it over.
 

DarkSearinox92

Veteran
Veteran
Joined
Jan 8, 2013
Messages
589
Reaction score
121
First Language
Italian
Primarily Uses

ImaginaryVillain

High Cultist of the Sporkle
Veteran
Joined
Jun 22, 2019
Messages
959
Reaction score
5,866
First Language
Absurdism
Primarily Uses
RMMZ
The fire flicker seems to work in the demo with the updated script. Try comparing your setup to it. Also you'll have to add the updated script to the demo manually. Though the note commands haven't changed, so it's just a copy paste affair.
 

Aesica

undefined
Veteran
Joined
May 12, 2018
Messages
1,880
Reaction score
1,824
First Language
English
Primarily Uses
RMMV
If you try dropping the lateset version into the demo and it still doesn't flicker properly, let us know please. :D
 

ImaginaryVillain

High Cultist of the Sporkle
Veteran
Joined
Jun 22, 2019
Messages
959
Reaction score
5,866
First Language
Absurdism
Primarily Uses
RMMZ
As I don't have MZ to test with, this is a hypothetical update to the MZ version which should fix the text/move route light source problem. As the change is identical to the MV version I don't foresee any problems. But someone will have to test it for me and let me know.
 

Attachments

  • Community_Lighting_MZ.js
    109.3 KB · Views: 4

DarkSearinox92

Veteran
Veteran
Joined
Jan 8, 2013
Messages
589
Reaction score
121
First Language
Italian
Primarily Uses
Uhmm... Guys, i'm testing even the Demo and it doesn't seems to work the flickering :/

Try you use this:

Fire radius 70 #E2B822

i really don't see the flickering on the player radius :/
 

firestalker

Veteran
Veteran
Joined
Nov 18, 2015
Messages
401
Reaction score
56
First Language
English
Primarily Uses
RMMV
Is there a way to adjust amount of flicker a fire can have?

So you can make a big fire have more flicker than a small campfire... for example
 

Latest Threads

Latest Profile Posts

What happens with this list, is it currently possible to buy any of these RPGMAKER at least those that are for PC?

Combat skill combination demostration
grief... finding a font that works with the engine has been a bigger process than I thought it'd be. doesn't help MV loves to scrunch letters next to each other like a football huddle.
The new Phoenix plugin. I drew icons and an interface into it

Forum statistics

Threads
122,182
Messages
1,147,098
Members
160,455
Latest member
fajar82
Top