Compatibility issue with LB_EquipVariables and HIME_EquipSlotsCore Plugin

1234Tidus

Warper
Member
Joined
Nov 30, 2012
Messages
4
Reaction score
1
First Language
German
Primarily Uses
Hello fellow Game Makers,

i have a problem with two plugins. They won't work together at all.

I need HIME_EquipSlotsCore to add more Equip Slots to my game.
But i also need LB_EquipVariables by @LadyBaskerville to use my Costume system in my game.
But whenever i use LB_EquipVariables the game refuses to load. The Error Message shows:
this._equips.LB_toDatabaseObject is not a function.
My guess is they are incompatible. I also tried them in a separate Project. Same Error.
So i need some help so i can use both of them together.
Those are the Plugins in case you need them.
https://forums.rpgmakerweb.com/index.php?threads/equipment-variables.73457/#post-700634
http://himeworks.com/2015/11/equip-slots-core/

Any help with that Problem is appreciated.
 

LadyBaskerville

Hell-poodle
Veteran
Joined
Sep 12, 2016
Messages
645
Reaction score
529
First Language
German
Primarily Uses
RMMV
Does it make any difference if you change the order of those two plugins in the Plugin Manager? Also, could you please press F8 when the error comes up and show a screenshot of the console window that opens then?
 

1234Tidus

Warper
Member
Joined
Nov 30, 2012
Messages
4
Reaction score
1
First Language
German
Primarily Uses

@LadyBaskerville Thats the console when the crash happens.
If i move the Plugin above Himes thing i can start the game but the variable won't change in the menu.
If its below Himes Plugin the game won't start at all.
 
Last edited:

1234Tidus

Warper
Member
Joined
Nov 30, 2012
Messages
4
Reaction score
1
First Language
German
Primarily Uses
No one that can help me with the problem? I can't figure it out on my own...
 

LadyBaskerville

Hell-poodle
Veteran
Joined
Sep 12, 2016
Messages
645
Reaction score
529
First Language
German
Primarily Uses
RMMV
Sorry for the late reply, I hadn't had time to look into it properly before today.

Please download this version and replace your current EquipVariables with it. Keep it below Hime's plugin like you had it when the error messages came up.

The game should start again, but I haven't done too much testing with both plugins activated yet - so if you find any more issues let me know.
 

1234Tidus

Warper
Member
Joined
Nov 30, 2012
Messages
4
Reaction score
1
First Language
German
Primarily Uses
Its fine. I'm actually glad you helped me at all. It seems to work fine so far.
No crashes and i can finally change Costumes in my game again.
Thank you so much LadyBaskerville.
 

Latest Threads

Latest Posts

Latest Profile Posts

2021? I still wonder if people still doing MV than MZ more
Seeing a lot more active Ace topics recently, is it making a comeback? :o
0-7, left-to-right, top-to-bottom
As soon as I'm able to get out of bed I'm probably gonna go so hyper from being too cooped up, and burn myself out into another awful flare. lol
It makes me feel proud whenever an RM game does well. Even though I had nothing to do with it.

Forum statistics

Threads
107,627
Messages
1,031,013
Members
139,746
Latest member
Krunga
Top