Could I please get a few people to test this issue?

Status
Not open for further replies.

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,451
Reaction score
15,231
First Language
English
Primarily Uses
RMMV
Hi, another one we're having problems reproducing, that I'd like to get a few people to try out if possible ...


On a new map, add a single event, triggered by action button.


Add a Show Animation command, over the event, and use animation Heal One 1 (animation id 41).


Play game, interact with event, animation should show fine.


Now play in browser and see if the results are the same. I believe some of you will see no difference, but for some of you, the NPC sprite will go black during the animation.


https://www.dropbox.com/s/y09wicbp97806jv/Screenshot%202015-11-06%2015.46.50.png


Could you please advise whether it looks normal for you in the browser or not, and


- what version of MV you're running


- what browser and version you have


- whether your browser game is running in canvas mode


Thanks :)
 
Last edited by a moderator:

Alexa Angel

Veteran
Veteran
Joined
Oct 8, 2015
Messages
51
Reaction score
16
First Language
English
It all works for me..

Version 1.0.0 mv

Chrome version 46.0 it looks like.

Yes it is
 

nio kasgami

VampCat
Veteran
Joined
May 21, 2013
Messages
8,973
Reaction score
3,089
First Language
French
Primarily Uses
RMMV
can't see the picture :(
 

Schlangan

A madman with a computer
Veteran
Joined
May 20, 2015
Messages
1,439
Reaction score
1,726
First Language
French
Primarily Uses
RMMV
No problem for me on Firefox 42 and RPG Maker MV 1.0.1.


I wanted to test more, but the local server setup fails, so I can't test on other browsers for now. I'll try again tonight and I'll update this post if nobody has replied in between.
 

mlogan

Global Moderators
Global Mod
Joined
Mar 18, 2012
Messages
16,123
Reaction score
8,932
First Language
English
Primarily Uses
RMMV
Firefox 42.0, MV 1.0.0, no idea about canvas mode, but I had no issues
 

Berylstone

Veteran
Veteran
Joined
Jun 3, 2013
Messages
642
Reaction score
62
First Language
English
Primarily Uses
I would like to help out and test this also.  But I don't understand what it means to play in browser.

How do I go about doing that?
 
Last edited by a moderator:

mlogan

Global Moderators
Global Mod
Joined
Mar 18, 2012
Messages
16,123
Reaction score
8,932
First Language
English
Primarily Uses
RMMV
After you create a project, you can go into the project's folder and there is an file named "index.html". If you double click it, it will run the game in your internet browser.
 

Berylstone

Veteran
Veteran
Joined
Jun 3, 2013
Messages
642
Reaction score
62
First Language
English
Primarily Uses
After you create a project, you can go into the project's folder and there is an file named "index.html". If you double click it, it will run the game in your internet browser.
Thanks.

I was able to locate a file called "index" with the google chrome logo.  However when I double-clicked it I got this, Error Failed to Load: data/Actors.json.

So I didn't get very far at all - and wasn't able to get into the game from there to test the event.  I'm not sure why.  
 
Last edited by a moderator:

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,451
Reaction score
15,231
First Language
English
Primarily Uses
RMMV
Look in the manual at the section on Local Server Setup. You have to set up a few options and put your project into that folder in order to be able to run it in a browser.
 

Galenmereth

Retired
Veteran
Joined
May 15, 2013
Messages
2,248
Reaction score
2,167
First Language
English
Primarily Uses
N/A
Tested in multiple major browsers now on three different OS's:

Windows 10:

  • Happens inChrome 46.0.2490.80 m
[*]Does not happen in:
  • Edge 20.10240
  • Firefox 42.0
  • Opera 33.0
Ubuntu:

  • Does not happen in:Chrome 41.0.2272.76
  • Firefox 37.0.2
OSX El Capitan (10.11.1):

  • Does not happen in:Chrome 46.0.2490.86 (this is interesting, considering this is the same version as the Win 10 Chrome build, but I think OSX Chrome uses a different WebKit build)
  • Safari 9.0.1
  • Firefox 38.0.5 and 42.0

So far I've only seen it happen in Chrome on Windows. I've verified that all browsers have used the WebGL rendering mode and thus using the GPU (although Ubuntu was using virtualized GPU).

The problem has to do with the Flash effect on sprites, which uses the method "setBlendColor", which in turn uses the blending functionality of WebGL in the Pixi library. From what I can tell, this has been fixed in Pixi v3 but I'm not sure. You'll see it happen in this demo I have too, where when clicking characters there's an animation that sets them to flash white, but in Chrome it flashes completely black instead.
 
Last edited by a moderator:

Berylstone

Veteran
Veteran
Joined
Jun 3, 2013
Messages
642
Reaction score
62
First Language
English
Primarily Uses
Look in the manual at the section on Local Server Setup. You have to set up a few options and put your project into that folder in order to be able to run it in a browser.
I created the inetpub folder and moved my project folder to the wwwroot folder.

But every time I type the address into my browser search bar I get this error:

ERR_NAME_NOT_RESOLVED

Edited#

I think I may have gotten it to work finally but it seems to be taking forever to load.  Now Loading....

I'll let you know if it ever loads.
 
Last edited by a moderator:

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,451
Reaction score
15,231
First Language
English
Primarily Uses
RMMV
Tested in multiple major browsers now on three different OS's:

Windows 10:

  • Happens inChrome 46.0.2490.80 m
Wouldn't you know that's exactly the browser I'm using, but I'm on Windows 8.1!  Thanks so much for testing on so many systems for me.
 
Last edited by a moderator:

RyokuHasu

Developer
Veteran
Joined
Jun 23, 2012
Messages
274
Reaction score
38
First Language
English
Primarily Uses
I can confirm it happens on my Windows 8 in the same chrome browser. I have a Windows 7 computer too that I can test it on if you want.
 
Last edited by a moderator:

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
43,451
Reaction score
15,231
First Language
English
Primarily Uses
RMMV
No, I think we're good here.  I've let them know, and I'll come back if they need further testing done.

Thanks for helping everyone :)  I'm going to close this up for the time being.
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

Who's a fan of firearms? The 5 on the bottom row (not including the green laser ones) I made pretty recently. I plan for most of these to be in my project.

Screenshot 2021-09-28 165924.png
Doing RPG Maker News for 28th September 2021

RMMV - Skip script errors:

For game developer testing purposes.
You know, I really get to farm likes since I post all of @Avery and @hiddenone 's blog tutorials on the forums...
Back from a very long hiatus with a new project woo
This is my battler placeholder image trying out art styles too I want to fake a backview battle system
I think I will want portraits and battle sprites to be 2D and stick to pixel art for overworld not 100%sure but pretty sure its easier to make pixel art for overworld sprites, events and maps and stuff.
Placeholder.png

Forum statistics

Threads
115,441
Messages
1,089,947
Members
150,226
Latest member
Reyeskhalifa32
Top