lithkast

Quirky mini boss
Veteran
Joined
May 12, 2014
Messages
105
Reaction score
49
First Language
english
Primarily Uses
As the title states, I'm having issues getting the stats to show up on the status screen.  Here is the code for reference.

Code:
    ## Stats settings    :stats2   =>  {      :enable      => true,      :width       => 220,      :line_height => 24,      :stats       => [:hit, :cri, :eva, :mev, :cnt, :mrf],            :names =>  {        :x       => 260,        :y       => 318,        :z       => 500,        :vocabs  => ["Hit", "Critical", "Evade", "Magic Evade", "Counter", "Reflect"],        :color   => [100, 200, 255, 255],        :outline => [0, 0, 0, 255],        :bold    =>  true,        :italic  =>  true,        :align   =>  0,        :font    =>  "Copperplate Gothic bold",        :size    =>  16,
When in game, I'm not getting anything to show up.  I know its not a z: positioning problem because the z position is the same as the main stats (ATK, DEF, ETC) and they show up just fine.  I've adjusted the x and y position on the off chance they were off screen but that didn't help either.  I only have the base Luna Engine 1.04 scripts installed + the window cursor script and CP Luna Status Config and Core.

any help would be appreciated.  I'll continue messing around and see if I can figure out the problem myself.  I'll update this post if I figure it out myself.  Thank you!
 

Warpmind

Twisted Genius
Veteran
Joined
Mar 13, 2012
Messages
937
Reaction score
580
First Language
Norwegian
Primarily Uses
Wouldn't it be better to just reference the xparam list directly?

Instead of the big block there, try something based off this:

  def draw_xparameters(x, y)
    6.times {|i| draw_actor_xparam(@actor, x, y + line_height * i) }
  end

Yes, that's based on the default Window_Status script; it's a good a place to start as any, I figure.
 

lithkast

Quirky mini boss
Veteran
Joined
May 12, 2014
Messages
105
Reaction score
49
First Language
english
Primarily Uses
problem solved.  did not realize there were multiple pages to this status menu to config.  so yeah, they were hidden on a separate page.  problem solved
 

Latest Threads

Latest Posts

Latest Profile Posts

It does sometimes get a little embarrassing that I often come here to ask for help with something and seldom have anything to actually show for it. If there is one thing though I can commend myself for, it's for sticking with an idea I've been tinkering with for this long now and gradually making headways. Even though I've been reserved about my progress, I can say I'm farther now than where I initially started.
I'm gonna put my project on pause for a tiny bit so I can explore the engine outside of it... Winging it can only get you so far LMFAO
Have seen some of my favorite people here posting and helping others with questions today -- love to see it!
Haven't been on here actively in awhile, project is going strong my biggest issue is the STORY, i'm refining the plot and learning so much i decided to take a writers class to improve even more but the programming and functionality of the game is stepping up nicely!
Hi everyone! Here's what I'm working on today! It's one of the dorms on campus. I know I said I wouldn't use assets but I reused a few things from the cafeteria hehe.
FCuxBOMXMAICK5e

Forum statistics

Threads
116,127
Messages
1,095,998
Members
151,544
Latest member
SeraphimRosenhart
Top