grapeslover

Villager
Member
Joined
Apr 16, 2021
Messages
6
Reaction score
1
First Language
English
Primarily Uses
RMMV
I'm making my first game and following this tutorial (except I'm not using animations):
However when opening the menu in the game, it'll transfer to a black screen with a ship and the player visible, when the menu button is pressed again it'll show the custom menu screen, but only the upper left corner. When trying to exit, it'll only go back to the black screen.
I've ran through it several times, but I don't know anything about javascript and can't seem to find the problem...If anyone could help it'd be amazing!
1.png
2.png
3.png
 
Last edited:

ShadowDragon

Realist
Veteran
Joined
Oct 8, 2018
Messages
3,891
Reaction score
1,480
First Language
Dutch
Primarily Uses
RMMV
did you copy exacly everything in the video?
I made 2 evented versions of this that and both works.

I also made another evented menu, but when using map projectiles,
it got an issue with that part, but I made my own custom menu
to work with (single actor based), so it doesn't really work with more
than 1 actor.

so check the video on the event part, pause it and check if you missed
something, somewhere, but personally, it has 1 tiny issue which has
most evented menu with transfer on them.

recheck, and it should work correctly, cannot say what you missed atm.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,196
Reaction score
14,665
First Language
English
Primarily Uses
RMMV
You should probably say what you EXPECT to be happening here. I'm not sure what part you're having the problem with. Is that screen meant to be black, or should a map be displayed? Is the player and ship meant to be visible, or hidden? If they're meant to be hidden and that's the only issue, then you don't have stuff set up correctly in your System tab and it has nothing to do with the custom menu.

You don't show a screenshot of what it looks like when the menu appears - that would be helpful, as well as an explanation of what it should look like.

Please provide some more information.
 

grapeslover

Villager
Member
Joined
Apr 16, 2021
Messages
6
Reaction score
1
First Language
English
Primarily Uses
RMMV
did you copy exacly everything in the video?
I made 2 evented versions of this that and both works.

I also made another evented menu, but when using map projectiles,
it got an issue with that part, but I made my own custom menu
to work with (single actor based), so it doesn't really work with more
than 1 actor.

so check the video on the event part, pause it and check if you missed
something, somewhere, but personally, it has 1 tiny issue which has
most evented menu with transfer on them.

recheck, and it should work correctly, cannot say what you missed atm.
Yep, I copied everything except for the animation exactly and rechecked multiple times :(
I'm only using one actor, but I'll look everything over again.


You should probably say what you EXPECT to be happening here. I'm not sure what part you're having the problem with. Is that screen meant to be black, or should a map be displayed? Is the player and ship meant to be visible, or hidden? If they're meant to be hidden and that's the only issue, then you don't have stuff set up correctly in your System tab and it has nothing to do with the custom menu.

You don't show a screenshot of what it looks like when the menu appears - that would be helpful, as well as an explanation of what it should look like.

Please provide some more information.
Sorry about that! Right now if the map button (M) is pressed once in the game, it's going to the black screen which it shouldn't be doing at all. If the button is pressed a second time, it'll change to what the menu is actually supposed to be, but just the corner. And I haven't really touched the system tab yet so I'll add that as well in case there's some wrong settings there.
 
Last edited:

ShadowDragon

Realist
Veteran
Joined
Oct 8, 2018
Messages
3,891
Reaction score
1,480
First Language
Dutch
Primarily Uses
RMMV
you can do that with my evented main menu easier for that look as well for
the plugin I have.

but if you want to event it, the menucontrollerStart switch using
if branche
code
else
if brance
code
else
if brance code
end
end
end

but you have it seperately (but both ways should work otherwise).
but not always so put them in an else brance and recheck.

1 map works differently than an else brance on a different map,
so I think the issue might be there.

if you dont use any map projectiles, try my evented main menu (in spoiler)
which open on the current map without transfering.

it works a slightly different, but it does the job nicely, but not recommened
if you use abs system because it needs a function for that part and still figure
that part out.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,196
Reaction score
14,665
First Language
English
Primarily Uses
RMMV
I'm not sure if this is a plugin issue, but because you're using a plugin to do it, I'll move to plugin support.
 

grapeslover

Villager
Member
Joined
Apr 16, 2021
Messages
6
Reaction score
1
First Language
English
Primarily Uses
RMMV
you can do that with my evented main menu easier for that look as well for
the plugin I have.

but if you want to event it, the menucontrollerStart switch using
if branche
code
else
if brance
code
else
if brance code
end
end
end

but you have it seperately (but both ways should work otherwise).
but not always so put them in an else brance and recheck.

1 map works differently than an else brance on a different map,
so I think the issue might be there.

if you dont use any map projectiles, try my evented main menu (in spoiler)
which open on the current map without transfering.

it works a slightly different, but it does the job nicely, but not recommened
if you use abs system because it needs a function for that part and still figure
that part out.
I ended up using your evented main menu and it was much easier to set up, thanks so much!! The only issue I'm having is that the menu automatically opens as soon as the game starts, how do I fix this?
 

ShadowDragon

Realist
Veteran
Joined
Oct 8, 2018
Messages
3,891
Reaction score
1,480
First Language
Dutch
Primarily Uses
RMMV
it shouldn't automatically open if switch is OFF, or bound to a common event
by YEP_ButtonCommonEvent (untested), while if you see the demo if it's
still working, it shouldn't happen or I need to take a look at it, depending how
you set it up.
 

grapeslover

Villager
Member
Joined
Apr 16, 2021
Messages
6
Reaction score
1
First Language
English
Primarily Uses
RMMV
it shouldn't automatically open if switch is OFF, or bound to a common event
by YEP_ButtonCommonEvent (untested), while if you see the demo if it's
still working, it shouldn't happen or I need to take a look at it, depending how
you set it up.

I just copied the demo events and adjusted them, so I'm not sure how it's happened. Here's what it looks like:
1212121.png
 

ShadowDragon

Realist
Veteran
Joined
Oct 8, 2018
Messages
3,891
Reaction score
1,480
First Language
Dutch
Primarily Uses
RMMV
can you send me the project demo where it's made, than I take a look
where it went wrong, and send it back once its working, because
it's a strange behavior you have.
 

grapeslover

Villager
Member
Joined
Apr 16, 2021
Messages
6
Reaction score
1
First Language
English
Primarily Uses
RMMV
can you send me the project demo where it's made, than I take a look
where it went wrong, and send it back once its working, because
it's a strange behavior you have.
Thanks for taking a look, here's the download
 

ShadowDragon

Realist
Veteran
Joined
Oct 8, 2018
Messages
3,891
Reaction score
1,480
First Language
Dutch
Primarily Uses
RMMV
@grapeslover I cannot tell what it can cause, I even re-create the entire
menu from scratch to see if it work, but somehow, it still triggers to open
it somehow, so I make a workaround for you, I use 1.6.1 and you use 1.6.2
and while they are the same, its weird.

Download the data and replace it with your current one (this has all the data
of your maps and events.

there was in the buttoncommon event plugin "X" and "M" markeet on CE3
so I removed 1 to see if that is the cause, but it wasn't, something trigger
the cancel button from start and I cannot tell why it does that.

while it shouldn't happen, I made a failsafe on the event (which load the
images from start) this one is only runs once on starting point, the other
menu part runs on each map to call it.

in the cache autorun, the failsafe = Switch Main Menu = OFF. this forces
the menu to be off on start, and if a switch is OFF, you can turn it off again,
but does nothing, so I cannot say what trigger the cancel though, but it's
working with the failsafe switch to make it off once the games is booted.

if you have any other question, let me know and I can see what can be done :)
Good luck on your project further :)
 

Attachments

  • data(unknownCause).zip
    49.9 KB · Views: 2

grapeslover

Villager
Member
Joined
Apr 16, 2021
Messages
6
Reaction score
1
First Language
English
Primarily Uses
RMMV
Hmm how strange...But thank you so much for taking the time to help me out, you're a lifesaver!!
I'll make sure to link to your thread in the game credits once it's finished :)
 

Latest Threads

Latest Profile Posts

here's another RPG Maker remake idea: "Plumbers Don't Wear Ties". I'll salute to whomever does this
I won't finish it today, I only will have time to work on that next Saturday, what a shame... :(
I made something for @LittenDev [as he requested]
It's been a weird while. I've been so torn down that even playing video games has been something I avoided. But I shouldn't forget two things. One, I love RPG Maker for a reason. Two, only way to eat an elephant is a bite at a time.

Forum statistics

Threads
111,385
Messages
1,060,722
Members
144,729
Latest member
jovanp
Top