Custom sprite sheet is slightly off in-game

KKraze

Villager
Member
Joined
Jan 31, 2017
Messages
6
Reaction score
4
First Language
English
Hi. I'm sorry if this isn't in the right place to post this but I'm not too sure on how this site works as I pretty much just joined. I'm looking for some help. I have this sprite sheet I've made for a game by myself. It's not done yet but it's still pretty good in my opinion. Ignore the clothes-less 2nd and 3rd row.


Click here for image


Though when I use it in-game... it looks a bit different. Not much, but I'm a bit of a perfectionist and this has been bugging me for a few days now. It seems like the game has tried lowering the pixels and now it's just changed without my say or something along those lines. I don't know how it works.


Here's the video of my sprite in action. Mind the bad phone camera quality though.


The eye isn't supposed to blend with the lashes every few frames. When it turns upwards the outline for the hair isn't supposed to thicken. The hair strands at the front aren't meant to disappear and come back either. I don't know what's going on and I don't want this to happen to everything I do in the game. The light reflecting on the back of her hair (two dots) keeps growing and shrinking every few frames too. Yeesh. It wouldn't bother me so much if they'd spare the eye but c'mon, it's the eye. Eyes are important to me.


Any help regarding this would be appreciated. Thanks

EDIT: Thanks for all of the help, it's working perfectly now
 
Last edited:

Celianna

Tileset artist
Global Mod
Joined
Mar 1, 2012
Messages
10,543
Reaction score
5,551
First Language
Dutch
Primarily Uses
RMMV
Are you in fullscreen when you do this?
 

KKraze

Villager
Member
Joined
Jan 31, 2017
Messages
6
Reaction score
4
First Language
English
Are you in fullscreen when you do this?
Yes, when I posted the video it was in fullscreen. I first noticed it in windowed mode though so I don't think it has something to do with screen size. Then again I could be wrong
 

The Row

Villager
Member
Joined
Mar 2, 2016
Messages
5
Reaction score
3
First Language
Swedish
Primarily Uses
I might be wrong, but the image is 143px × 384px right? 143/3 is 47,666666 in other words not an even number so I am guessing the computer tries to make it work. Try making the sprite image so that the image is evenly divadable... (is that even a word?) with 3. say, 144?
Just be sure that the sprite remains in center, it can be a bit fiddly, but I hope this solves it, else I don´t know what is wrong.
 

KKraze

Villager
Member
Joined
Jan 31, 2017
Messages
6
Reaction score
4
First Language
English
I might be wrong, but the image is 143px × 384px right? 143/3 is 47,666666 in other words not an even number so I am guessing the computer tries to make it work. Try making the sprite image so that the image is evenly divadable... (is that even a word?) with 3. say, 144?
Just be sure that the sprite remains in center, it can be a bit fiddly, but I hope this solves it, else I don´t know what is wrong.
I tried what you said. It looks like the size of the sprite sheet is DEFINITELY affecting how it looks in-game. I made it a bit smaller in width and length and now the problem is fixed. Thank you so much, you saved it :)
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

I was planning to release a useless plugin for april fools, but then I thought I let it be.
Tfw every dev around me is using Live2D in their MV games and make me question my skills repeatedly.

Spending the day reworking my maps, especially the first "biome". This time it's not even in the dark. :LZSwink:
Activity on the forums has increased lately, probably because of people staying home. The amount of work for moderators has increased lol.

Forum statistics

Threads
95,522
Messages
929,784
Members
125,791
Latest member
Oersted_LAL
Top