Mr. Detective

NATO Special Operative
Veteran
Joined
Sep 9, 2012
Messages
1,034
Reaction score
494
First Language
English
Primarily Uses
N/A
Hello,

I'm currently using Sasuke Kannazuki's BattleVoiceMZ plugin. All of my skills are grouped together under one specific category. I've also tried this method, but it didn't work for some reason. I did put them in the characters' notebox.

<recoverVoice:filename> plays when actor uses HP recovering magic.
If set no SE one of filenames,
<attackVoice:atk1,atk2,$>
in this case, at attack, plays atk1 atk2, or doesn't play SE.

Not just skills that recover HP, but self-buff skills as well. I want the characters to not say anything when these skills are used. Does anyone know how to fix this?

This script should be in the dlc - basic resources - plugins - launch. Or should I post the entire plugin up here?
Apparently, the creator is only active over at the Japanese forum. I'll contact him there as a last resort. Hope someone on this forum can help me.

Thanks in advance.
061.gif
 

NaosoX

Veteran
Veteran
Joined
Feb 28, 2013
Messages
490
Reaction score
263
First Language
English
Primarily Uses
RMMZ
You should be able to do this by linking the skill to common event and utilising battlevoice plugin command to remove linked sound effects.
If You cant get this to work out, I'll have to give you an example later tonight.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
35,928
Reaction score
9,533
First Language
German
Primarily Uses
RMMV
or you can simply trick the plugin by creating/recording a silent audiofile and assigning that one to the skills that are not supposed to have a voice.
 

NaosoX

Veteran
Veteran
Joined
Feb 28, 2013
Messages
490
Reaction score
263
First Language
English
Primarily Uses
RMMZ
It's actor's action type specific(linked to actor, not the skill). Having blank audio wouldn't make sense when you can simply set to the audio type to none.
 

Mr. Detective

NATO Special Operative
Veteran
Joined
Sep 9, 2012
Messages
1,034
Reaction score
494
First Language
English
Primarily Uses
N/A
@NaosoX @Andar

I think I got it already... I added these two plugin calls to the action sequence.


aas.png


I also tried option 1 - change actor voice, but it didn't work with the $ for some reason. Well, nevertheless, that seems to have done the job nicely, at least for now. Worst case scenario, I'll have to use a blank audio file. Hope I won't need that.
Did I miss anything else? =w=
 

NaosoX

Veteran
Veteran
Joined
Feb 28, 2013
Messages
490
Reaction score
263
First Language
English
Primarily Uses
RMMZ
What's the $ for?
 

NaosoX

Veteran
Veteran
Joined
Feb 28, 2013
Messages
490
Reaction score
263
First Language
English
Primarily Uses
RMMZ
Hrmm. When set to none? I haven't encountered this. But if it works, I guess it's fine.
I also don't use notetags to set voices. I have a CE define the voices when the game loads.
 
Last edited:

Mr. Detective

NATO Special Operative
Veteran
Joined
Sep 9, 2012
Messages
1,034
Reaction score
494
First Language
English
Primarily Uses
N/A
You can't just set it to none or leave it blank. Gotta manually type the $ in.
 

NaosoX

Veteran
Veteran
Joined
Feb 28, 2013
Messages
490
Reaction score
263
First Language
English
Primarily Uses
RMMZ
For voice 2, yea.. guess that's something I have yet to try.
 

Latest Threads

Latest Profile Posts

grief... finding a font that works with the engine has been a bigger process than I thought it'd be. doesn't help MV loves to scrunch letters next to each other like a football huddle.
The new Phoenix plugin. I drew icons and an interface into it
R3-M1 can now leave footprints :kaojoy: Thanks Dsiver144 for another amazing plugin!!

1653686110642.png

Hey guys, do you wanna see who dominated the competition in our last game jam?! Stop by while we play Pinky by @Wumbohek Starting at 4:20pm EST.

Forum statistics

Threads
122,178
Messages
1,147,044
Members
160,438
Latest member
zodismegalame
Top