Does anyone else have this graphical error with Animated Sideview Enemies?

Discussion in 'RPG Maker MV' started by Dacuna, Jul 11, 2016.

  1. Dacuna

    Dacuna Veteran Veteran

    Messages:
    143
    Likes Received:
    10
    First Language:
    English
    Hello everyone,


    I don't know if it's just me, but whenever I use Yanfly's Animated Sideview Enemies plugin and make the enemies breathe, the black line circled in the picture below appears.


    It appears maybe once or thrice every breathing cycle for a split second, but it's really noticeable.


    This is understandable, since the enemy's graphic is being stretched out and such, but is there any way to fix this?


    It happens even on a new project with nothing but Battle Engine Core and Animated Sideview Enemies.

    Yanfly Animated Sideview Enemies Error.png
     
    #1
  2. Andar

    Andar Veteran Veteran

    Messages:
    28,701
    Likes Received:
    6,600
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    Let me guess: you changed the iconsheet?


    At that position, there is the default #0 icon - that position in the iconsheet always has to be fully transparent for exactly that reason.


    And it looks as if it isn't completely transparent, but a small line at the bottom is either black or the entire first icon row is missing a pixel line, resulting in the next iconrow becoming partially visible.


    Either that, or the sprite you're using to animate the enemy has a graphic glitch in the same way and needs to be corrected.


    But in both cases, the correction has to be done to an image, not to the scripts.
     
    #2
  3. Dacuna

    Dacuna Veteran Veteran

    Messages:
    143
    Likes Received:
    10
    First Language:
    English
    I haven't touched IconSet or any of the RTP enemies, this glitch happens on a completely new project...


    Edit: And on at least 3 different enemy graphics.


    Also, the black line in the picture above is actually done in a image editor program because it's extremely hard to screencap something that happens in a split second, if it matters.
     
    Last edited by a moderator: Jul 11, 2016
    #3
  4. cekobico

    cekobico Veteran Veteran

    Messages:
    343
    Likes Received:
    138
    Location:
    Indonesia
    First Language:
    Indonesian
    Eh...you drew them lol I was wondering why it's a default battler sprite when you said animated sideview enemies...


    So basically you're telling me that, enemies that are using SV_actors sheet has black lines on top of them that shows in split seconds? 


    If yes then:


    No, not just you. With or without custom iconset, I'm experiencing this as well in a very split second. I'm still unsure what caused it and pretend to address it later but now that you pointed it out might as well jumped in haha
     
    #4
  5. Dacuna

    Dacuna Veteran Veteran

    Messages:
    143
    Likes Received:
    10
    First Language:
    English
    Yup, except it happens with enemies in the sv_enemies folder, I'm not sure about the sv_actors folder.


    If you're getting the same problem, maybe I should tell Yanfly about the clipping...
     
    #5
  6. cekobico

    cekobico Veteran Veteran

    Messages:
    343
    Likes Received:
    138
    Location:
    Indonesia
    First Language:
    Indonesian
    No, the actors are fine. Enemies have blacky blacky lines. 


    I would report it Yanfly but I haven't got the time to sit down and make sample project and follow the rest of the guidelines so please do ourselves a favor xD 
     
    #6
  7. Dacuna

    Dacuna Veteran Veteran

    Messages:
    143
    Likes Received:
    10
    First Language:
    English
    All righty, my report is up for viewing here.
     
    #7
  8. ramza

    ramza Lunatic Coder Veteran

    Messages:
    559
    Likes Received:
    309
    Location:
    Nova Scotia, Canada
    First Language:
    English
    Primarily Uses:
    RMMV
    I would like to mention that it also happens when you use action sequences to zoom onto an actor. ma head.PNG


    I don't think it's an issue with yanfly's plugin, because the breathing effect is zooming the sprite slightly. I suspect it's an issue with the way zooming is happening in the rm mv engine. Because it's isn't using video hardware acceleration, most likely. The area where it appears is smaller than one pixel, which leads me to believe it is a rendering error.


    I have also seen it happen when you scale an SV animated enemy's sprite to be larger than normal, or an actor's battler graphic. It appears to happen whenever the sprites are scaled up (as that happens during the breathing motion as well)
     
    Last edited by a moderator: Jul 11, 2016
    #8
  9. Dacuna

    Dacuna Veteran Veteran

    Messages:
    143
    Likes Received:
    10
    First Language:
    English
    Hmm, okay, do you know of a quick fix within the plugin or something?
     
    #9

Share This Page