DragonBone Battler exists in fight, but no images show up.

Discussion in 'Javascript/Plugin Support' started by SickJoe, Oct 30, 2017.

Thread Status:
Not open for further replies.
  1. SickJoe

    SickJoe Warper Member

    Messages:
    3
    Likes Received:
    0
    Location:
    Boone, NC
    First Language:
    English
    Primarily Uses:
    RMMV
    Hello. I followed along with the setup as listed, as well as checked out the demo and how the notetags were setup in there. But the first few times I tried to test the Battle it gave me an error about an unsupported version. So I re-exported my assets in DragonBone as the different Data Configs. DragonBone JSON 5.5 and 5.0 would give me the error and 4.5 and 4.0 would not. The problem now is that in game the enemy exists in the fight, but none of the textures/images/animations tied to it show up. It does the same if I place my assets into the demo's Dragonbone Assets folder and update it's plugin to preload my files with the others in the demo. I made sure to use the transparent img for the battler that gets swapped out as well.

    Any help would be greatly appreciated and thank you very much in advance. ;)
    Have good one~
    -SJ
     
    #1
  2. Isabella Ava

    Isabella Ava Veteran Veteran

    Messages:
    635
    Likes Received:
    751
    First Language:
    English
    use older Dragon bone version 5.3 for exporting
     
    #2
  3. SickJoe

    SickJoe Warper Member

    Messages:
    3
    Likes Received:
    0
    Location:
    Boone, NC
    First Language:
    English
    Primarily Uses:
    RMMV
    Isabella, I reinstalled to the older version of Dragon bone and it allowed me to export in 5.0 (before it'd only do 4.0 and 4.5 w/o causing an error), but the invisible unit issue still remains. I tried scaling the texture sheet down and exporting through the different versions and the invisibility issue was constant across all of them.
     
    #3
  4. SickJoe

    SickJoe Warper Member

    Messages:
    3
    Likes Received:
    0
    Location:
    Boone, NC
    First Language:
    English
    Primarily Uses:
    RMMV
    I tried to make a smaller/simpler animation in the older version as well, double checked my animation names and everything, and I still end up with the invisible unit unfortunately.
     
    #4
  5. farysrh

    farysrh Villager Member

    Messages:
    14
    Likes Received:
    0
    First Language:
    ENGLISH
    Primarily Uses:
    N/A
    We are the same problem anyone please help
     
    #5
  6. slimmmeiske2

    slimmmeiske2 Little Red Riding Hood Moderator

    Messages:
    5,561
    Likes Received:
    4,123
    Location:
    Belgium
    First Language:
    Dutch
    Primarily Uses:
    RMXP

    farysrh, please refrain from necro-posting in a thread. Necro-posting is posting in a thread that has not had posting activity in over 30 days. You can review our forum rules here. Thank you.



    Closing this.

     
    #6
Thread Status:
Not open for further replies.

Share This Page