xyzeden

Villager
Member
Joined
Oct 16, 2021
Messages
6
Reaction score
1
First Language
English
Primarily Uses
RMMV
Hi, I have been making a game on this for the past year, and it's all been done since the very start with a laggy editor, meaning it freezes on every event, or when calling any sort of database. I can guarantee it isn't a hardware problem, an OpenGL problem, a tileset-size problem, or a driver problem. Have tried adding lines to package.json and even went from an HDD to an SSD (Which solved the crashes, but not the lag).

I have scoured every corner of the internet for the past year off and on trying to fix this issue, and I have tried basically everything that's available for a fix, except for one thing. Someone has posted a few times about a certain language or regional file containing incorrect mathematical text, namely trying to equate commas with dots in certain lines. (3,14 instead of 3.14, etc.)

I have been searching for anything resembling the location of this issue anywhere, and simply cannot find it. The few posts about it I've seen are in somewhat broken english, and also don't pinpoint the location of the conflicting text. If anyone knows anything about it, or can point me in the right direction, I'd be incredibly grateful. I've probably lost days of my life collectively waiting for stuff to load in the editor, and it drives me insane.
 

Vis_Mage

Wisp Charmer
Veteran
Joined
Jul 28, 2013
Messages
748
Reaction score
246
First Language
English
Primarily Uses
RMMV
Just to rule it out, does this editor lag still happen with a completely fresh new game? I've experienced some pretty heavy editor lag, that happens if certain database files become too large (animations and tilesets are the biggest offenders).
 

xyzeden

Villager
Member
Joined
Oct 16, 2021
Messages
6
Reaction score
1
First Language
English
Primarily Uses
RMMV
Just to rule it out, does this editor lag still happen with a completely fresh new game? I've experienced some pretty heavy editor lag, that happens if certain database files become too large (animations and tilesets are the biggest offenders).
Yeah, it starts on launch of the the program, fresh game or not. Also doesn't seem to matter what version I end up using, still the same thing.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,360
Reaction score
8,772
First Language
German
Primarily Uses
RMMV
1) which version of the editor do you have installed?
the crashes in languages with the wrong mathematical environment (dot/comma reversal) were only with the 1.0 and solved extremely fast with the first update.

2) what type of maps do you use?
Using large backgrounds for parallax is a problem with RAM, no matter what else you do in the editor.

3) where did you install the editor?
if the filepath to the exe or the projects break several HTML-based rules, this can cause problems.

4) what protection programs do you use?
some of these programs have extremely aggressive heuristic searches, and MV does use HTML-technology that might be mistaken for a remote website trying to infect your computer despite being simple local saving.
 

xyzeden

Villager
Member
Joined
Oct 16, 2021
Messages
6
Reaction score
1
First Language
English
Primarily Uses
RMMV
Appreciate the response very much. I'll try to answer best I can.

1. I currently have two versions, 1.0 which is generally the one I wind up using simply because of the time I spent on its generator, and 1.6.1 but both have the exact same issue. One isn't any better than they other. I even went as far as to buy it on steam and use the standalone versions to see if that made a difference, which it didn't, so I got it refunded there.

2. I sometimes have some large maps, but I have never used the background image thing for any of them, it's all been basic black backgrounds. Some of the largest maps I have were only added a few months ago, but this problem has been occurring since day 1 a year ago.

3. I didn't know this one, so this might be part of them problem. The main 1.0 version I use is located: "C:\Program Files (x86)\KADOKAWA\RPGMV\RPGMV.exe"

The secondary 1.6 version is located in This PC > Documents > RPGMV

Oh, and for clarity, if I remove one version and keep the other, the problem still persists, so I have both installed still since I did a lot of generator work on them.

4. I don't use any protection programs at all besides the default windows firewall stuff, but even then I've severely limited that's reach too. I use malwarebytes occasionally but it's never on consistently, just when things need a checkup.

Again thanks for your help.
1) which version of the editor do you have installed?
the crashes in languages with the wrong mathematical environment (dot/comma reversal) were only with the 1.0 and solved extremely fast with the first update.

2) what type of maps do you use?
Using large backgrounds for parallax is a problem with RAM, no matter what else you do in the editor.

3) where did you install the editor?
if the filepath to the exe or the projects break several HTML-based rules, this can cause problems.

4) what protection programs do you use?
some of these programs have extremely aggressive heuristic searches, and MV does use HTML-technology that might be mistaken for a remote website trying to infect your computer despite being simple local saving.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,360
Reaction score
8,772
First Language
German
Primarily Uses
RMMV
I even went as far as to buy it on steam and use the standalone versions to see if that made a difference, which it didn't, so I got it refunded there.
Just for your info: the key to the standalone version doubles as a steam key, so if you purchase the standalone version you can activate it on steam free of charge (it is the same key and the same licence, so you are not allowed to give it away. But I for example use this to have the editor in two different languages at the same time.
This PC > Documents > RPGMV
Unfortunately this is not a filepath as it contains the abbreviation "This PC" from Microsoft that could hide problems with the filepath. And one of these problems could be the cause if you blindly followed Microsofts advice and put your documents folder into OneDrive.In the true filepath this would have been obvious by the foldernames containing "onedrive" but "This PC" hides that part of the path.

1.0 which is generally the one I wind up using simply because of the time I spent on its generator,
can you please explain this? There is no difference in the generator if you mean the character generator, in fact the later version should be faster and more stable than the 1.0.


Additionally, what version is your project core? Especially if you change and use both editors?
You can check the project version by going to the project folder, js subfolder and open the rpg_core.js file with a text editor (do NOT doubleclick it).
If there is no number in the title line, it's 1.0 otherwise the core version is displayed in the title line.

And all cores older than 1.4.0 have one or more memory leaks that will cause lag crashes in the game on playtests.
 

xyzeden

Villager
Member
Joined
Oct 16, 2021
Messages
6
Reaction score
1
First Language
English
Primarily Uses
RMMV
Once again, appreciate the response. I don't really understand what you mean with the directory being wrong, or what I would do to fix it, if there's even a problem with it.

And as for the generator, I used an older version which didn't have the "kid" tab of the generator, and only realized that I was using an older version long after I put dozens of hours into editing the original generator. Trying to transfer everything over with all the newer stuff in the newer generator would have been an actual nightmare, so I just use the original I spent a ton of time on. Use that one for characters, and the newer generator for the kid sprites and whatnot. But I do most of my editing from the older version as well, for that reason.

The core doesn't have a number next to it, so I assume it's 1.0 yeah. The project is being used by both editors though, so is that a problem, or is there a fix? I'm just lost.
Just for your info: the key to the standalone version doubles as a steam key, so if you purchase the standalone version you can activate it on steam free of charge (it is the same key and the same licence, so you are not allowed to give it away. But I for example use this to have the editor in two different languages at the same time.

Unfortunately this is not a filepath as it contains the abbreviation "This PC" from Microsoft that could hide problems with the filepath. And one of these problems could be the cause if you blindly followed Microsofts advice and put your documents folder into OneDrive.In the true filepath this would have been obvious by the foldernames containing "onedrive" but "This PC" hides that part of the path.


can you please explain this? There is no difference in the generator if you mean the character generator, in fact the later version should be faster and more stable than the 1.0.


Additionally, what version is your project core? Especially if you change and use both editors?
You can check the project version by going to the project folder, js subfolder and open the rpg_core.js file with a text editor (do NOT doubleclick it).
If there is no number in the title line, it's 1.0 otherwise the core version is displayed in the title line.

And all cores older than 1.4.0 have one or more memory leaks that will cause lag crashes in the game on playtests.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
34,360
Reaction score
8,772
First Language
German
Primarily Uses
RMMV
The core doesn't have a number next to it, so I assume it's 1.0 yeah. The project is being used by both editors though, so is that a problem, or is there a fix? I'm just lost.
then you really should update the project, because that will cause problems and is likely to be at least part of the reason for the lag.

you can update your project independently of the editor itself - otherwise it would be too difficult to handle different editors and different versions.
unfortunately an update from 1.0 to 1.6.2 may have or cause problems if done wrong...

first problem is your plugins. some plugins only work up to 1.4 because that changed a number of internal functions. Other plugins require at least 1.4.0 exactly because they need those functions - so you're unlikely to use any of them.

I suggest you make a backup of your project first. Then activate your key on steam (if you haven't done so already), switch steam to version 1.4 in the program properties (beta versions) and use that to create a new project. Instructions on how to update your project are in all the news topics about new MV versions here on the forum, follow them with the 1.4 and test if the project still works after updating to 1.4.
If not, go back to the backup and try it with another backup and 1.3
 

xyzeden

Villager
Member
Joined
Oct 16, 2021
Messages
6
Reaction score
1
First Language
English
Primarily Uses
RMMV
then you really should update the project, because that will cause problems and is likely to be at least part of the reason for the lag.
This is 100% the reason. I have never closed my project before to test a fresh one on 1.6, and it loaded events instantly - an experience I have never had before. Unreal how much time I waste waiting for stuff like that.

I did what was recommended for updating the project core and whatnot, and it's still very slow in the backup. I did it multiple times, too. I copied everything except the plugins folder, then everything except the plugins folder and the plugins.js in with the rest of the .js files (with the index update and whatnot as well, not even sure what it does. Even on the fresh version, it opens a chrome tab with the error message "failed to load actors.json"), but still no luck. I imagine it's going to need 1.4 exactly, since it refuses to work with the normal method, but that's a hurdle as well. I'll try to think of a way to do this without needing to find my key, since I definitely have no idea where it is, and don't feel like buying the game again just to update a project...

Thank you very much though, at least I have finally identified the problem. Just sucks even simple fixes like this never work, no matter how easy they are on paper.


EDIT: I caved and just re-bought it on steam, since it's on sale. I opened the betas tab, selected 1.4 in the dropdown, relaunched, and made a new project.

I copied: EVERY file in "js", except for the "plugins" folder, as well as the "index" HTML file into the old project I'm trying to update. Absolutely no change, it's still laggy even on relaunch.

I also noticed that copying "plugins" JS file along with all the others basically removed all my old plugins, so I did it all again, but this time ignored adding the "plugins" JS file into the old project. My old plugins are all there again, but the lag is the exact same it has ever been. I really don't think I'm doing this improperly, the "core" even now has a proper version listed at the top, but it still continues to be as laggy as ever. Really not sure what to do, going back to 1.3 and using a new project on that like you suggested didn't even work.

I even elected to try keeping in the plugins files to the old project, just to see what would happen. Absolutely no change again, except the only plugin in the list now being some "made with" splash or something. So the plugins aren't the issue, it's something to do with the actual project itself that replacing those files to update it aren't solving.

My only suggestion now would be to maybe send you a copy of the project. I obviously don't know what I'm doing, apparently, but maybe you could figure something out.
 
Last edited:

Latest Threads

Latest Posts

Latest Profile Posts

aww man, color hex code #C4C4C4 doesn't work for the tint value in this scene I need something darker, which stinks just because I liked that one it was my favorite plastic explosive three times...#696969 (nice) should work better (WHY IS MY BRAIN LIKE THIS)
Tell it to me straight, doc. If I've been trying to piece together a "shorter" game to learn stuff outside of game jams... am I just running away from my WIP? :v
Well, I've got a party tomorrow, and my friends are coming over. I wanted to work a bit on the Fandom Scouts assets so I can be ready when that update arrives... in other news, Pizza Time Horror is getting a second teaser, and it shows Cabaret Helen's last performance before the location closed.
Also who used to be scared of Chuck E as a kid? I was! Now I love him!
The new cards and what they do:

(I am clearly not a youtuber... Haha)

Forum statistics

Threads
117,282
Messages
1,106,103
Members
153,458
Latest member
uQueirox
Top