Joined
Dec 31, 2021
Messages
51
Reaction score
24
First Language
English
Primarily Uses
RMMV
(MV)

I am having an issue when text is specifically displayed "centered" in a window.
This does not affect any text that is displayed normally (left to right or right to left).

How my font is supposed to look:
1651961074563.png
How it looks when it's centered in certain windows.
1651961028980.png

This isn't an issue of fullscreen scaling btw. It is the same effect when in it's tiny native resolution window, I just used fullscreen images to show the effect up close. Here's native res screenshots:
1651961471482.png
1651961577362.png

It kind of stretches each letter horizontally for some reason, making them look stuck together. Using the plugin parameters to space the font more only helps it not look stuck together, but still looks funky. Is there a way to get around this? I could for the most part make the text not be centered but there are certain windows and things that automatically center text within the engine and it looks a bit distracting.
 

Eliaquim

Hakuen Studio
Veteran
Joined
May 22, 2018
Messages
2,819
Reaction score
2,160
First Language
Portuguese - Br
Primarily Uses
RMMZ
(MV)

I am having an issue when text is specifically displayed "centered" in a window.
This does not affect any text that is displayed normally (left to right or right to left).

How my font is supposed to look:
View attachment 225524
How it looks when it's centered in certain windows.
View attachment 225523

This isn't an issue of fullscreen scaling btw. It is the same effect when in it's tiny native resolution window, I just used fullscreen images to show the effect up close. Here's native res screenshots:
View attachment 225526
View attachment 225527

It kind of stretches each letter horizontally for some reason, making them look stuck together. Using the plugin parameters to space the font more only helps it not look stuck together, but still looks funky. Is there a way to get around this? I could for the most part make the text not be centered but there are certain windows and things that automatically center text within the engine and it looks a bit distracting.
Hi there!
What a strange issue!
Do you have this same issue in a clean project? Like, with only Eli Book and Eli Bitmap Font?
When exactly this glitch happens, it's like on the menu commands, where the text is centered by default?
 
Joined
Dec 31, 2021
Messages
51
Reaction score
24
First Language
English
Primarily Uses
RMMV
Hi there!
What a strange issue!
Do you have this same issue in a clean project? Like, with only Eli Book and Eli Bitmap Font?
When exactly this glitch happens, it's like on the menu commands, where the text is centered by default?

Yeah it's any menus that the text is centered by default. It also ofc happens to any text I set to centered myself. If displayed from left to right, no issue at all.

I used my clean test project, and turned off yanfly plugins just in case (the only plugins I usually test with). Same issue:
1652025337667.png
 

Eliaquim

Hakuen Studio
Veteran
Joined
May 22, 2018
Messages
2,819
Reaction score
2,160
First Language
Portuguese - Br
Primarily Uses
RMMZ
Yeah it's any menus that the text is centered by default. It also ofc happens to any text I set to centered myself. If displayed from left to right, no issue at all.

I used my clean test project, and turned off yanfly plugins just in case (the only plugins I usually test with). Same issue:
View attachment 225592
Thanks for the info!
Well, I did tried to replicate the issue but I didn't manage to see the error.
The one on the left is from the Menu. The one on the right is from the Message window.
They seem the same to me.
1652055576151.png

So I whould like you to send me a sample project replicating the error so I can take a deep look and see what is the problem. You can upload it anywhere: Google drive, dropbox etc. Send me the link here or through PM.
 
Joined
Dec 31, 2021
Messages
51
Reaction score
24
First Language
English
Primarily Uses
RMMV
Thanks for the info!
Well, I did tried to replicate the issue but I didn't manage to see the error.
The one on the left is from the Menu. The one on the right is from the Message window.
They seem the same to me.
View attachment 225622

So I whould like you to send me a sample project replicating the error so I can take a deep look and see what is the problem. You can upload it anywhere: Google drive, dropbox etc. Send me the link here or through PM.
I will try to upload one soonish. Though just to clarify, you are doing this with MV correct? I would assume so but just wanted to make sure. Either way pretty weird yeah.
 

Eliaquim

Hakuen Studio
Veteran
Joined
May 22, 2018
Messages
2,819
Reaction score
2,160
First Language
Portuguese - Br
Primarily Uses
RMMZ
I will try to upload one soonish. Though just to clarify, you are doing this with MV correct? I would assume so but just wanted to make sure. Either way pretty weird yeah.
Yeah, I used MV! ^^
 
Joined
Dec 31, 2021
Messages
51
Reaction score
24
First Language
English
Primarily Uses
RMMV
I tested this using the title screen on a fresh new project.
As you can see the name "Test Project" is a bit messed up with the scaling. Weirdly, when I wrote a much longer title to test it out, it displayed perfectly. As well as doing just "Test" worked normally. Seems to be some weird scaling issue with short to medium amounts of text that is centered I guess? IDK what up with that:kaosigh::

1652242706878.png

Here's the project:
 

Eliaquim

Hakuen Studio
Veteran
Joined
May 22, 2018
Messages
2,819
Reaction score
2,160
First Language
Portuguese - Br
Primarily Uses
RMMZ
I tested this using the title screen on a fresh new project.
As you can see the name "Test Project" is a bit messed up with the scaling. Weirdly, when I wrote a much longer title to test it out, it displayed perfectly. As well as doing just "Test" worked normally. Seems to be some weird scaling issue with short to medium amounts of text that is centered I guess? IDK what up with that:kaosigh::

View attachment 225804

Here's the project:
Hi there!
Thanks for the project. But Google requires me to ask for access before downloading it. And I asked.
 

Eliaquim

Hakuen Studio
Veteran
Joined
May 22, 2018
Messages
2,819
Reaction score
2,160
First Language
Portuguese - Br
Primarily Uses
RMMZ
You've been approved to view it now.
Well, I tested here, and everything seems fine to me.

I used my clean test project, and turned off yanfly plugins just in case (the only plugins I usually test with). Same issue:
1652025337667.png
Look how the "Equip" command is:
1652248699120.png


Seems to be some weird scaling issue with short to medium amounts of text that is centered I guess? IDK what up with that:kaosigh::

1652242706878.png
And the title screen:
title 2.JPG title.JPG

1 - Are you sure you sent me the same project you managed to solve that weird issue?
2 - If yes, I don't know what it could be. Did you try to update your PIXI version or NW.js version? Although I don't believe that is the problem...
 
Joined
Dec 31, 2021
Messages
51
Reaction score
24
First Language
English
Primarily Uses
RMMV
Well, I tested here, and everything seems fine to me.


Look how the "Equip" command is:
View attachment 225817



And the title screen:
View attachment 225818 View attachment 225819

1 - Are you sure you sent me the same project you managed to solve that weird issue?
2 - If yes, I don't know what it could be. Did you try to update your PIXI version or NW.js version? Although I don't believe that is the problem...
Oh, that equip you compared is from a different window with centered text btw.

But anyway, the NW.js stuff might be my problem. I updated it to 0.49.2 (this version specifically to make sure I got steam achievements down) before working on our game, totally forgot it affects every project I make.

Welp, probably just an incompatibility issue with that. I heard that it can affect small stuff like that, the tutorial I used they said they used a certain version and it made their text appear slower.

Though... if that's the case I wonder if it's just an issue *in* the project. Gonna export a build and share it to the other devs and see if it has the same issue. Either way though, guess I just have to work around it!

Sorry for bugging you about this issue!! :kaoswt2:
 

Eliaquim

Hakuen Studio
Veteran
Joined
May 22, 2018
Messages
2,819
Reaction score
2,160
First Language
Portuguese - Br
Primarily Uses
RMMZ
Oh, that equip you compared is from a different window with centered text btw.

But anyway, the NW.js stuff might be my problem. I updated it to 0.49.2 (this version specifically to make sure I got steam achievements down) before working on our game, totally forgot it affects every project I make.

Welp, probably just an incompatibility issue with that. I heard that it can affect small stuff like that, the tutorial I used they said they used a certain version and it made their text appear slower.

Though... if that's the case I wonder if it's just an issue *in* the project. Gonna export a build and share it to the other devs and see if it has the same issue. Either way though, guess I just have to work around it!

Sorry for bugging you about this issue!! :kaoswt2:
No need to be sorry!
I hope you manage to find a solution ^^
 

BloodletterQ

Chaotic Neutral Assassin
Veteran
Joined
Aug 15, 2012
Messages
1,568
Reaction score
1,217
First Language
English
Primarily Uses
N/A
For some reason, with the Visustella Core, the names for the Battle Actor Status are still in the normal font instead of the Bitmap Font.
1653012064643.png
This is with the Visustella Core plugin itself as opposed to any other of their plugins.
 

Eliaquim

Hakuen Studio
Veteran
Joined
May 22, 2018
Messages
2,819
Reaction score
2,160
First Language
Portuguese - Br
Primarily Uses
RMMZ
For some reason, with the Visustella Core, the names for the Battle Actor Status are still in the normal font instead of the Bitmap Font.
View attachment 226826
This is with the Visustella Core plugin itself as opposed to any other of their plugins.
Hi there!
Did you try changing the plugin orders?
 

Eliaquim

Hakuen Studio
Veteran
Joined
May 22, 2018
Messages
2,819
Reaction score
2,160
First Language
Portuguese - Br
Primarily Uses
RMMZ
I did change it around. Same results as before.
So let's try to figure this out.

If you remove Visustella plugins(or any plugin that is not mine), the bitmap font works as it should?

If Yes, then is a compatibility issue.
My guess is they created/changed the Sprite Name that is used to draw the Battle Actor Status.
Can't know for sure, since their code is obfuscated. So it's just a guess.
So there is nothing more I can do. If the code was open I just have to open the plugin file and see the issue.

You can try to tweak their plugin parameters since I know there is a lot, so maybe you find the answer there.
Or you can try talking to them and see if they can take a look at it. Even if you have the Pro version of my plugin, you can show it to them.

If not, then you can send a sample project to me replicating the issue, so I can take a look at it.
 

BloodletterQ

Chaotic Neutral Assassin
Veteran
Joined
Aug 15, 2012
Messages
1,568
Reaction score
1,217
First Language
English
Primarily Uses
N/A
Having so much trouble with this.Unlock_22.png
Becoming...
1654615170275.png
 

ShadowDragon

Realist
Veteran
Joined
Oct 8, 2018
Messages
5,688
Reaction score
2,241
First Language
Dutch
Primarily Uses
RMMV
@BloodletterQ did you adjust the param to adjust space
between letters? to put a higher number?

if not, you could try that as well to see if it get rid of the letters.
 

Eliaquim

Hakuen Studio
Veteran
Joined
May 22, 2018
Messages
2,819
Reaction score
2,160
First Language
Portuguese - Br
Primarily Uses
RMMZ
Having so much trouble with this.View attachment 228465
Becoming...
View attachment 228466
Hi there!
Only these words you said are not enough for me to help you. The plugin has a sample project, sample files and the help file.

I see that you already have some trouble with this plugin before. But I sent you a message and you didn't answer me:

So let's try to figure this out.

If you remove Visustella plugins(or any plugin that is not mine), the bitmap font works as it should?

If Yes, then is a compatibility issue.
My guess is they created/changed the Sprite Name that is used to draw the Battle Actor Status.
Can't know for sure, since their code is obfuscated. So it's just a guess.
So there is nothing more I can do. If the code was open I just have to open the plugin file and see the issue.

You can try to tweak their plugin parameters since I know there is a lot, so maybe you find the answer there.
Or you can try talking to them and see if they can take a look at it. Even if you have the Pro version of my plugin, you can show it to them.

If not, then you can send a sample project to me replicating the issue, so I can take a look at it.
 

BloodletterQ

Chaotic Neutral Assassin
Veteran
Joined
Aug 15, 2012
Messages
1,568
Reaction score
1,217
First Language
English
Primarily Uses
N/A
I decided to ditch the Visustella plugins.

Also I think I've figured it out, but now I get this issue:
InvalidStateError
Failed to execute 'drawImage' on 'CanvasRenderingContext2D': The image argument is a canvas element with a width or height of 0.
Also have a suggestion for gradient fonts like in RPG Maker 2000/2003. Unless I can do that already...

Looks like I’ll have to do this the long way and create the bitmap in GIMP. Otherwise, I think I’ve resolved this roadblock.
 
Last edited:

Latest Threads

Latest Posts

Latest Profile Posts

ScreenShot_6_24_2022_9_20_7.png
Here's Mike when you get a preemptive strike in battle. There's another one for when an enemy sneaks up on you too.
Suddenly, games mean nothing. The money spent was worth it to bring souls towards the light of life. May God bless my path forever. I pray that all are shaken for truth and poured out flat on the table of true understanding, knowledge, and wisdom. Bless you.
Finally I bought OMORI...cant wait to get traumatised!!!
Finished making this pretty ambitious forest map. Was wondering what y'all think of it! :kaopride:
1656136876015.png
All this anger everywhere,Who's happy but me?
Seems to be all the people that don't follow Jesus wholeheartedly. My smile might burn you ahhhhhhhhhhh!

Forum statistics

Threads
123,022
Messages
1,153,450
Members
161,365
Latest member
sieuthitien
Top