Encountered bugs with deployment. Just reporting them.

Discussion in 'RPG Maker MV Deployment' started by RHachicho, Jul 15, 2018.

  1. RHachicho

    RHachicho Veteran Veteran

    Messages:
    264
    Likes Received:
    125
    Location:
    Basildon, United Kingdom
    First Language:
    English
    Hello it seems I've encountered multiple bugs with the 'Exclude unused files' Option. During deployment .. First I would like to say I am well aware of this not recognizing images that are called by plugins. And this isn't about that. In fact I am very careful during deployment so that these images are included manually. The issue I have is it seems every time I use this there are missing face graphics and animations and even sound effects from the project that are clearly called by base engine commands. Honestly right now this behavior means that I have to test my entire (12hr) game from front to back before releasing every single update. And it's a pain. Not only that but I'm not even looking for real bugs. I'm looking for graphics or sounds that rpgmaker forgot about.
     
    #1
  2. Kes

    Kes Global Moderators Global Mod

    Messages:
    20,926
    Likes Received:
    10,640
    First Language:
    English
    Primarily Uses:
    RMVXA
    This isn't the place to report bugs which should be over in MV Improvement Board, using this template.

    However, before doing that, I'll move this to MV Deployment because other people have used this without those issues, so it may be that it's not an engine bug, but something about your set up.

    Moving to RPGMaker MV Deployment

     
    #2
  3. Andar

    Andar Veteran Veteran

    Messages:
    28,610
    Likes Received:
    6,568
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    can you give examples?
    because there is one other reason why this might happen - if any of those files or the directory path to them does not conform to networking rules.
    so please give the full paths to both the project directoy and the output directory (from drive letter to index.html) and give us an example of one of the files that was not included.
     
    #3
  4. RHachicho

    RHachicho Veteran Veteran

    Messages:
    264
    Likes Received:
    125
    Location:
    Basildon, United Kingdom
    First Language:
    English
    The project directory is G:\FWEP1 and the target directory is G:\Deploy\F1EP1 I rename the directory later to include a dot but that shouldn't interfere with deployment right? As for an example ..
    [​IMG]
    [​IMG]
     
    #4
  5. RHachicho

    RHachicho Veteran Veteran

    Messages:
    264
    Likes Received:
    125
    Location:
    Basildon, United Kingdom
    First Language:
    English
    So I guess since both my deployment directories and my images are net code complient .. One of them even being a DLC image .. U got nuthin?
     
    #5
  6. Andar

    Andar Veteran Veteran

    Messages:
    28,610
    Likes Received:
    6,568
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    the problem is that I wasn't interested in the images itself but in the filenames of the images.
    And unfortunately I can't be sure if the names I get from trying to save them are the correct ones or set by the forum software.
    If they are the correct names, then it still might be that they break the rules:

    One of the names I get is UkIvKx.png
    That is critical because of Windows's capitalization override - the override that loads the wrong file if there is a difference in capitalization.

    For all but Windows, the files abc.png and Abc.png are two different files, because the letter a is a different letter than A (for the computer, the code are two different numbers).
    Windows is the only OS that redirects a loading function to Abc.png if the engine tries to load abc.png if that other file with the wrong name exists.
    So the deleted picture files could be that the deployment function saw that you used abc.png in your game and deleted the not used file Abc.png from the deployment. Because in non-Windows OS the engine wouldn't be redirected to the wrong file Abc.png anyway if it is looking for abc.png
     
    #6
  7. RHachicho

    RHachicho Veteran Veteran

    Messages:
    264
    Likes Received:
    125
    Location:
    Basildon, United Kingdom
    First Language:
    English
    One of the images is called ZhaiOhlTPK.png and the other is 60FPS_AC2Q005_Swipe.png
    Also I really don't think that's the case there's the possibility that the first one was renamed at one point. But 60FPS_AC2Q005_Swipe.png came from rpgmaker DLC and has never been messed with since I copied it to the project directory.
     
    #7

Share This Page