Encrypted game doesn't show custom menu pictures

Haydeos

The Dragon
Veteran
Joined
Apr 6, 2014
Messages
513
Reaction score
969
First Language
English
I'm using SumRndmDude's Menu Backgrounnds plugin, Version 2.05.

They work fine while play-testing and also when I deployed the game without encrypting the files.

However, when I encrypt the deployed game files, the backgrounds are missing, it becomes a black background.

What am I missing?
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,709
Reaction score
7,365
First Language
German
Primarily Uses
RMMV
that sounds as if that plugin can't handle encrypted files - in this case you'll have to ask @SumRndmDde for an update enabling that function.
Also make sure that your projects core (that is different from the editor) is up-to-date
 

SumRndmDde

Follower of RNGesus
Veteran
Joined
Jul 30, 2013
Messages
225
Reaction score
423
First Language
English
Primarily Uses
RMMV
The plugin does not do anything "special" when it comes to loading images, and I haven't received any reports of this plugin not working with encryption (despite how relatively old it is), so I doubt that there's a problem with the encryption itself.

Could you perhaps check to make sure the background images are included with the exported game?
Maybe you may have checked "Exclude Unused Files" unintentionally? :kaoswt2:
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,709
Reaction score
7,365
First Language
German
Primarily Uses
RMMV
another question:
which version are the core files of your project?
There was someone who couldn't encrypt without errors because the project's core files were too old and couldn't handle encryption.
 

Haydeos

The Dragon
Veteran
Joined
Apr 6, 2014
Messages
513
Reaction score
969
First Language
English
My core JS files are all 1.4.1

I'm also not excluding any unused files, I've tried moving it around in the plugin order all with the same result.

I've also tried reinstalling or just turning off other window related plugins.

I have also now just tried removing the plugin itself, redownloading it & renaming the images. Still nothing.

I've also now tried installing the plugin & needed images on an entirely new & clean game, with ALMOST the same results: Not encrypted works as intended. Encrypted gives an error "Failed to Load: img/SumRndmDde/menu/Menu.png"
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

12 done, 4-5 started. Now that the weekend is over, things will sloooowwwww down again proabably.
when you're completely done with someone's crap lol...
Ami
--- Survival For RPGist Part 3 ---

F.Healer: Here it is,I made the Simple Sandwich
Survivalist
: it's so Delicious!
Chef: Here you Go! My Gourmet Steak.
Survivalist: It's Super Delicious,Too!
F.Mage: I Made it for you!
F.Healer: Uhh...Charcoal?
F.Mage No,It's a Toast!
Chef: Did you Let it in 10 Minutes?
F.Mage: Maybe?

Forum statistics

Threads
103,033
Messages
996,817
Members
134,507
Latest member
juegostudios
Top