Status
Not open for further replies.

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
546
Reaction score
21
First Language
english
Primarily Uses
RMVXA
So I am having some weird issues with this script. When I face an enemy and kill them it counts it as two defeated even when there was only one in the battle. How do I fix this?
1635368662952.png
Edit: Just noticed that this was put in the wrong spot. My bad.
 

Attachments

  • Scripts.zip
    579.8 KB · Views: 0
Last edited:

Roninator2

Gamer
Veteran
Joined
May 22, 2016
Messages
3,356
Reaction score
795
First Language
English
Primarily Uses
RMVXA
Which enemy was it? I may not have your latest game files, but in my test on your scripts, it worked fine.
 

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
546
Reaction score
21
First Language
english
Primarily Uses
RMVXA
Which enemy was it? I may not have your latest game files, but in my test on your scripts, it worked fine.
I was a group if different slimes.

One thunder slime.
1635380655568.png
After one battle:
1635380733055.png
It says number defeated: 2
There was only one thunder slime.
Game file:
 
Last edited:

Roninator2

Gamer
Veteran
Joined
May 22, 2016
Messages
3,356
Reaction score
795
First Language
English
Primarily Uses
RMVXA
It looks like just an error with the troop. I cleared the enemies and re-added them.
then it worked.
 

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
546
Reaction score
21
First Language
english
Primarily Uses
RMVXA
It looks like just an error with the troop. I cleared the enemies and re-added them.
then it worked.
Does that mean I have to redo all the troops?
Edit: Re-added the troop, but it still gave the same problem.
 

Roninator2

Gamer
Veteran
Joined
May 22, 2016
Messages
3,356
Reaction score
795
First Language
English
Primarily Uses
RMVXA
so far just the one. It may have been caused by an extra troop getting placed in there from a blank enemy.
 

Roninator2

Gamer
Veteran
Joined
May 22, 2016
Messages
3,356
Reaction score
795
First Language
English
Primarily Uses
RMVXA
Just be careful of what enemies you place in the troop and test the ones you have done to see if they are working.
 

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
546
Reaction score
21
First Language
english
Primarily Uses
RMVXA
Just be careful of what enemies you place in the troop and test the ones you have done to see if they are working.
With the thunder and healer slimes, I just copy and pasted the slimes and changed some info on them and changed their color. I don't know what could be causing the problem.
Ok, so the problem is even going through the regular enemies that were default in the database. It is acting as though one kill counts as two kills. It even happens in a new project.
 
Last edited:

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
546
Reaction score
21
First Language
english
Primarily Uses
RMVXA
@Roninator2 So I looked into it and it must be an incompatible script in my list of scripts. I will do some digging and see what I can find out.
 

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
546
Reaction score
21
First Language
english
Primarily Uses
RMVXA
@Roninator2 Found the problem. It is an incompatibility with Yanfly ace Battle script:
I tried it without the battle engine and everything worked just fine.
 

Roninator2

Gamer
Veteran
Joined
May 22, 2016
Messages
3,356
Reaction score
795
First Language
English
Primarily Uses
RMVXA
I think it's the battle log in yanfly battle engine.
Comment out line 2505.
Test and see if it works correctly,
 

slickdeath97

Veteran
Veteran
Joined
Feb 26, 2019
Messages
546
Reaction score
21
First Language
english
Primarily Uses
RMVXA
I think it's the battle log in yanfly battle engine.
Comment out line 2505.
Test and see if it works correctly,
IT WORKED! THANK YOU SO MUCH! YOU ARE A LIFE SAVER!
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
44,100
Reaction score
15,517
First Language
English
Primarily Uses
RMMV

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Latest Threads

Latest Profile Posts

Got a windowskin working nicely to go with Mog's menu plugins.
p8BE5bj.png

tsD4gZS.png

nwpeK84.png
Just getting started on RPG maker and having a blast!
I am once again escalating in the kitchen. I might or might not be 4 types of cookies into baking and not finished...
Today is a great day!
A bust of my character, Lizzabelle, that I put together in GIMP. I combined the RMMZ generated face with my actual illustration of her. This is just me experimenting with busts. I don't really want to use busts in dialogue, but perhaps in the character menu.

2Ixbzbd.png

Forum statistics

Threads
117,036
Messages
1,104,012
Members
152,958
Latest member
Ahbsz
Top