Alyon93

Veteran
Veteran
Joined
May 19, 2015
Messages
62
Reaction score
2
First Language
Italian
Primarily Uses
N/A
Hi guys,


Sorry for bothering you with this question.

I've a problem with the appear half-way option on the enemy in troop.

I've set the option and I've set the condition to be the 2° turn in the battle, for a single time.

So I've put of course the command  "enemy approach" or "enemy appear"(not sure for the right spelling since I haven't RMVXA in English) on the right enemy.

But even if the enemy actually become present(he can attack, he can receive status) his actual sprite is not visible.

It becomes visible only once you select it during target selection(when it is flashing) and afterwards it is visible as intendend. 

The strange thing is that it only started to behave like this only recently, in the past months it worked as intended.

The only things I've changed in this period is the version(I have the Steam one) and I've added another event page in the troop(nothing that cares about enemies anyway).

What do you guys think it's causing this issue?

As always sorry if my english is not perfect(I'm not native) and I hope it won't bother you too much to answer me.

Thanks in advance
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
36,691
Reaction score
9,863
First Language
German
Primarily Uses
RMMV
Please post screenshots of the troop with the event, we need to see it to check it for problems.


But most likely this is caused by a script (or to be precisely I assume you added a script recently to the battlescripts you were already using, and that was a script that introduced an incompatibility). Test this by transfering the troop with the events to a new project to see if it works without any scripts added to the project.
 

Alyon93

Veteran
Veteran
Joined
May 19, 2015
Messages
62
Reaction score
2
First Language
Italian
Primarily Uses
N/A
As you suggested the problem was a script. 

I tried it on a completely new project and it worked.

Afterwards I tried to find out what was the script to cause the issue and it appears to be this one:

http://www.rpgmakercentral.com/topic/155-cache-optimization/

Cache Optimization by Jet.


I thought it made sense because it has to do with the graphics.

I posted it here so that anyone with the same script might be interested in knowing this little bug.

Maybe the original scripter would be interested in solving this.

It's ok now, hope my question could be anyone else useful.

As always, thanks  a lot Andar for your quick and useful answers.


Have a good day!
 

Latest Threads

Latest Profile Posts

For those with up to 9 elements of magic; how do you structure your database. By element? Or by what is offensive vs supportive spells?
would anyone here be interested in rough concept art for the main protagonist of my game that might get changed later? :kaoswt2:
I guess I have no idea how to properly upload a custom font lmao. The menu fonts are too damn small.

Font_Size.PNG
Dev be like: "I'll make the character goes amnesia so I could explain the world and the lore better and immersive to the players"

Forum statistics

Threads
124,435
Messages
1,163,638
Members
163,251
Latest member
Rpgmaker_mf
Top