Error when characters move in game

squidsofspace

Warper
Member
Joined
Nov 4, 2015
Messages
3
Reaction score
0
First Language
English
When I run a PlayTest, it loads correctly, I can click continue or new game. But when I either move the characters or open the menu, one of these

two errors appears.

Move: Cannot read property 'traits' of undefined

Menu: Cannot read property 'params' of undefined

I have tried checking my items, actors, enemies or whatever for blanks in the 'traits' section (pretty thoroughly) for any blanks made by me deleting

things in the database.

Anyone know if this is a common problem or what the solution may be?
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,665
Reaction score
13,276
First Language
English
Primarily Uses
RMMV
Does it happen on a brand new project? If not, it's likely because of plugins. So let us know which ones you're using.
 

squidsofspace

Warper
Member
Joined
Nov 4, 2015
Messages
3
Reaction score
0
First Language
English
Does it happen on a brand new project? If not, it's likely because of plugins. So let us know which ones you're using.
TBH, I haven't downloaded or used any plugins yet. Still getting used to the program.

When I run a new project it is able to work. I think it has something to do with an error I am causing in the database, but I don't actually have any idea.
 

Sated

puking up frothing vitriolic sarcastic spittle
Veteran
Joined
Nov 4, 2015
Messages
127
Reaction score
112
First Language
English
Primarily Uses
N/A
This used to happen in the older makers if you reduced the maximum size of database lists, things like items or skills or heroes. Try setting them all to their maximum value and see if you still get the error.
 
Last edited by a moderator:
Joined
Feb 22, 2014
Messages
4
Reaction score
0
First Language
English
Primarily Uses
  I was having the same problem I'm using steam I had to reinstall to fix it. Now my characters are moving but now the event keeps running over and over until the characters run out of room.
 

squidsofspace

Warper
Member
Joined
Nov 4, 2015
Messages
3
Reaction score
0
First Language
English
So, in the end, I just made a new save file in the game itself, overriding the old one. The errors didn't occur again.

Sorry for wasting your time.
 

Raths Rants

Veteran
Veteran
Joined
Mar 9, 2014
Messages
100
Reaction score
18
First Language
English
Primarily Uses
RMMV
So, in the end, I just made a new save file in the game itself, overriding the old one. The errors didn't occur again.

Sorry for wasting your time.
I had the same issue when working with VX/Ace. Old saves don't seem to play nice with edits that change the base game. Like removing a database entry for example.

You have to start a new game and make a new save.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Husband has roped me into playing one of his PSO2 characters. Productivity is now negative.
Tileset A is lava! Don't burn D:
as MZ come out what you guys think about.....Some particles engine :3c?
Who wants to sing this song with me?~

Decided to submit my games to the Monday Night Stream. Figured it might be a fun way to get some traction.

Forum statistics

Threads
100,703
Messages
978,537
Members
132,319
Latest member
ZlayerDragg
Top