Error when i play test

Discussion in 'RPG Maker MV' started by rudystudio, Sep 6, 2018.

    Tags:
  1. rudystudio

    rudystudio Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    Portuguese
    Primarily Uses:
    Other
    error in my project RMMV version 1.3.0.0/ I was going to play peacefully and when I first went to start the test he gave it this:
    Sem Título.png what i should to do?
     
    Last edited: Sep 6, 2018
    #1
  2. Aloe Guvner

    Aloe Guvner Walrus Veteran

    Messages:
    1,626
    Likes Received:
    1,049
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    Can you please show two screenshots from your project?

    1.)
    Your project structure (see my example below).

    2.)
    The inside of your "package.json" file (see my example below) - open this file with any text editor.

    ProjectStructure.png

    PackageJSON.png
    PackageJSONinside.png
     
    #2
    rudystudio likes this.
  3. rudystudio

    rudystudio Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    Portuguese
    Primarily Uses:
    Other
    Thank you first for having responded. here's what i should do more?
    2018-09-06 (1).jpg 2018-09-06.jpg
     
    Last edited: Sep 6, 2018
    #3
  4. Aloe Guvner

    Aloe Guvner Walrus Veteran

    Messages:
    1,626
    Likes Received:
    1,049
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    Hmmmm, my first guess might be wrong.

    I was looking at your error message, specifically this part:
    SemTítulo.png

    I first thought your error was because of the "package.json" file. This file tells the program the entry point to the game. I thought your "package.json" file contained an incorrect path for the "main" property.

    Normally when you do "Test Play", it does not look for the "www" folder. In your case, it is looking for a file called "index.html" inside of a "www" folder. Actually, it should not look at any "www" folder, it should only look at the "index.html" from the same level. Here is an example of my "Test Play":

    NormalTestPlay.png

    We can check one more thing:

    Please open your "rpg_core.js" file with a text editor and take a screenshot of the version number. This file is inside the "js" folder. Then compare it to the version number of the editor program (press Help --> About...) to show the editor version.
    The version of your project and the version of your editor should be equal.

    Here is an example:
    VersionCheck.png
     
    #4
  5. rudystudio

    rudystudio Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    Portuguese
    Primarily Uses:
    Other
    Your guess is right.
    2018-09-06 (2).jpg 2018-09-06 (3).jpg
     
    #5
  6. Aloe Guvner

    Aloe Guvner Walrus Veteran

    Messages:
    1,626
    Likes Received:
    1,049
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    OK, so the Project files are v1.6.1 but the Editor is v1.3.0.

    Either you can downgrade the Project to v1.3.0 to match the Editor, or upgrade the Editor to v1.6.1 to match the Project.

    Here are some instructions from the official thread. The instructions will work either way, it's important to make these two versions equal. This may solve your error.
     
    #6
  7. rudystudio

    rudystudio Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    Portuguese
    Primarily Uses:
    Other
    Ok tomorrow i install , rpgmv v1.6.1 and i tell you if it work thank you
     
    #7
  8. rudystudio

    rudystudio Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    Portuguese
    Primarily Uses:
    Other
    Hey man can you help me how i install project for v1.3.0 ?
     
    #8
  9. Andar

    Andar Veteran Veteran

    Messages:
    28,642
    Likes Received:
    6,584
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    why are you asking that?

    you can only install the editor, and then "update" a project to the same version as the editor.
    and downgrading a project is not always the best solution.

    so it depends on when and why you updated your project to 1.6.1 - and how you even managed that without going to 1.6.1 in the editor...
     
    #9
  10. rudystudio

    rudystudio Villager Member

    Messages:
    6
    Likes Received:
    0
    First Language:
    Portuguese
    Primarily Uses:
    Other
    I dont know because my editor is 1.3.0 crack and then i enter in project he is 1.6.1 and i dont know how to update my project to 1.3.0
     
    #10
  11. Kes

    Kes Global Moderators Global Mod

    Messages:
    20,976
    Likes Received:
    10,674
    First Language:
    English
    Primarily Uses:
    RMVXA

    Given the evidence, we heavily suspect that you are using a pirated RPG Maker, which is not tolerated here and we have an instant-ban policy regarding this. You have now been banned. If you feel we were incorrect and you have been falsely accused, you can send us a support question with proof of your purchase of the RPG Maker to revert our decision.

     
    #11

Share This Page