Event not fading out/in?

Discussion in 'RPG Maker VX Ace' started by SpookyHollows, Feb 5, 2017.

  1. SpookyHollows

    SpookyHollows Veteran Veteran

    Messages:
    58
    Likes Received:
    5
    First Language:
    English
    Primarily Uses:
    RMMV
    Been a while since I've asked a question on here, I figured now is a good time.
    While working on the second Chapter of my RPG game, I was working on adding in a new story cutscene, with images I had drawn and imported in. I set up the event, and it works, sort of...

    In Chapter 2, you need to find a place for the character to sleep. Once you find a place, he has a nightmare. (Where I have the images show up). But I would like the screen to fade out when you first click on the sleeping area, then fade in to show the images. Right now, when you click on the event, it only makes the images and text pop up (the BGM works as well, and the screen tinting) the only thing that doesn't work, is the fading in and fading out.
    I have the event set up like this so far... (in the attached file, not sure how to get it to show up in post.)

    Any help with this is greatly appreciated!

    And yep, I'm using VX Ace. :)
     

    Attached Files:

    #1
  2. Shaz

    Shaz Veteran Veteran

    Messages:
    37,552
    Likes Received:
    11,260
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    There shouldn't be any need to show the same picture twice.

    Have you tried adding a Wait after fade out?
     
    #2
  3. SpookyHollows

    SpookyHollows Veteran Veteran

    Messages:
    58
    Likes Received:
    5
    First Language:
    English
    Primarily Uses:
    RMMV
    @Shaz I just tried adding Wait, however it still didn't do a fade effect. It ended up making the screen freeze, and got rid of the weather effects immediately, then the image popped up.
     
    #3
  4. Andar

    Andar Veteran Veteran

    Messages:
    28,311
    Likes Received:
    6,437
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    the transfer player command - does it go to the same map or to a different map?

    If it goes to a different map, the event you screenshot will be deleted and all commands after the transfer command will be gone with it.
    Some commands might work as long as the event itself is in processing, but that depends on too many variables - everything below a transfer to a new map should be in a new event on that new map to work correctly.
     
    #4
  5. SpookyHollows

    SpookyHollows Veteran Veteran

    Messages:
    58
    Likes Received:
    5
    First Language:
    English
    Primarily Uses:
    RMMV
    @Andar
    It's all in the same map.
     
    #5
  6. Shaz

    Shaz Veteran Veteran

    Messages:
    37,552
    Likes Received:
    11,260
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    Do you have any scripts? Disable them all and see if the issue still happens. Another test could be starting a brand new project and putting in just that event (and the necessary graphics, though you could probably just use default ones) and see if it works there.

    So this event is in [the city] map?

    Could you please show a screenshot of page 2 of that event?
     
    #6
  7. SpookyHollows

    SpookyHollows Veteran Veteran

    Messages:
    58
    Likes Received:
    5
    First Language:
    English
    Primarily Uses:
    RMMV
    @Shaz I never used any scripts, this event is in one of the city maps, the third city map (I have different ones for different parts of the story).
    I think it's working now though, I had to make the wait event set at about 300 or so, it would freeze a little bit but then it finally faded.
    I ended up having the player get teleported to the fourth city map, where the screen fades back in and then tints, which seems to have worked better than having everything jumbled up in the third map. XD
     
    #7
  8. Shaz

    Shaz Veteran Veteran

    Messages:
    37,552
    Likes Received:
    11,260
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    300 is 5 seconds. Fadeout/fadein usually take much less time than that.

    But if it all works ... ;)
     
    #8

Share This Page