Event Sprite Appearing Black Durning Playtest

Joined
Jul 25, 2019
Messages
30
Reaction score
2
First Language
English
Primarily Uses
RMMV
Hello All,

Recently ive been having an issue with a specific scene in a project i'm working on. A cutscene required a sprite with more than the usual 3 frames, so i'm using Shaz's More character frames plugin. However, whenever I playtest the scene the sprite is black. Attached are the sprite, how it appears in the editor, and how it appears during playtesting. Do any of you know how to fix this?

The Spritesheet
Screen Shot 2020-10-19 at 10.37.29 AM.pngScreen Shot 2020-10-19 at 10.39.10 AM.png
 

EpicFILE

Epic Member
Veteran
Joined
Sep 27, 2017
Messages
429
Reaction score
1,365
First Language
Indonesia
Primarily Uses
RMMV
Why don't you use show picture event? I think it's a lot easier. :D
 

caethyril

^_^
Veteran
Joined
Feb 21, 2018
Messages
2,058
Reaction score
1,483
First Language
EN
Primarily Uses
RMMZ
RPG Maker treats each image as a separate texture, and I think the maximum size PIXI allows is 4096 px square (?). Your GPU might limit that further. Not sure if that's the problem here. :kaoslp:

As mentioned, you might be best off using a series of Show Picture commands instead~
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,256
Reaction score
7,632
First Language
German
Primarily Uses
RMMV
your filenames for the sprites break networking rules by containing spaces.
that also will prevent a browser from loading them.
 
Joined
Jul 25, 2019
Messages
30
Reaction score
2
First Language
English
Primarily Uses
RMMV
Why don't you use show picture event? I think it's a lot easier. :D
I've had trouble with the show picture event before, which is why ive been doing this instead, but I might as well just do this


your filenames for the sprites break networking rules by containing spaces.
that also will prevent a browser from loading them.
The sprite has to be named that was for the plugin to work its magic, although it might be an issue as well
RPG Maker treats each image as a separate texture, and I think the maximum size PIXI allows is 4096 px square (?). Your GPU might limit that further. Not sure if that's the problem here. :kaoslp:
Maybe, ill have to experiment with the art a bit
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,256
Reaction score
7,632
First Language
German
Primarily Uses
RMMV
The sprite has to be named that was for the plugin to work its magic, although it might be an issue as well
then the plugin has problems and is not programmed correctly.
no browser ever has been able to handle spaces in filenames, it is only with an override replacing spaces with the code %20 that Windows has forced browsers to be able to load such file - and that override does not work every time, and is windows only (other operating systems have other overrides).

So whoever programmed that plugin is not very experienced if he/she made such a mistake, and that means there might be other mistakes in the plugin as well.
 

caethyril

^_^
Veteran
Joined
Feb 21, 2018
Messages
2,058
Reaction score
1,483
First Language
EN
Primarily Uses
RMMZ
@Andar newer versions of MV's code base explicitly invoke JavaScript's native encodeURIComponent method, negating problems related to non-standard characters in filenames. :) Supporting code excerpt:
JavaScript:
ImageManager.loadBitmap = function(folder, filename, hue, smooth) {
    if (filename) {
        var path = folder + encodeURIComponent(filename) + '.png';
        var bitmap = this.loadNormalBitmap(path, hue || 0);
        bitmap.smooth = smooth;
        return bitmap;
    } else {
        return this.loadEmptyBitmap();
    }
};
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
40,062
Reaction score
13,687
First Language
English
Primarily Uses
RMMV
So whoever programmed that plugin is not very experienced if he/she made such a mistake, and that means there might be other mistakes in the plugin as well.
That would be me, and the plugin has always worked for most people using it. The spaces would cause issues if the game were being deployed to a non-Windows device, but that is not what's happening here.

I can see that that is a very large sprite, and you appear to have 26 frames in each direction. It is likely not being loaded due to image size.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Why is there so much month left at the end of money? D=
Hello humans! How goes your day in this journey of living? I hope it is good, for I am human like you, and I am feeling great! Worship the altar.
Sand is basically small rocks

Forum statistics

Threads
105,608
Messages
1,014,969
Members
137,273
Latest member
Parzival
Top