Events do X at time Y. not working properly.

Status
Not open for further replies.

jetboost

Veteran
Veteran
Joined
Sep 29, 2016
Messages
84
Reaction score
26
First Language
Dutch
Primarily Uses
RMMV
Hello i'm quite new to this forum but have learned quite a bit from reading the different threads you can find here but now i have an issue that i haven't been able to solve myself the last couple days so i would like to ask for some help/advice.

As the title says i want to have events do X at time Y this is working properly already in a the map a floor higher and outside even though it's a bit of hassle.
But now 1 of the events is providing me with a headache because it doesn't do it's work properly most of the time (to clarify yes sometimes it does work but interaction is a bit off can't talk with the event or the event is just continuing along or walking through the player i haven't been able to pinpoint the reason why this is the case but when i simply wait for a minute or so the chances of it working seem to increase?)

The event is going by the name guard1 and is being directed by another event there is a guard2 setup in the same way but he has no issues.

The crystalls you see are there for setting time left one for minutes and the right one for hours and then there is the transfer player event in the form of a stairway.
There are no further events on the map.

I have made some screenshots as well.

Can someone tell me what is perhaps going on and how to solve this?
I myself suspect it might have something to do with the way i made the balloon icon apear but as you can see guard2 is sleeping soundly so haven't really tested that case further.
Edit:
Thought it might be usefull to also mention the plugins you see in use over here:
Yanfly moveroute core and Yanfly Save event locations though in case of the latter it isn't apparent its in use i do have some more plugins in use but they are all from Yanfly (except one that has to do with pausing weather) if needed i will post the entirety of my pluginlist.
Edit2:
I think i may have found where the problem lies i disabled the passing of time and manually set the time in accordance with the guard events and then everything seems to go smoothly.
normally time would every (5 * wait 60) 300 frames do $minute+1.
It also seems there where also issues with guard 2 just i didn't notice it because his image was set to none i could't see it but he was still standing next to the stairs but i think due to this guard 1 couldn't come down from the stairs because the guard2 event was occupying that spot and from that point further screwing up this cycle.

Or another possibility is that the parallel process refreshes itself during the code it's supposed to run and thus maybe partly overwriting each other? or wanting to run both?

At the very least something is conflicting with each other and i have got the feeling it's the second possibility i mentioned.

Can someone confirm this?
Edit3
Ruled out possibility 2 in edit2.
It s seems this bug?mymistake? occured with the use of the "TELEPORT: X, Y" but i can't see a mistake in my way of using the command.
Because some(if not all of) my issues have dissapeared when i used the build in function to set an events position when i have everything properly replaced and in correct order i will let it be known if it works now if it does then i have found out that the issue originated with my (maybe excessive/wrong) use of that plugin command.
But this will be something for tommorow.
Edit4
It was indeed the use of the "TELEPORT: X, Y" command which was keeping the rest from properly working the issue has been solved by replacing it with the build-in function so my issue is solved.
But i'm still left with the question why it was conflicting was it because i was making use of it in a wrong way? Or is there a bug? Or something else?

Greetings Jetboost.
 
Last edited:

jetboost

Veteran
Veteran
Joined
Sep 29, 2016
Messages
84
Reaction score
26
First Language
Dutch
Primarily Uses
RMMV
I have narrowed it down to be an issue with (my way of use of?)the plugins it wasn't an event structure issue so i don't know what to do with this thread now.
 

jetboost

Veteran
Veteran
Joined
Sep 29, 2016
Messages
84
Reaction score
26
First Language
Dutch
Primarily Uses
RMMV
And my other problem that when i interact with the event that it walked through me well that a problem for not having it "Wait for completion" but it didn't teleport (for this i have made a different thread under javascript/plugin support)and i am now using the "Jump to: X, Y" command.

This brought me another problem but that has also been solved so the rest of my questions will await to be answered here.
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
12,502
Reaction score
12,785
First Language
English
Primarily Uses
RMVXA

This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

 
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

I'm an adult married woman

Being a hobbyist dev and also loving my job is like nothing to lose during both busy days and holidays ~ ♥
I tried to free some space in my phone and this is what I find: https://framapic.org/Dio090k00QQ6/8tiNZ3AV5IYw.png
...Almost 60% of all images in my gallery is just that- books and notes and guides...
I've bought a set of Harry Potter to entertain myself. However, my crazy geography homework accounts for more than half of my homework.
Girls with swords are cool on their own. Then I give them guns. *Profit*

Forum statistics

Threads
93,449
Messages
912,502
Members
122,976
Latest member
ssalum
Top