Failed to load tileset data?

Discussion in 'RPG Maker VX Ace' started by AllyJamy, May 12, 2017.

  1. AllyJamy

    AllyJamy Veteran Veteran

    Messages:
    48
    Likes Received:
    25
    First Language:
    English
    Primarily Uses:
    RMVXA
    So this basically started when i copied my project over to a hard disk, because I was resetting my PC.
    Suddenly this message "Failed to load tileset data" started coming up and I can not open my project or game.

    I've looked for solutions to this problem such as replacing the tileset data with a clean one. To no avail.
    It doesn't look like any of my tileset files are damaged, so I don't know what the problem is.
    Could anyone help?

    [​IMG]
     
    #1
  2. Andar

    Andar Veteran Veteran

    Messages:
    27,233
    Likes Received:
    6,017
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    some of your project files have been damaged while being copied - you can try to copy them again or try to replace the given file with the version from a new project.

    In any such message, the damage could be in one of three cases:
    1) the file mentioned in the error message
    2) the project file itself (which tells the engine what and where to load
    3) the editor could be damaged and needed to be reinstalled
     
    #2
  3. AllyJamy

    AllyJamy Veteran Veteran

    Messages:
    48
    Likes Received:
    25
    First Language:
    English
    Primarily Uses:
    RMVXA
    Yep thats what I figured.
    It doesn't say anything about what file is damaged though. and they all look fine after sifting through them. I've just done a clean install of windows 10 and rpg maker now aswell. and copied my project from my hard disk over to my PC, but its still acting up. The only thing it could be is the photoshop files I have in my graphic folders. But I don't see how that could affect the tilesets. I remember some errors coming up for some files when I was copying it over to the hard disk, but I just dismissed them as a common error at the time. I don't remember which files that came up though.
     
    #3
  4. Andar

    Andar Veteran Veteran

    Messages:
    27,233
    Likes Received:
    6,017
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    wrong, that's why I pointed you to the message.

    Failed to load tileset data means that the file tilesets.rvdata2 inside your data folder is damaged - all files are named after the data they contain.
     
    #4
  5. AllyJamy

    AllyJamy Veteran Veteran

    Messages:
    48
    Likes Received:
    25
    First Language:
    English
    Primarily Uses:
    RMVXA
    Okay. Is there anything I can do to fix it, apart from replacing the tilesets.rvdata2 with a clean one? Because that hasn't seemed to have worked.
     
    #5
  6. Andar

    Andar Veteran Veteran

    Messages:
    27,233
    Likes Received:
    6,017
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    if exactly the same thing happens (with exactly the same error message and not one pointing to the next damaged file), then either the replacement file was damaged as well or it was one of the other two causes.
     
    #6
  7. AllyJamy

    AllyJamy Veteran Veteran

    Messages:
    48
    Likes Received:
    25
    First Language:
    English
    Primarily Uses:
    RMVXA
    Yep, exact same error. So it may well be the project file itself thats damaged. Is there anything that can be done about that?
     
    #7
  8. Andar

    Andar Veteran Veteran

    Messages:
    27,233
    Likes Received:
    6,017
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    same way as any other file: replace it with a clean version from a new project.

    If that doesn't change and reinstalling the editor doesn't help either, I suggest you upload the project somewhere and link it to ask other people if they can access the data - it might be something on your computer
     
    #8
  9. AllyJamy

    AllyJamy Veteran Veteran

    Messages:
    48
    Likes Received:
    25
    First Language:
    English
    Primarily Uses:
    RMVXA
    Nope, that hasn't seemed to work either... thanks for the help anyway!
     
    #9
  10. Celianna

    Celianna Tileset artist Global Mod

    Messages:
    10,464
    Likes Received:
    5,449
    First Language:
    Dutch
    Primarily Uses:
    RMMV
    If all else fails, create a new project, and slowly copy in over your database stuff from your old project, one by one, and keep checking if it works until you find the culprit. Hopefully by then, you have copied at least the bulk of your project.
     
    #10
    PhoenixX92 likes this.
  11. PhoenixX92

    PhoenixX92 The Light Bearer Veteran

    Messages:
    212
    Likes Received:
    94
    Location:
    United States
    First Language:
    English
    Primarily Uses:
    RMMV
    It's probably attempting to load the tilesets from a location that they don't exist in anymore. Delete the tilesets from the database, then reimport them.
    I had this problem once, and that's how I fixed it. That may not be your issue, though.

    *Edit*
    Just saw you said you can't open the project.
    Yeah, you're going to have to copy your project piece by piece into a new one like @Celianna said.
     
    #11
  12. AllyJamy

    AllyJamy Veteran Veteran

    Messages:
    48
    Likes Received:
    25
    First Language:
    English
    Primarily Uses:
    RMVXA
    Thanks for tips guys, I'll try them out.
     
    #12
  13. AllyJamy

    AllyJamy Veteran Veteran

    Messages:
    48
    Likes Received:
    25
    First Language:
    English
    Primarily Uses:
    RMVXA
    So yeah. It was the animation data that had messed up for some reason. Everything else was fine for the most part. Thank you for the help everyone. :)
     
    #13

Share This Page