Failing to initialize the game data/Map001.json

Alkaline

Veteran
Veteran
Joined
Jun 30, 2020
Messages
37
Reaction score
5
First Language
English
Primarily Uses
RMMV
Hey RPG Makers,

I just finished installing Yanfly's plugins, however when I went to test my game I keep getting this error... Any ideas what's causing it/how can I fix this?

Thank you all,
Alkaline
1593484288487.png
 

MushroomCake28

KAMO Studio
Global Mod
Joined
Nov 18, 2015
Messages
3,783
Reaction score
4,726
First Language
English
Primarily Uses
RMMZ

I've moved this thread to Javascript/Plugin Support. Please be sure to post your threads in the correct forum next time. Thank you.

 

Alkaline

Veteran
Veteran
Joined
Jun 30, 2020
Messages
37
Reaction score
5
First Language
English
Primarily Uses
RMMV
Oh my apologies, this is my first post I didn't know where to find the proper place to post it...
 

MushroomCake28

KAMO Studio
Global Mod
Joined
Nov 18, 2015
Messages
3,783
Reaction score
4,726
First Language
English
Primarily Uses
RMMZ
Don't worry about it, the blue text is auto-generated, it's not a personal message.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
40,829
Reaction score
14,021
First Language
English
Primarily Uses
RMMV
Are you choosing New Game from the title screen, or are you trying to load a game you'd previously saved? Or aren't you even getting to the title screen?

One VERY common issue that causes issues with Yanfly's plugins is having them in the wrong order. If you go to Yanfly's site, where you can see the list of all the plugins, you MUST have them in the same order as they appear on that page.

So go check that, make sure they're all in the right order, and try to run again. If you still get an error, please hit F8 to open the Developer Tools, find the Console tab in the window that appears, and grab a screenshot of that and post it here. Also post a screenshot of your Plugin Manager (or several screenshots, if you have more plugins than will show at once).
 

Alkaline

Veteran
Veteran
Joined
Jun 30, 2020
Messages
37
Reaction score
5
First Language
English
Primarily Uses
RMMV
I followed the order as indicated on the website when listing the plugins. This error shows up when I run the game even before getting to the Title Screen
1593494742403.png
1593494774785.png
1593494805716.png
1593494874068.png
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
40,829
Reaction score
14,021
First Language
English
Primarily Uses
RMMV
Okay - see that error screenshot? See the very first message there? "You are getting this error because you are trying to run YEP_X_ActorAutoBattleAI without YEP_BattleAICore"

So you are missing one plugin that another one requires in order to work properly.

So go find that plugin and add it to your project, making sure it's in the right place, and try again.

Can you also check your project's data folder and make sure there IS a file called Map001.json in there?
 

Alkaline

Veteran
Veteran
Joined
Jun 30, 2020
Messages
37
Reaction score
5
First Language
English
Primarily Uses
RMMV
The AI battle core was just misplaced i fixed that. Map001 doesnt show up on the data folder for whatever reason. This is weird because before I added the plugins the game was running just fine. I am still getting the same error :rsad:
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
40,829
Reaction score
14,021
First Language
English
Primarily Uses
RMMV
So did you delete any maps? It's trying to load map 1 for some reason, and it's not finding it. The others are probably just additional issues that we've discovered while troubleshooting this.

Do you ONLY have YEP plugins, or do you have others as well that you haven't shown in your screenshots above?

Do you have any plugins that skip the title screen, or use an evented title screen rather than the default? Do you have any plugins that clone events, and might be looking for events on map 1?
Just trying to figure out why it might be attempting to load map 1 before you've even started or loaded a game.

You could just create a new map in the editor, and it'll probably name it Map001 if it's not already there. But it'd be good to know why it's trying to load it, and what's meant to be on it.

Maybe check your recycle bin and see if there's a Map001 in there anywhere. If there is, create a new map in the editor, check that it's called Map001, save your game and exit the editor, then go and restore the old one from the recycle bin so you've got the original content. THAT might let you then load your game and run it without errors, and you can see what Map001 was originally for.

Also, both of these statements can't be true:
I followed the order as indicated on the website when listing the plugins.
The AI battle core was just misplaced i fixed that.

It would not be misplaced if you had followed the right order, which indicates that other plugins might also not be in the right order.
 

Alkaline

Veteran
Veteran
Joined
Jun 30, 2020
Messages
37
Reaction score
5
First Language
English
Primarily Uses
RMMV
1593528779816.png
These are the only non-YEP plugins I have. The whole thing about the AI battle core was that after putting the plugins in order and getting the error I tried to bundled up the cores together. When I went to put the cores back in their proper place I had misplaced only the AI battle core.

What confuses me is that before adding the plugins the game would run normally and I made no changes to the game itself, such as adding events or adding/removing maps
 

Trihan

Speedy Scripter
Veteran
Joined
Apr 12, 2012
Messages
2,616
Reaction score
1,978
First Language
English
Primarily Uses
RMMV
If you turn all plugins off are you still having the issue? Did you try the other things Shaz suggested with the map file?
 

Alkaline

Veteran
Veteran
Joined
Jun 30, 2020
Messages
37
Reaction score
5
First Language
English
Primarily Uses
RMMV
I created a new empty map and kept its standard name MAP001. That allowed the game to boot up! Thank you all for your help!
 

Latest Threads

Latest Posts

Latest Profile Posts

I'm moving on from RMXP finally. I've been stuck in a difficult decision between XP and MZ, and I've given up and moved on to MZ. Overall I'm really liking it, I wish tilesets were easier to setup like XP, but it's actually not that bad!
Have you ever gone full 'Ship of Theseus' while frankenspriting? Because I just did.
I saw my new eye doctor today, he reminds me of Satoru Iwata for some reason
I've been using a modified version of a script called Multiple Messages. It makes my text boxes look like a Mario & Luigi game! There is something about it that bothers me a little bit, but I shouldn't worry about that now.

Side note, Mist's walking animation is almost perfectly in sync with Loose Yourself by Eminem.
Starting work on some stuff for the community. Hopefully it will be fun, and useful to somebody.

Forum statistics

Threads
107,772
Messages
1,032,033
Members
139,914
Latest member
smudge
Top