Failing to initialize the game data/Map001.json

Alkaline

Villager
Member
Joined
Jun 30, 2020
Messages
23
Reaction score
3
First Language
English
Primarily Uses
RMMV
Hey RPG Makers,

I just finished installing Yanfly's plugins, however when I went to test my game I keep getting this error... Any ideas what's causing it/how can I fix this?

Thank you all,
Alkaline
1593484288487.png
 

MushroomCake28

KAMO Studio
Global Mod
Joined
Nov 18, 2015
Messages
3,334
Reaction score
4,425
First Language
English
Primarily Uses
RMMV

I've moved this thread to Javascript/Plugin Support. Please be sure to post your threads in the correct forum next time. Thank you.

 

Alkaline

Villager
Member
Joined
Jun 30, 2020
Messages
23
Reaction score
3
First Language
English
Primarily Uses
RMMV
Oh my apologies, this is my first post I didn't know where to find the proper place to post it...
 

MushroomCake28

KAMO Studio
Global Mod
Joined
Nov 18, 2015
Messages
3,334
Reaction score
4,425
First Language
English
Primarily Uses
RMMV
Don't worry about it, the blue text is auto-generated, it's not a personal message.
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,429
Reaction score
12,952
First Language
English
Primarily Uses
RMMV
Are you choosing New Game from the title screen, or are you trying to load a game you'd previously saved? Or aren't you even getting to the title screen?

One VERY common issue that causes issues with Yanfly's plugins is having them in the wrong order. If you go to Yanfly's site, where you can see the list of all the plugins, you MUST have them in the same order as they appear on that page.

So go check that, make sure they're all in the right order, and try to run again. If you still get an error, please hit F8 to open the Developer Tools, find the Console tab in the window that appears, and grab a screenshot of that and post it here. Also post a screenshot of your Plugin Manager (or several screenshots, if you have more plugins than will show at once).
 

Alkaline

Villager
Member
Joined
Jun 30, 2020
Messages
23
Reaction score
3
First Language
English
Primarily Uses
RMMV
I followed the order as indicated on the website when listing the plugins. This error shows up when I run the game even before getting to the Title Screen
1593494742403.png
1593494774785.png
1593494805716.png
1593494874068.png
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,429
Reaction score
12,952
First Language
English
Primarily Uses
RMMV
Okay - see that error screenshot? See the very first message there? "You are getting this error because you are trying to run YEP_X_ActorAutoBattleAI without YEP_BattleAICore"

So you are missing one plugin that another one requires in order to work properly.

So go find that plugin and add it to your project, making sure it's in the right place, and try again.

Can you also check your project's data folder and make sure there IS a file called Map001.json in there?
 

Alkaline

Villager
Member
Joined
Jun 30, 2020
Messages
23
Reaction score
3
First Language
English
Primarily Uses
RMMV
The AI battle core was just misplaced i fixed that. Map001 doesnt show up on the data folder for whatever reason. This is weird because before I added the plugins the game was running just fine. I am still getting the same error :rsad:
 

Shaz

Veteran
Veteran
Joined
Mar 2, 2012
Messages
39,429
Reaction score
12,952
First Language
English
Primarily Uses
RMMV
So did you delete any maps? It's trying to load map 1 for some reason, and it's not finding it. The others are probably just additional issues that we've discovered while troubleshooting this.

Do you ONLY have YEP plugins, or do you have others as well that you haven't shown in your screenshots above?

Do you have any plugins that skip the title screen, or use an evented title screen rather than the default? Do you have any plugins that clone events, and might be looking for events on map 1?
Just trying to figure out why it might be attempting to load map 1 before you've even started or loaded a game.

You could just create a new map in the editor, and it'll probably name it Map001 if it's not already there. But it'd be good to know why it's trying to load it, and what's meant to be on it.

Maybe check your recycle bin and see if there's a Map001 in there anywhere. If there is, create a new map in the editor, check that it's called Map001, save your game and exit the editor, then go and restore the old one from the recycle bin so you've got the original content. THAT might let you then load your game and run it without errors, and you can see what Map001 was originally for.

Also, both of these statements can't be true:
I followed the order as indicated on the website when listing the plugins.
The AI battle core was just misplaced i fixed that.
It would not be misplaced if you had followed the right order, which indicates that other plugins might also not be in the right order.
 

Alkaline

Villager
Member
Joined
Jun 30, 2020
Messages
23
Reaction score
3
First Language
English
Primarily Uses
RMMV
1593528779816.png
These are the only non-YEP plugins I have. The whole thing about the AI battle core was that after putting the plugins in order and getting the error I tried to bundled up the cores together. When I went to put the cores back in their proper place I had misplaced only the AI battle core.

What confuses me is that before adding the plugins the game would run normally and I made no changes to the game itself, such as adding events or adding/removing maps
 

Trihan

Speedy Scripter
Veteran
Joined
Apr 12, 2012
Messages
1,869
Reaction score
1,218
First Language
English
Primarily Uses
RMMV
If you turn all plugins off are you still having the issue? Did you try the other things Shaz suggested with the map file?
 

Alkaline

Villager
Member
Joined
Jun 30, 2020
Messages
23
Reaction score
3
First Language
English
Primarily Uses
RMMV
I created a new empty map and kept its standard name MAP001. That allowed the game to boot up! Thank you all for your help!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

Automatic level scaling without an option to turn it off can be a very bad choice for a game. The worst I've ever seen was in Nightmare of Druaga, where if a power outage made your system turn off, the game detects it as an attempted cheat and overwrites your save while taking away your best gear, leaving you unable to progress at the late stages of the game, and unable to recover.
Problem with sequels: Heroes getting rid of all their items and forgets all of their skills within the span of a year without explanation. :kaomad3:
I can see the end of my prologue. Perfect time to decide to pull everything over into MZ, right? Right?!
Excited to be nearing the end of setting up my own custom Point-And-Click system template! Just need to iron out some kinks, get an input text system going, add animations to buttons, and then finalize my button-mashing event system and it'll be complete >:3c
AlcTheHero wrote on Mystic_Enigma's profile.
hi.

Forum statistics

Threads
99,643
Messages
967,612
Members
131,312
Latest member
jacob_rev
Top