Falcao Pearl ABS attack enemy problem

Discussion in 'RGSSx Script Support' started by LNicol90, Aug 20, 2014.

  1. LNicol90

    LNicol90 Veteran Veteran

    Messages:
    30
    Likes Received:
    2
    First Language:
    English
    Hello everyone

    I'm using Falcao's Pearl ABS liquid V3 script in my game. I was almost finished with it, and I played through the game for a final check. I then discovered that none of the weapons damaged the enemies.

    As per advised in the "Helping others help help you" post, I moved all necessary pieces into a new game file. I copied over the database, nothing more, and suddenly I couldn't damage the enemies again. But, on a third file, I copied nothing over but the script but added the bare minimum of items manually, and the system works.

    Here is the game file where I repeated my problem:

    http://www.mediafire.com/download/r1yn14a37183x2y/Falcao+issue.exe

    And this is the second game file where I didn't repeat it:

    http://www.mediafire.com/download/281xcis54b527k0/take+x.exe

    I can't see a difference between the two databases, other than me deleting what I don't need in the first file and leaving them in the second. And the only difference between the maps is that I added behaviour to the enemies in the second file and not the first.

    Can anyone tell me what I done wrong and what the difference is between the two?

    Thanks in advance

    LNicol90
     
    #1
  2. Andar

    Andar Veteran Veteran

    Messages:
    28,703
    Likes Received:
    6,600
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    I didn't check your games, but most probably this is the key:

    Most probably you deleted something that you only believed to be not needed without realising that Falcao's engine does need that.
    I suggest making a copy of the variant that still works, and then starting to delete what you don't need - checking after every part of things.


    When suddenly the game stops working, then you'll know that your last step destroyed the needed data. Go back that step and start checking that part in more detail, until you locate the problem.
     
    #2
  3. LNicol90

    LNicol90 Veteran Veteran

    Messages:
    30
    Likes Received:
    2
    First Language:
    English
    Thanks for the advice, Andar. You were right.

    My problem was that I wasn't using skills and had erased them all, and as you guessed the script doesn't like that.

    For anyone else who reads this post: Keep at one item of usable data of every database page (filled with parameters and commands that make it useful).

    Can this thread please be closed.

    Thanks again Andar.

    LNicol90
     
    #3

Share This Page