For some reason, my switches are always on

Discussion in 'Javascript/Plugin Support' started by Alphey4406, Nov 30, 2018.

  1. Alphey4406

    Alphey4406 Villager Member

    Messages:
    14
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    Every time i open my game, all of the switches are on.

    I think it has to do with pluigns.

    Here is my plugin list:

    bandicam 2018-11-27 17-24-56-813.jpg
     
    #1
  2. Isabella Ava

    Isabella Ava Veteran Veteran

    Messages:
    635
    Likes Received:
    756
    First Language:
    English
    Try turn off plugins one by one to see which one caused the problem?
     
    #2
    Aloe Guvner likes this.
  3. Shaz

    Shaz Veteran Veteran

    Messages:
    37,932
    Likes Received:
    11,598
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    Try turning off ALL the plugins to see if it's actually a plugin problem. Sounds more like you might have an event set up that turns them all on.

    Are they ALL on? Or just SOME of them?


    mmm ... That HimeSyncSaveData might be a suspect, especially if you've already saved a game where they're all on.

    Next time you take a screenshot, use Alt + PrintScreen. That will capture the active window and not your entire desktop, making it easier to read. The text in the plugin list is a bit small because of all the background.
     
    #3
  4. Alphey4406

    Alphey4406 Villager Member

    Messages:
    14
    Likes Received:
    0
    First Language:
    English
    Primarily Uses:
    RMMV
    i discovered the plugin responsible for the problem. the OrangeOverlay plugin (for some reason)

    Do you know what plugins it is not compatible with?

    i use the HimeSyncSaveData Plugin for my title screen, and it is not the problem. even when there is no file, the problem still happens. Plus i tried turning off all of my plugins and the problem was fixed.
     
    Last edited by a moderator: Nov 30, 2018
    #4
  5. slimmmeiske2

    slimmmeiske2 Little Red Riding Hood Moderator

    Messages:
    5,736
    Likes Received:
    4,171
    Location:
    Belgium
    First Language:
    Dutch
    Primarily Uses:
    RMXP
    @Alphey4406 I've merged your posts together. Please use the 'Edit' button in the future if you want to add something to your last post.
     
    #5
  6. mlogan

    mlogan Global Moderators Global Mod

    Messages:
    13,899
    Likes Received:
    7,681
    Location:
    Texas
    First Language:
    English
    Primarily Uses:
    RMMV
    I'm going to move this to Plugin Support, since that is what we are dealing with.
     
    #6
  7. Shaz

    Shaz Veteran Veteran

    Messages:
    37,932
    Likes Received:
    11,598
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    RMMV
    I cannot imagine that plugin would be the cause, unless you have not configured it correctly for switches. Despite what the name might imply, plugins are not just plug-n-play. You have to edit the parameters to customise it to your needs. If it uses switches 1, 2 and 3 by default (most plugins use the lower numbered switches), and you are using those for something different, then you need to tell it to use different switches. And you need to name those switches in your project so you don't use them for something else.

    You also completely ignored the questions I asked you.
     
    #7

Share This Page