Announcement Forum Update - February 2, 2021

Archeia

Level 99 Demi-fiend
Staff member
Developer
Joined
Mar 1, 2012
Messages
15,369
Reaction score
15,838
First Language
Filipino
Primarily Uses
RMMZ
Thank you for your patience! The newest forum update is here!
If you find any issues, please report it here and we'll fix as soon as we are able!

What's New?
  • Upgraded to the latest forum software for security reasons.
  • Themes has been updated to support new forum software.
  • Profile Banners.
  • There are now 2 featured threads blocks.
Known Issues (General)
  • Preview thread no longer puts you to another page for focused posting. We are still investigating if this is part of the new update.
  • Badges no longer appear below user and will be fixed once the plugin is updated.
  • On some elements, hyperlinks don't get underlined or change colors, please let us know if you encounter some of them!
Known Issues (RMW - Light)
  • When you highlight text on opening post, the highlight color is still too light.
Known Issues (RMW - Dark)
  • Certain sections of the forums have a strong bg color that makes it unsuitable for typing.
Fixed Issues (RMW - Dark)
  • Highlight color is broken on some themes (Dark Theme for example).
  • Hover effect is now disabled.
 
Last edited:

Bendyizzt

The Radionist
Veteran
Joined
Dec 15, 2020
Messages
392
Reaction score
494
First Language
English
Primarily Uses
Other
Thanks for telling us Cat friend...
 

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
8,706
Reaction score
5,754
First Language
Dutch
Primarily Uses
RMXP
Hey Archeia, the highlight color is now broken (barely visible) on the light theme.
 

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
8,706
Reaction score
5,754
First Language
Dutch
Primarily Uses
RMXP
On the RMW Light theme, when trying to type a post, it looks like this:
highlight.png
I really have to squint to see what my cursor highlighted.
 

Bendyizzt

The Radionist
Veteran
Joined
Dec 15, 2020
Messages
392
Reaction score
494
First Language
English
Primarily Uses
Other
Oh, I thought that was added by you guys, yes, I see it too, the letters are light blue when I type...but then it's black when I push enter...
 

Zyhond

Villager
Member
Joined
Jan 22, 2021
Messages
22
Reaction score
32
First Language
chinese
Primarily Uses
RMMZ
Hello, I would like to ask how to add pictures from my computer. Isn’t it troublesome to use links? Please guide me

edit:
I think I found the function of dragging and uploading pictures here. Sorry, excuse me
thank you @slimmmeiske2
 
Last edited:

TheoAllen

Self-proclaimed jack of all trades
Veteran
Joined
Mar 16, 2012
Messages
6,248
Reaction score
7,635
First Language
Indonesian
Primarily Uses
RMVXA
I appreciate that the dark theme is better than it was before.
Great work.
 

slimmmeiske2

Little Red Riding Hood
Global Mod
Joined
Sep 6, 2012
Messages
8,706
Reaction score
5,754
First Language
Dutch
Primarily Uses
RMXP
@Zyhond You can already add images from your computer. Just click on the picture icon (left of the :) ) and click on the top left icon to upload your image directly.

@Bendyizzt The text color isn't my issue, it's the fact you can't see that I highlighted some of those words.
 

ShadowDragon

Realist
Veteran
Joined
Oct 8, 2018
Messages
4,121
Reaction score
1,572
First Language
Dutch
Primarily Uses
RMMV
I notice 2 things from white and dark theme.

1) white theme, "links" to website/@ someone are light blue, dark theme = white.

2) The icons like B, I, TT, and other stuff on white theme has 2 lines, while dark has 1.

3) on account details, White theme is account and setting NOT visible if it's
a link or not, but its green on dark theme which is visible.

I dont see any things at this points, but that is so far what I found.
I think White Theme "links or @" can be a bit darker blue, as for darktheme,
light blue or greenish as well (instead of white).
 

mephet

Veteran
Veteran
Joined
Dec 3, 2020
Messages
34
Reaction score
67
First Language
English
Primarily Uses
RMMV
Since the update messages seem to kind of bob up and down when hovering the cursor over them - is there a way to switch that off? Finding it quite distracting. (However, great to see the previous problems fixed! The forum looks nice :))
 

Kokoro Hane

Overly Ambitious
Veteran
Joined
Dec 11, 2013
Messages
268
Reaction score
232
First Language
English
Primarily Uses
RMVXA
Profile banner, hmmm... gonna have to try this new feature!

Curious.... any recommended size for banners?
 

Bastrophian

The Pixel Heartist!
Veteran
Joined
Oct 26, 2013
Messages
3,833
Reaction score
2,105
First Language
English
Primarily Uses
Other
@Archeia - Theres a Swift Logo where the Rpg maker Logo should go on the swift theme

EDIT: ...Sorry, more specifically, its the default Swift theme.
 

TheGentlemanLoser

"And when we fall, we will fall together..."
Veteran
Joined
Dec 30, 2020
Messages
268
Reaction score
290
First Language
English
Primarily Uses
RMMV
HUZZAH! Oh edit bar how I've missed you!
 

TheoAllen

Self-proclaimed jack of all trades
Veteran
Joined
Mar 16, 2012
Messages
6,248
Reaction score
7,635
First Language
Indonesian
Primarily Uses
RMVXA
I just realized that there is a motion when hovering posts in a dark theme (just like when it was when the first time forum was updated). It doesn't happen in light theme.
 

mlogan

Global Moderators
Global Mod
Joined
Mar 18, 2012
Messages
16,076
Reaction score
8,913
First Language
English
Primarily Uses
RMMV
Is the Swift Default theme gone? I liked that one.
 

SpyreStudio

Veteran
Veteran
Joined
Aug 9, 2019
Messages
36
Reaction score
14
First Language
English
Primarily Uses
RMMV
Small thing, but figured I'd mention it, the
[TABLE]
[TR]
[TD][/TD]

[TD][/TD]
[/TR]
[TR]
[TD]'<title>Announcement - Forum Update - February 2, 2021 | RPG Maker Forums</title>'[/TD]
[TD][/TD]
[/TR]
[TR]
[TD][/TD]

[TD][/TD]
[/TR]
[/TABLE]
is missing the tab icon for RPG Maker Forum or it isn't linked up properly.
 

Archeia

Level 99 Demi-fiend
Staff member
Developer
Joined
Mar 1, 2012
Messages
15,369
Reaction score
15,838
First Language
Filipino
Primarily Uses
RMMZ
Is the Swift Default theme gone? I liked that one.

Still fixing it dw i just disabled it for time being to remove some stuff.

I just realized that there is a motion when hovering posts in a dark theme (just like when it was when the first time forum was updated). It doesn't happen in light theme.


Yeah i noticed it and will fix it soon
 

Latest Threads

Latest Posts

Latest Profile Posts

So the number one complaint I get so far is the levels are simply too large. What's funny is in testing I deemed levels taking too long and actually shortened them. Figuring I could beat them in 5-6 minutes so players would be able to do so in probably double that. I was apparently very mistaken, only one player has mentioned even reaching the second area. Let alone the first boss. :kaoswt:
I don't believe it. I actually did some proofreading in my game - and fixed some grammar errors! I feel so accomplished, knowing I can actually proofread my own writing!
...I've had a bad day, okay? Bad enough for me to want to proofread stuff. :yswt2:
Ughhh, July is not my month. Thankfully, it's nearly done.
mercba30 wrote on Jesse - PVGames's profile.
How do I get the new version of the character creator? Thank you in advance!

I fixed the lips and noses for MZ! The files have been updated.
qQwgk8C.png

Everything below!
Ugh, I opened MV after a few weeks and I'm completely lost on what I was working on.
Does it happen to someone else or am I the only disorganized one around? :kaoswt:
xH5Fk2f.jpg

Forum statistics

Threads
113,674
Messages
1,076,583
Members
147,694
Latest member
ProjectElpizo
Top