Framedrops / Low Framerate in Editor

Maronius

Villager
Member
Joined
Oct 29, 2015
Messages
21
Reaction score
4
Primarily Uses
Hello Everyone,

I bought a new PC and for some unknown reasons I get very low framerates in the RPGMaker MV Editor itself. Playtesting works perfect (160 fps on my 160 fps G-Sync monitor) but while using the RPG Maker Editor, the framerate drops to 20 - 30 frames for several seconds and then jumps back to 160 fps and so on. The Nvidia driver is the latest available.

This also happens on the Bethesda Game Launcher, so it's most problably not RPGMaker specific, but I hope someone got an idea how to fix this. All other Game Launchers (Steam, Epic games, Uplay) are 160 fps constant, so I'm a little bit out of ideas what could be the reason for this framedrops on the RPG Maker and the Bethesda Game Launcher (maybe they have something in common?).
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
33,873
Reaction score
8,585
First Language
German
Primarily Uses
RMMV
It is extremely unlikely that those programs have something in common.

I can think of two causes for this behaviour:
1) you have a background program that temporarily blocks those two programs before giving them an OK.
Most likely that would be an antivirus or similar that does not have those two programs confirmed in its own database, requiring to go to heuristic mode for them.
One solution would be to whitelist those two programs in that protection program.

2) resource load delay
no matter what program, a resource needs to be completely loaded before it can be used. And unless you have everything on SSD (and sometimes even then) larger pictures (like when using a parallax background on the map with display in editor active) will take some time and RAM to load.
 

Maronius

Villager
Member
Joined
Oct 29, 2015
Messages
21
Reaction score
4
Primarily Uses
Hi again,

I found the solution in the NVidia Forum. It's the geforce driver version 460.xx which is causing the problem with framedrops in several applications. There's a hotfix to version 460.97 which I just installed and now the RPGMaker works fine again.

So if someone else got this problem this is the solution :)
 

Latest Threads

Latest Posts

Latest Profile Posts

I've been busy trying out different art styles for my game.

Enemies deserve some spotlight also
hackingCompressed.gif
I think I can make a text-based mini-game with almost zero art assets and with code only...just a lot of code as assets all by themselves. :kaojoy:
A video update on the progress I've been making on the cutscenes. :kaosalute:

I wonder if color LUTs is possible for RPG Maker. It would be game changer and can replace the not so good looking tint screen

Forum statistics

Threads
115,866
Messages
1,093,580
Members
151,096
Latest member
RPGThrowawaymaker
Top