FROZEN! Problem with my game?!?!

Cqualt

Veteran
Veteran
Joined
Jul 15, 2019
Messages
74
Reaction score
6
First Language
English
Primarily Uses
RMMV
Hey guys so long story short i cannot for the life of me understand why my game is not continuing , its the start of the game

there is a scene before this with an autorun and then it transfers to "Home" then a small cut scene plays PERFECTLY and then towards the end everything happens.. as shown it fades out transfers transparency is off and fades back in fine and Switch A to flip to the next page which is Below characters>Action button>Self Switch A is ticked.

but as your suppose to receive control of the character it is frozen. cannot enter menu, cannot walk.
Tileset has been marked "o" so tiles can be walked on, i also transfered to a complete different map with grass and still frozen and cannot walk or enter menu, i even transfered player into a new area with NO AUTORUN and it is still frozen as if i cant move or enter menu again.

POSITIVE: the only positive i can give is when transfering to "home" from the intro screen, Without the Autorun happening(Without the cutscene) it walks and interacts.... i have NO idea how to fix this, any ideas? am i doing something wrong?

REALLY APPRECIATE IT THANK YOU!!!!
 

Attachments

  • autorunproblem.png
    autorunproblem.png
    257.1 KB · Views: 9
  • autorunproblem1.png
    autorunproblem1.png
    548.1 KB · Views: 9
  • autorunproblem2.png
    autorunproblem2.png
    539.7 KB · Views: 9
  • autorunproblem3.png
    autorunproblem3.png
    521.7 KB · Views: 9
  • autorunproblemx.png
    autorunproblemx.png
    267.5 KB · Views: 9
  • autorunproblemxx.png
    autorunproblemxx.png
    186.1 KB · Views: 11

mlogan

Global Moderators
Global Mod
Joined
Mar 18, 2012
Messages
16,008
Reaction score
8,897
First Language
English
Primarily Uses
RMMV

I've moved this thread to MV Support. Please be sure to post your threads in the correct forum next time. Thank you.


(If this should be MZ Support instead, let me know, I wasn't certain.)

Since you don't show the whole of event page 1, are you sure you actually turned on the self-switch? I only ask, because overlooking such a detail is something I absolutely would do.
 

Cqualt

Veteran
Veteran
Joined
Jul 15, 2019
Messages
74
Reaction score
6
First Language
English
Primarily Uses
RMMV
[move]MV Support[/move]
(If this should be MZ Support instead, let me know, I wasn't certain.)

Since you don't show the whole of event page 1, are you sure you actually turned on the self-switch? I only ask, because overlooking such a detail is something I absolutely would do.
sorry my apologies i accidently uploaded the wrong screen shot, ive fixed now ill also post here
 

Attachments

  • autorunproblem.png
    autorunproblem.png
    257.1 KB · Views: 6

mlogan

Global Moderators
Global Mod
Joined
Mar 18, 2012
Messages
16,008
Reaction score
8,897
First Language
English
Primarily Uses
RMMV
What is happening in the event in the top left?
 

Cqualt

Veteran
Veteran
Joined
Jul 15, 2019
Messages
74
Reaction score
6
First Language
English
Primarily Uses
RMMV
[move]MV Support[/move]
(If this should be MZ Support instead, let me know, I wasn't certain.)

Since you don't show the whole of event page 1, are you sure you actually turned on the self-switch? I only ask, because overlooking such a detail is something I absolutely would do.
I have uploaded the entire cutscene

"transfers from intro to cutscene" then cutscene happens, then cutscene suppose to stop and player can play

The event in the top left is the Autorun event being shown
 

mlogan

Global Moderators
Global Mod
Joined
Mar 18, 2012
Messages
16,008
Reaction score
8,897
First Language
English
Primarily Uses
RMMV
Oh, haha, the top left is the one you've posted, I was thinking it was a different event. I have to get going, so I can't look closely at the moment, maybe someone else will be able to spot the problem, but if not, I'll try to look again when I get back.

Do you have any plugins that might effect this?
 

Sword_of_Dusk

Keyblade Master
Veteran
Joined
Sep 13, 2015
Messages
374
Reaction score
413
First Language
English
Primarily Uses
RMMV
Where exactly is the freeze happening? Do you successfully transfer to the new map, fade in, then have no control? What map are you leaving and do you have any stray events on the map you're transferring to that might cause issues?
 

Dev_With_Coffee

Veteran
Veteran
Joined
Jul 20, 2020
Messages
445
Reaction score
195
First Language
PT-BR
Primarily Uses
RM2k3
It is not possible to analyze such a problem just by describing some details.
It would be better to compress the "data" folder and graphics (not standard) into a ZIP or RAR file and attach them here.
The graphics I refer to are those made by the generator or downloaded:
Data Folder:
Database files
Maps info files
Maps

IMG Folder:
characters\used in map

It's easier for you to send
And it is easier for those who download.

  • MediaFire
  • Google Drive (You need to make the file public after upload)
  • OneDrive (You need to make the file public after upload)
  • mega.nz
  • Dropbox
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,195
Reaction score
14,663
First Language
English
Primarily Uses
RMMV
If you are transferred to the new map and all of the event has finished playing (screen fades back in, any text is shown) and you still can't move or access the menu, it usually means you have another event somewhere that's set to autorun. This will be either an event on the new map, or a common event, with an autorun trigger - even if there are no commands.

The other possibility is that you've half way through a move route (or an event on the new map is trying to do a move route) with the Wait option set, and there is an event or an impassible tile in the way. Events can't move through other events, regardless of the priority, and the player can't move through an event with Same as Characters priority, unless one of them has THROUGH turned on.
 

Cqualt

Veteran
Veteran
Joined
Jul 15, 2019
Messages
74
Reaction score
6
First Language
English
Primarily Uses
RMMV
i think you would of had a very close answer to the problem, ive fixed the issue first of all i'd like to say thank you to everyone who tried to help me with this problem today and giving me your times im very grateful

The coding was perfect, everything was completely fine.
THE PROBLEM? : Friend Bust In Control Switch> Why? Literally broken. it is #1 in all control switches and i also remember in my last game i created #1 was broken for no reason literally crashed whole game for a reason i have no idea why and had no interaction with anything to do with anything. so very strange.... Control switch #1 was just simply broken. that is the best outcome considering it happened last game file i can come up with

as soon as i removed it from script perfect game. just thought i'd post it here incase it helps anyone?
If you are transferred to the new map and all of the event has finished playing (screen fades back in, any text is shown) and you still can't move or access the menu, it usually means you have another event somewhere that's set to autorun. This will be either an event on the new map, or a common event, with an autorun trigger - even if there are no commands.

The other possibility is that you've half way through a move route (or an event on the new map is trying to do a move route) with the Wait option set, and there is an event or an impassible tile in the way. Events can't move through other events, regardless of the priority, and the player can't move through an event with Same as Characters priority, unless one of them has THROUGH turned on.
 

Jules98

Veteran
Veteran
Joined
Jul 10, 2017
Messages
337
Reaction score
221
First Language
Dutch
Primarily Uses
RMMV
The coding was perfect, everything was completely fine.
THE PROBLEM? : Friend Bust In Control Switch> Why? Literally broken. it is #1 in all control switches and i also remember in my last game i created #1 was broken for no reason literally crashed whole game for a reason i have no idea why and had no interaction with anything to do with anything. so very strange.... Control switch #1 was just simply broken. that is the best outcome considering it happened last game file i can come up with
Check your plugins. It sounds like one of them is using Switch #1 for something, which is what's causing problems.
 

Shaz

Global Moderators
Global Mod
Joined
Mar 2, 2012
Messages
42,195
Reaction score
14,663
First Language
English
Primarily Uses
RMMV
Switch #1 is never broken. But it is often the cause of issues if you add plugins and don't configure them properly. You've always got to check plugin parameters and see if they use any switches or variables, and make sure you're not using them for something as well - if you aren't, you need to give them names so you don't accidentally use them; if you are, you need to change the plugin to use a different one - and then name it.
 

Latest Threads

Latest Posts

Latest Profile Posts

How would you judge a game you played? Art/Graphics? Story? Gameplay?
Learn MV sales goal = 2%
NSFW game sales goal = 2500% (no jokes) :guffaw:
After gathering, sorting out & reconsidering hundreds of enemy battlers over the last two das, finally my favorite part begins: Inventing names and lore for them all :D
I'm running a sale for Learn RPG Maker MV on Itch.io, can I compete with NSFW games earning goals?

Forum statistics

Threads
111,375
Messages
1,060,574
Members
144,706
Latest member
DonTonyPepperoni
Top